Finalise Ubuntu Font Family licence/distribution terms

Reported by Paul Sladen on 2010-09-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
High
Unassigned
Ubuntu Font Licence
Undecided
Unassigned

Bug Description

In order for any .deb packages to be presented for potential uploading to the main Ubuntu archives ('universe'/'main') the licensing will need to be clarified/finalised to something DFSG-ish (Ubuntu has slightly different requirements to Debian but they are fairly similar). The Ubuntu Font Family is released for the present under the Ubuntu Font Licence 1.0:

  https://launchpad.net/ubuntu-font-licence

For the phased beta/development stages, the Ubuntu Font Family has been distributed under both internal, and latterly non-NDA licensing terms via the PPAs. This bug report is a placeholder to track what needs doing on a _technical level_ once any high-level decision/choice/etc has been assessed/finalised at some point. Following finalisation of any licensing decision the font family will need further updates to adjust in various places:

  1. in the .ttfs (probably best to get DM to undertake this, although it could be done retrospectively as the TTF data is structured)
  2. in the .deb package's 'debian/copyright' file.
  3. relevant wiki pages, eg. https://wiki.ubuntu.com/Ubuntu%20Font%20Family
  4. fonttest.design.canonical.com
  5. any press/notices/blogs on the subject (DM, Mark, Fridge, UWN, DX Team blog, Canonical, ...)
  6. please click edit and extend this list!

Paul Sladen (sladen) on 2010-09-07
Changed in ubuntu-font-family:
status: New → Confirmed
Paul Sladen (sladen) on 2010-09-07
summary: - Finalise <1.0 Ubuntu Font Family licence/distribution terms
+ Finalise Ubuntu Font Family licence/distribution terms
tags: added: uff-10.10-todo
Paul Sladen (sladen) on 2010-09-08
Changed in ubuntu-font-family:
milestone: none → 0.7.0
Paul Sladen (sladen) on 2010-09-13
Changed in ubuntu-font-family:
milestone: 0.6.7 → 0.7.0
Paul Sladen (sladen) wrote :

On a related-note, bug #648406 notes that the DRMish bits need clearing.

tags: added: ttf-licence ttf-metadata
Nicolas Spalinger (yosch) wrote :

Metadata in the sources (vfb, hinting ttfs, text sources) also needs to be double-checked and synced.

Paul Sladen (sladen) wrote :

The upstream packaging is done by unpackaging:

  http://font.ubuntu.com/download/ubuntu-font-family-sources_0.68+ufl.diff

to the .zip file drop from Dalton Maag. The additions to the Makefile here would be:

  * execute 'patch-truetype' over the VTT .ttfs
  * investigate the .vfb format and work out how to patch that internally
  * Prepend a filled out 'copyright.txt' to the CacheTT .cfg

Any others? For the result of these will be a new upstream-tarball, and can (post-RC, on Thursday) be used to upload a new package.

Changed in ubuntu-font-family:
status: Confirmed → In Progress
assignee: nobody → Paul Sladen (sladen)
status: In Progress → Confirmed
Paul Sladen (sladen) on 2010-09-29
Changed in ubuntu-font-family:
importance: Undecided → High
Paul Sladen (sladen) wrote :

ubuntu-font-family-sources (0.68+ufl-0ubuntu1) maverick; urgency=low

  * New upstream release 0.68+ufl: (LP: #629622, #633508)
    - Libre font, licensed under the Ubuntu Font Licence 1.0 (LP: #632411)

  * New upstream release 0.68:
    - All
      + Version numbering agreed (LP: #633176, #629727)
      + The glyph at Unicode x1F5d was changed in all fonts, i.e. change
        of commaaccent in Greek glyph
      + Updated OS/2 table Strikethrough and 'post' table underline
        values to match thickness of underscore.
    - Italic / Bold Italic
      + The feminineordinal in the Italic now follows the design of
        the a, it has been updated and hinted.

  * New upstream release 0.67:
    - All
      + Version number forwarded to 0.67
    - Regular
      + Hinting adjustments for 15 - 18 ppm
      + Greek glyph uni1F5D has accent corrected.
      + Hinting amends for lowercase v, w and y in sizes 30 - 42
      + hdmx table include 120dpi ranges (LP: #608823)
      + Hinting amended to adjust for Freetype hint
        implementation. (LP: #614693)
    - Italic
      + Greek glyph uni1F5D has accent corrected.
    - Italic / Bold Italic:
      + lowercase f redesigned. (LP: #623925)
      + ae dipthong redesigned. (LP: #621157)

 -- Paul Sladen <email address hidden> Tue, 28 Sep 2010 06:00:00 +0100

description: updated
Changed in ubuntu-font-family:
assignee: Paul Sladen (sladen) → nobody
milestone: 0.70 → 0.68
status: Confirmed → Fix Released
Paul Sladen (sladen) on 2010-09-30
Changed in ubuntu-font-licence:
status: New → Fix Released
Nicolas Spalinger (yosch) wrote :

In version 0.69, the various files in sources/ still need licensing information to be applied in their metadata and headers.

Paul Sladen (sladen) wrote :

Yup, there's no documentation (on style-decisions/direction) either, a few issues in the FONTLOG and because of the last-minute patching broken digital signatures in the DSIG table.

My current idea/intent is (after the stress of the Ubuntu 10.10 release) we try to get a "perfect" distribution made of what we've already got, signed and with all the documentation/source licence fixes, and have Dalton Maag put that out as 0.70. Does this make sense?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers