Diacritcal: Ö and Ü have different height umlaut to other umlauts

Bug #614693 reported by ferguweb on 2010-08-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Undecided
Unassigned

Bug Description

Rendered in 20pt Italic

Sample Glyphs:

Description:

Rendered on screen in Ubuntu Beta by Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

I've tested diaresis sign in all five lower and capital vocals and I found differences in the height of the sign over the lower "i" and capitals "O" and "U" compared with the rest of the vocals.

UA String:

Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

Revision history for this message
Paul Sladen (sladen) wrote :

Please could you attach a screenshot.

Changed in ubuntufontbetatesting:
status: New → Incomplete
visibility: private → public
Revision history for this message
ferguweb (ferguweb) wrote :

Hi Paul,
I've attached a screenshot displaying the affected characters.
Cheers

Revision history for this message
Malcolm Wooden (malcolm-daltonmaag) wrote :

Latest version does not appear to have the problem.

Changed in ubuntu-font-family:
status: Incomplete → Fix Released
Revision history for this message
Paul Sladen (sladen) wrote :

ferguweb: can you confirm that it's fixed on your setup in the latest version too?

Revision history for this message
ferguweb (ferguweb) wrote :

Hi Paul,
Lower ï seems solved for me, while Ö and Ü (capital letters) still have a minor difference (really hard to see, but still it is). I'm attaching a screenshot.
Cheers,

Paul Sladen (sladen) on 2010-08-21
tags: added: uff-diacritcals
summary: - Diaresis sign in lower i and capitals O and U have a different height
- than in the rest of the vocals
+ Diacritcal: Ö and Ü have different height umlaut to other umlauts
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 614693] Re: Diaresis sign in lower i and capitals O and U have a different height than in the rest of the vocals

Agreed, it's definitely still visibly off.

 status triaged

Mark

Changed in ubuntu-font-family:
status: Fix Released → Triaged
Revision history for this message
Paul Sladen (sladen) wrote :

Viewing the sequence 'äëïöüÿÄËÏÖÜ' at very small point sizes (where the height of the umlaut is under 2 pixels) shows that some of the character have heavier part of the umlaut as the bottom pixel of the umlaut, and some have the top pixel being heavier.

Based on that, I'm unsure that hinting is the cause, but it might be that in the unadorned glyph there is a misalignment in the placement of the diacritical sub-glyph.

Paul Sladen (sladen) on 2010-08-21
tags: added: uff-diacritcal
removed: uff-diacritcals
Ivanka Majic (ivanka) on 2010-09-01
Changed in ubuntu-font-family:
assignee: nobody → Shiraaz Gabru (shiraaz)
Revision history for this message
Shiraaz Gabru (shiraaz) wrote :

Hinting amended to adjust for Freetype hint implementation.

Changed in ubuntu-font-family:
milestone: none → 0.6.7
status: Triaged → Fix Released
Revision history for this message
Paul Sladen (sladen) wrote :

ubuntu-font-family-sources (0.68+ufl-0ubuntu1) maverick; urgency=low

  * New upstream release 0.68+ufl: (LP: #629622, #633508)
    - Libre font, licensed under the Ubuntu Font Licence 1.0 (LP: #632411)

  * New upstream release 0.68:
    - All
      + Version numbering agreed (LP: #633176, #629727)
      + The glyph at Unicode x1F5d was changed in all fonts, i.e. change
        of commaaccent in Greek glyph
      + Updated OS/2 table Strikethrough and 'post' table underline
        values to match thickness of underscore.
    - Italic / Bold Italic
      + The feminineordinal in the Italic now follows the design of
        the a, it has been updated and hinted.

  * New upstream release 0.67:
    - All
      + Version number forwarded to 0.67
    - Regular
      + Hinting adjustments for 15 - 18 ppm
      + Greek glyph uni1F5D has accent corrected.
      + Hinting amends for lowercase v, w and y in sizes 30 - 42
      + hdmx table include 120dpi ranges (LP: #608823)
      + Hinting amended to adjust for Freetype hint
        implementation. (LP: #614693)
    - Italic
      + Greek glyph uni1F5D has accent corrected.
    - Italic / Bold Italic:
      + lowercase f redesigned. (LP: #623925)
      + ae dipthong redesigned. (LP: #621157)

 -- Paul Sladen <email address hidden> Tue, 28 Sep 2010 06:00:00 +0100

Changed in ubuntu-font-family:
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
assignee: Shiraaz Gabru (shiraaz) → nobody
Revision history for this message
Shiraaz Gabru (shiraaz) wrote :

The variable way that Freetype interpret hints (against Windows GDI) causes some rasterising variations. Hinting of some glyphs has been amended to compensate for these effects.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers