Kerning/Hinting: 'N-o' too widely spaced at 24pt

Bug #608823 reported by Adam Gundy on 2010-07-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Low
Unassigned

Bug Description

Rendered in 24pt Regular

Sample Glyphs:

No

Description:

kerning between 'N' and 'o' too wide

UA String:

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.6) Gecko/20100630 Ubuntu/8.04 (hardy) Firefox/3.6.6

Paul Sladen (sladen) wrote :

Please could you attach a screenshot showing exactly what you're seeing with the sequence 'N-o'.

visibility: private → public
summary: - kerning
+ Kerning/Hinting: 'N-o' too widely spaced at 24pt
Changed in ubuntufontbetatesting:
status: New → Incomplete
Adam Gundy (adam-starsilk) wrote :

first two letters.. also looks like g-o is having slight issues to (bottom left).

this is hardy, with firefox 3.6.7 (no truetype hinting?)

Ivanka Majic (ivanka) on 2010-09-01
Changed in ubuntu-font-family:
status: Incomplete → Confirmed
assignee: nobody → Shiraaz Gabru (shiraaz)
importance: Undecided → High
Paul Sladen (sladen) wrote :

The spacing of 'No' could also be a side-effect of bug #617522 where the browsers are not using some of the more extensive font metrics/kerning information at sizes >20px.

Adam Gundy (adam-starsilk) wrote :

just tried the online font test again, still looks broken to me. I checked with firebug and the 'optimizelegibility' flag is definitely set...

Adam Gundy (adam-starsilk) wrote :

hmm. looks good at 22pt, but 24pt and above don't kern. looks like a firefox bug.

Changed in ubuntu-font-family:
milestone: none → arabic-beta-available
Changed in ubuntu-font-family:
milestone: arabic-beta-available → none
Shiraaz Gabru (shiraaz) wrote :

The problem is probably due to device metrics not being calculated for 40ppm. Looking into this now.

Shiraaz Gabru (shiraaz) wrote :

The 'hdmx' and tables generated by cachett.exe have been included for 120dpi, which should solve this problem.

Changed in ubuntu-font-family:
milestone: none → 0.68
status: Confirmed → Fix Committed
Shiraaz Gabru (shiraaz) on 2010-09-16
Changed in ubuntu-font-family:
milestone: 0.68 → 0.67
status: Fix Committed → Fix Released
Adam Gundy (adam-starsilk) wrote :

still looks just as broken to me, using the http://fonttest.design.canonical.com/show page. looks fine at 22pt, broken at 24pt.

Paul Sladen (sladen) on 2010-09-16
Changed in ubuntu-font-family:
status: Fix Released → Fix Committed
Shiraaz Gabru (shiraaz) wrote :

Comments from my Colleague Malcolm Wooden.

This bug concerns the wide spacing between the N - o in the Firefox screenshot now.png attached. This persons screen resolution is 120dpi and is using Ubuntu 8.04. The nearest I could get to duplicating this in Firefox on my Ubuntu system is shown on the screenshot DM_now.png. the system info on the ubuntu system I have is:
Rendered in Ubuntu Beta by Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.10) Gecko/20100916 Ubuntu/10.10 (maverick) Firefox/3.6.10
This is using the latest release of the Ubuntu Regular font. There does not appear to be the same spacing problems as is shown in now.png.

It seems that Firefox does not use the rasteriser display setting from the systems 'Appearence Preferences' but uses it own configuration file for controlling the rasterising of fonts. It looks like the DM_now.png file is using no RGB subpixeling and only minimal hinting. It also seems that if the user has enough knowledge of the Ubuntu system and the Firefox installation they can change the configuration file used by Firefox if they so wish.

The nearest I could get to the now.png image is the From_gedit.png screenshot. This is using the Ubuntu text editor Gedit with the system Appearance Prefs set to Subpixel RGB and Full Hinting. Again there does not seem to be the same problem with the spacing as in now.png

Many of these spacing glitches are outside our control when Users and Applications can make changes to the basic setting of the font rasteriser.

Changed in ubuntu-font-family:
status: Fix Committed → Incomplete
importance: High → Low
Shiraaz Gabru (shiraaz) wrote :
Shiraaz Gabru (shiraaz) wrote :
Paul Sladen (sladen) wrote :

ubuntu-font-family-sources (0.68+ufl-0ubuntu1) maverick; urgency=low

  * New upstream release 0.68+ufl: (LP: #629622, #633508)
    - Libre font, licensed under the Ubuntu Font Licence 1.0 (LP: #632411)

  * New upstream release 0.68:
    - All
      + Version numbering agreed (LP: #633176, #629727)
      + The glyph at Unicode x1F5d was changed in all fonts, i.e. change
        of commaaccent in Greek glyph
      + Updated OS/2 table Strikethrough and 'post' table underline
        values to match thickness of underscore.
    - Italic / Bold Italic
      + The feminineordinal in the Italic now follows the design of
        the a, it has been updated and hinted.

  * New upstream release 0.67:
    - All
      + Version number forwarded to 0.67
    - Regular
      + Hinting adjustments for 15 - 18 ppm
      + Greek glyph uni1F5D has accent corrected.
      + Hinting amends for lowercase v, w and y in sizes 30 - 42
      + hdmx table include 120dpi ranges (LP: #608823)
      + Hinting amended to adjust for Freetype hint
        implementation. (LP: #614693)
    - Italic
      + Greek glyph uni1F5D has accent corrected.
    - Italic / Bold Italic:
      + lowercase f redesigned. (LP: #623925)
      + ae dipthong redesigned. (LP: #621157)

 -- Paul Sladen <email address hidden> Tue, 28 Sep 2010 06:00:00 +0100

Changed in ubuntu-font-family:
assignee: Shiraaz Gabru (shiraaz) → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers