Finalise UFF family name eg. 'Ubuntu'/'UbuntuBeta'/something else

Reported by Paul Sladen on 2010-07-07
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Font Family
Wishlist
Unassigned

Bug Description

The UbuntuBeta (Maag) font is currently uncomfortable known as the "Ubuntu Font" font. This is likely to cause ambiguity issues with the main Ubuntu brand. When Ubuntu-related projects have been set up so far, they have been names distinct from "Ubuntu" alone, generally in the form "Ubuntu /Something/":

  "Ubuntu-Title", a font used for the first 5 years of branding
  "Ubuntu One", an online-services portfolio related to Ubuntu
  "Ubuntu Light Themes", default themes used on the Ubuntu desktop
  "Ubuntu Netbook Editiion", a version of the Ubuntu-system optimised for something else

When the seedlings of the Ubuntu project and Launchpad were forming, a great deal of care was taken to ensure that the corporate entity had an identity distinct from the product, and didn't just become "Ubuntu dot com" (the name "Canonical" being picked).

Ideally the new Maag-designed font could have its _own_ long-term (but associated) identity and suitably unambiguous name eg. "Ubuntu-Unity", "Ubuntu-Natural", "Ubuntu-Umiak", "Ubuntu-Union". Or perhaps even just "Uniformity" or "Unicorn".

(The name does not matter, just ideally that there is some definite postfix).

Paul Sladen (sladen) on 2010-07-07
visibility: private → public

IMHO trademark guidelines and reserved names for downstream branching are key issues to consider for this font: getting people to easily identify and trust the master branch through a well-known name but also allowing separate downstream branches marked as such to exist alongside and to contribute to extending the coverage and feature set for the wider Ubuntu community. A delicate balance but well worth getting right.

Might be interesting to consider Bantu reduplication as well: http://en.wikipedia.org/wiki/Reduplication#Bantu_languages

Paul Sladen (sladen) on 2010-07-12
summary: - Ubuntu Maag font lacks unique name-of-its-own
+ Ubuntu Maag font lacks unique name-of-its-own (eg. Ubuntu Sans)
Changed in ubuntufontbetatesting:
status: New → Incomplete
Paul Sladen (sladen) on 2010-07-16
Changed in ubuntufontbetatesting:
importance: Undecided → Wishlist

Ubuntu Maag - sounds cool enough to pull off a font name ;-)

Paul Sladen (sladen) wrote :

Preferred current terminology for the typeface seems to be heading towards "Ubuntu Font Family", with the individual released fonts themselves being "Ubuntu Regular"/"Ubuntu Italic"/"Ubuntu Bold"/"Ubuntu Bold Italic".

Paul Sladen (sladen) on 2010-09-07
tags: added: uff-10.10-todo
summary: - Ubuntu Maag font lacks unique name-of-its-own (eg. Ubuntu Sans)
+ Finalise UFF family name eg. 'Ubuntu'/'UbuntuBeta'/something else

I think the final plan is:

  Ubuntu
  Ubuntu Light
  Ubuntu Mono
  Ubuntu Condensed

Mark

Paul Sladen (sladen) on 2010-09-08
Changed in ubuntu-font-family:
milestone: none → 0.7.0
Paul Sladen (sladen) on 2010-09-13
Changed in ubuntu-font-family:
milestone: 0.6.7 → 0.7.0
Paul Sladen (sladen) wrote :

Patched in as part of the midstream .orig.tar.gz generation process from:

  http://font.ubuntu.com/download/ubuntu-font-family-sources_0.68+ufl.diff

Changed in ubuntu-font-family:
status: Incomplete → Fix Released
Paul Sladen (sladen) on 2010-09-30
Changed in ubuntu-font-family:
milestone: 0.70 → 0.68
Bdale Garbee (bdale) wrote :

What is the motivation for using the token 'Ubuntu' in this font family name?

Mark Shuttleworth (sabdfl) wrote :

Bdale, the font was designed with the Ubuntu project values in mind, and designed to be useful as the font for the wordmarks of both Ubuntu and Canonical. If you look at the current logo's of both, they are both designed with the glyphs that became the base for the font.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers