help.ubuntu.com search is not working without google javascript

Bug #310621 reported by markor on 2008-12-22
2
Affects Status Importance Assigned to Milestone
Ubuntu Documentation
Wishlist
Matthew East

Bug Description

I am using Ubuntu Hardy/8.04.1 LTS, amd64 , Firefox 3.0.5, together with Noscript extension and also
Seamonkey with Noscript extension.
However, *.ubuntu.com scripts are enabled and working.

Steps to reproduce:
Go to https://help.ubuntu.com Enter something to search in search box.
Result: There is no search result.
Expected behavior: Search results should be displayed.

Possible cause: During November, way of searching of Ubuntu Documentation is changed
to use external Google service.
If User enables Google JavaScript of .google.com then it is throwned back to customized Google page
with search results, instead of displaying search results inside help.ubuntu.com site.

If user is unwilling to use Google JavaScript, outside *.ubuntu.com it can never get search results for ubuntu documentation, like described. (Or Ubuntu documentation seems like not working)
Therefore this is a bug on a way of displaying search results to the user and have nothing to do with Google
itself.
Also I found any request to use any JavaScript outside https://*.ubuntu.com as a foolish misbehavior so this "solution" will not fix this bug.
Bug: https://bugs.launchpad.net/ubuntu-doc/+bug/299827 does not Fix itself and that bug is not a duplication
of this bug.

markor (markoresko) wrote :
markor (markoresko) wrote :

This is NOT duplication of the bug #299827.
I bug #299827 is about graphical elements on the page not displaying correctly
and I think I mentioned it in bug report!
This bug is about using External Java script on a page causing search results not displaying
for users NOT using external javascript.

So I think that Dougie Richardson is wrong setting this bug as a duplicate,
even the bug itself is saying is shouldn`t be mark as duplicate of that another bug!

markor (markoresko) wrote :

Fix Is NOT released for this bug and therefore it can`t be marked as duplicate
for another bug.
OR Fix for another bug does not adress issue on that bug?

Marko,

Bug tracking is a good way for us to manage our work-flow, please understand that this is the reason for merging these bugs. There is no point in raising a further bug when you have already raised the issue and discussed a solution, which is to be implemented in another bug. As one of the people to address your bug, I feel I'm better positioned to judge how I use the tracker!

We have discussed the issue at length and Matthew and Dustin have confirmed that the changes cannot be rolled out immediately.

Again, I feel the need to draw your attention to the Code of Conduct - I believe you have the link?

Matthew East (mdke) wrote :

Dougie - much as I don't like Marko's tone either, he is right that this isn't a duplicate. Unsetting.

Changed in ubuntu-doc:
assignee: nobody → mdke
importance: Undecided → Wishlist
status: New → In Progress
Matthew East (mdke) wrote :

The fix was rolled out a few weeks ago for the wiki theme at https://help.ubuntu.com/community, see http://bazaar.launchpad.net/~mdke/ubuntu-doc/helpwiki-newtheme/revision/39

Still some work to do for updating the static files on https://help.ubuntu.com

Matthew East (mdke) wrote :

I've committed a fix for this to the repository containing the static files for help.ubuntu.com, see revisions 16 and 17 here - https://code.launchpad.net/~mdke/ubuntu-doc/help.ubuntu.com

These changes will be rolled out to help.ubuntu.com in the next few days I hope.

Changed in ubuntu-doc:
status: In Progress → Fix Committed
Matthew East (mdke) wrote :

Now rolled out.

Changed in ubuntu-doc:
status: Fix Committed → Fix Released
markor (markoresko) wrote :

Thank you very much Matthew East for the job! and Dougie Richardson for contributing.
I just checked help.ubuntu.com and concluded that fix works for 2 scenarios:
1.All javascript is On - Works
2. All javascript is Off. - Works with error message (With Firefox/Seamonkey complaining every time about
sending request over insecure link. This deserves separate bug report after this one is fixed)
But,
in usage scenarios described in this bug description,
Fix does not results in Search working with displaying search results.
This are conditions:
3. All ubuntu.com javascript is On, Google.com javascripts are off. - Not working.

So bug fix does not fix this bug in terms of bug-explained usage scenario when user
trust and uses ubuntu.com javascripts but not use or run external javascript outside of ubuntu.com
as default setting.
Result: Search results not shown.

Should we set this bug not yet fixed until this bug is solved according to bug description?

Hi,

On Sun, Feb 8, 2009 at 5:37 AM, markor <email address hidden> wrote:
> 2. All javascript is Off. - Works with error message (With Firefox/Seamonkey complaining every time about
> sending request over insecure link. This deserves separate bug report after this one is fixed)

That isn't an error message - it's a warning for the user. Given that
the user is being transferred to a non-https website, it is entirely
proper.

> But,
> in usage scenarios described in this bug description,
> Fix does not results in Search working with displaying search results.
> This are conditions:
> 3. All ubuntu.com javascript is On, Google.com javascripts are off. - Not working.

I don't think that is a common enough use case for us to spend time on
it. The vast majority of users will have javascript enabled browsers.
The site works for those that don't. I think you are likely to be the
only person (or if not the only, one of a very few number indeed) who
permits certain javascripts and restricts others. Firefox itself
doesn't permit such a setup.

If you have evidence that large numbers of people have a setup like
this, then you can reopen the bug, but otherwise we can regard it as
fixed.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

markor (markoresko) wrote :

Ok, i just wanted to make a point that Fix does not fix this bug as bug is reported.

Also I would like to say that there are many noscript users and setup with noscript in browser
is common these days for mare surfing a web without 100% cpu usage.
For me (and all using Noscript) it is regular everyday thing to enable scripts ad flash Per site wanted to.
Also noscript is in Ubuntu repositories.

I would like this bug to be open since it do not work for me, as explained,
but I understand your reasoning even if it is easily reproducible.

I will try to get back with more people having this issue, thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers