Localized LibreOffice Help files ignored when help for en-US is installed

Bug #957589 reported by Giovanni Tornatore on 2012-03-17
122
This bug affects 21 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
Ubuntu Italian ISO defaults package
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
Nominated for Trunk by Jeremy Bicha
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
Low
Björn Michaelsen

Bug Description

WORKAROUND
==========
uninstall the english help package (libreoffice-help-en-us)

Revised bug description
=======================

Ubuntu's language packs don't install the LibreOffice help language packs.
For instance language-pack-en should install libreoffice-help-en-us or libreoffice-help-en-gb; language-pack-de should install libreoffice-help-de and so on.

libreoffice-help-en-us is currently special-cased and installed by ubuntu-desktop. Ubuntu flavors that don't ship LibreOffice are then forced to either install that several MB package or users will get redirected to webhelp when they click Help buttons in LibreOffice.

Menu > tools > customize

Also LibreOffice calc is bugged

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/957589

tags: added: iso-testing localized-iso
Paolo Sammicheli (xdatap1) wrote :

Giovanni,

51 screenshot sono decisamente troppi allegati ad un bug. È sufficente dire che libreoffice ha delle stringhe tradotte, semmai, poi le possiamo trovare anche senza tutte queste schermate.

Secondariamente nel Testcase c'è chiaramente scritto "Attenzione: Non aprire bug per traduzioni mancanti prima del 19 Aprile (LanguagePackTranslationDeadline). Segnalare eventualmente solo errori di ortografia, battitura, ecc. ". Le traduzioni non sono ancora state importate in Precise.

Per favore, prima di aprire un bug come questo chiedi consiglio in canale, ci hai inondato l'email inutilmente ed immagino che tu abbia speso parecchio tempo per farlo.

Changed in ubuntu-defaults-it:
status: New → Invalid
Fabio Marconi (fabiomarconi) wrote :

Hello Giovanni,
This isn't the right way to report a bug.
It's highly dispersive to open and observe all the screenshot one by one.
It's better describe the steps to reproduce the bug one by one, and at the limit, just to clarify or if you havent got a way to better explain, attach one or two screenshot or one screencast.
plus seems to me that the translation deadline comes in 19 April, http://forum.ubuntu-it.org/index.php/topic,497930.0.html
A bug report to be efficient need to be short, detailed and expressive.

Adolfo Jayme (fitojb) on 2012-03-24
summary: - In LibreOffice Writer of the text is translated not
+ Descriptions of menus and toolbars not translated to Italian

Created attachment 58962
Screenshot of the problem

Open the Customize -> Menus tab (Calc, Writer, Impress ). Select some menu entries under Entries, and the Description of that menu item at the bottom of the window will appear untranslated.
The attached screenshot is Hungarian, but this was originally found by an Italian user, so it is likely an i18n problem.
Downstream bug:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/957589

I see this too, forwarded to upstream: https://bugs.freedesktop.org/show_bug.cgi?id=47798

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in libreoffice (Ubuntu):
status: New → Confirmed
summary: - Descriptions of menus and toolbars not translated to Italian
+ [Upstream] Descriptions of menus and toolbars not translated to Italian

You did not have localized help package installed. These strings come from the help.

I have found that these strings are coming from the LO help, so if you install the libreoffice-help-LL package, they should show up translated.

I see the same issue here -- localized help is installed, but does not get picked up by LibreOffice. See also:

 https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/984942

any hints on what might cause this?

Confirming on Debian Sid with libreoffice-1:3.5.2-4+b1

summary: - [Upstream] Descriptions of menus and toolbars not translated to Italian
+ LibreOffice ignore localized help
summary: - LibreOffice ignore localized help
+ LibreOffice ignores localized help

I have found that simply removing the libreoffice-help-en-us package solves this problem.

Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
importance: Undecided → High
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Giovanni Tornatore, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p libreoffice 957589
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected precise
description: updated
Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed

Also affected: libreoffice help is in english and not in french.

philippe@XPS17:~$ dpkg -s libreoffice-help-fr
Package: libreoffice-help-fr
Status: install ok installed
Version: 1:3.5.3-0ubuntu1
Provides: libreoffice-help-3.5

Ubuntu 12.04 installed de novo.

epictete (p-latreyte) wrote :

The tip provided by Gabor in the post #63 (removing the libreoffice-help-en-us package) has worked for me. Thank's Gabor!

Does the workaround from https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/997934/comments/4 work here too?

possibly related/same root cause as bug 997934.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
Gabor Kelemen (kelemeng) wrote :

Hi Björn

I have tried to set en_NZ and en_GB before plain English, but this had no effect on the help language.

Changed in libreoffice (Ubuntu):
status: Incomplete → Confirmed

Gabor,

This needs to be done in "Language Support" in Ubuntu, not in Libre Office. Which did you try?

NOT confirmed on Debian Lenny, LibreOffice 3.5.4 (packages from libreoffice.org). Both en-US and et help packages are installed, but when UI language is set to Estonian, then help is also in Estonian (as far as it's translated, that is).

I don't remember seeing such a bug in earlier 3.5.x releases either, so perhaps it's a bug in the packages provided by Debian/Ubuntu (i.e. NOTOURBUG)?

I have Help in English, or my system is in French.
I have a lot of help package:
libreoffice-help-ru
libreoffice-help-en-us
libreoffice-help-en-gb
libreoffice-help-zh-cn
libreoffice-help-zh-tw
libreoffice-help-fr (logic)
libreoffice-help-es
libreoffice-help-et
libreoffice-help-dz
libreoffice-help-de
libreoffice-help-ca

I delete libreoffice-help-en-us and my help is now in French. If after i install libreoffice-help-en-us english come back. Finally i prefer uninstall ibreoffice-help-en-us

I can confirm the same problem. If libreoffice-help-en-us is installed localized help is not displayed.

J-Paul BERARD (arverne) wrote :

Same problem for me but I must add an information :

French help is installed and is available in the 'Content' tab of the help. You'll find everything.

BUT, in the Index ou the search tab, you can see only the english items. The search can only found english results.
It looks like if the french database of the words is right but without any index.
Thanks.
12.04 - libreoffice 3.5.3.2

mohican (mohican) wrote :

Workaround (allready noted by several people ) :
If you uninstall the help package in english (libreoffice-help-en-us), you will find that the help in your own langage is fully available.

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Opinion
Gabor Kelemen (kelemeng) wrote :

Why is this only Opinion now?

Jeremy Bicha (jbicha) on 2012-08-26
summary: - LibreOffice ignores localized help
+ Language packs do not install LibreOffice help language packs
Jeremy Bicha (jbicha) on 2012-08-26
description: updated
Michael Nagel (nailor) on 2012-09-22
description: updated

Reverting to "Confirmed", since there was no explanation for the change to "Opinion".

Changed in libreoffice (Ubuntu):
status: Opinion → Confirmed
summary: - Language packs do not install LibreOffice help language packs
+ Localized LibreOffice Help files ignored when help for en-US is
+ installed
Changed in libreoffice (Ubuntu):
importance: High → Low
tags: added: quantal

Fix (or rather workaround) from Debian released with LibreOffice 4 which Breaks/Conflicts between en-US and other langpacks.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

This has broken some image builds and I'm fairly sure also some installation cases. We require the ability to coinstall support for multiple languages.

Changed in libreoffice (Debian):
status: Unknown → Fix Released
Changed in libreoffice (Debian):
status: Fix Released → Confirmed

This is not reproducible on Ubuntu 13.10 with LibreOffice 4.1 anymore.

Changed in libreoffice (Ubuntu):
status: Confirmed → Fix Released

Not reproducible with LibreOffice 4.1 on Ubuntu 13.10 => WORKSFORME

Changed in df-libreoffice:
status: Confirmed → Invalid
Gabor Kelemen (kelemeng) on 2013-10-31
Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in libreoffice (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.