Alarms get set at wrong times after travelling

Bug #1480546 reported by Robie Basak on 2015-08-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Critical
Bartosz Kosiorek

Bug Description

User impact: alarm will fail to ring at time set by user.

This might be the same issue as bug 1470320 but I don't feel that report is clear enough to be sure. My use case is:

1. Set an alarm to 9am (and leave clock app running).
2. Travel across timezones.
3. Use the settings icon (top right) from the clock app and then "Change time and date" to enter system settings, and change the time zone to my new location
4. Switch back to clock app (swipe from right edge)
5. Press back to get back to the main screen
6. Swipe from bottom edge to view alarms
7. Note that the alarm still says 9am
8. Edit the alarm by touching it

Expected result: the alarm time picker starts off at 9am.

Actual result: the alarm time picker starts off at 3am (or whatever the time zone difference is presumably)

9. Change alarm time to 10am
10. Touch the tick on the top right

Expected result: the alarm page now shows the alarm set at 10am, and an alarm is set to 10am in the date/time indicator.
Actual result: the alarm page now shows the alarm set at 4pm, and an alarm is set for 4pm in the date/time indicator.

It seems to me that if the timezone is changed while the clock app is running, then the alarm edit UI page screws up by offsetting anything displayed or set by the timezone difference. This will cause the user to inadvertently set an alarm to ring at the wrong time after having set the timezone correctly.

Robie Basak (racb) wrote :

Using Aquaris 4.5 on image r24.

Nekhelesh Ramananthan (nik90) wrote :

Thanks for taking the time to report this bug. The clock app uses the Ubuntu SDK TimePicker widget in the EditAlarm Page. However it seems that the TimePicker is at fault here. This issue has been reported sometime back and is being tracked at https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1371694. I am marking this bug a duplicate as such. If you think the bugs are different, free to comment here.

Changed in ubuntu-clock-app:
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-clock-app:
status: Triaged → In Progress
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in ubuntu-clock-app:
milestone: none → 3.6
Changed in ubuntu-clock-app:
importance: High → Critical
Changed in ubuntu-clock-app:
status: In Progress → Triaged
Changed in ubuntu-clock-app:
milestone: 3.6 → 3.7
Bartosz Kosiorek (gang65) wrote :

It seems that the JavaScript Date compoent is not working correctly after timezone changes.

Changed in ubuntu-clock-app:
milestone: 3.7 → 3.8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers