Cities not translated on the main clock page if language is switched

Bug #1477492 reported by Dave Morley on 2015-07-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
High
Bartosz Kosiorek

Bug Description

STEPS:
1. Flash the phone, on setup select EN_US as lanugae
2. Navigate to the apps scope
3. Tap on the clock app
4. Accept the Location
5. Add the City Paris
6. Close the clock app
7. Open the settings app
8. Tap on Language and Text
9. Tap on the Display
10. Set this to the First Spanish setting After the English settings
11. Set it as default (Phone reboots)
12. Navigate to the apps scope
13. Tap on the clock app

EXPECTED:
See screenshot 2, I expect to see that version of Paris France to be visible on the main clock page

ACTUAL:
The clock face still shows the initial translation of Paris France, it is like the list on the clock face is not translatable.

VERSIONS:
current build number: 66
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-07-22 17:01:40
version version: 66
version ubuntu: 20150722
version device: 20150709-8965e37
version custom: 20150716-819-8-42

MODIFICATIONS:
com.ubuntu.clock 3.4.305 installed for testing

Related branches

Dave Morley (davmor2) wrote :
tags: added: qa-silo
Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
Dave Morley (davmor2) wrote :

While this isn't a regression, so we are allowing this update into the store, it will not be allowed to pass a second time, so it needs fixing before the next store update. So marking as high.

11:22 < DanChapman> looks like the city get's saved as a string to the clockDB in the current locale, so on replay of that after the locale change would still bring back the string for the original language.
11:27 < DanChapman> http://bazaar.launchpad.net/~ubuntu-clock-dev/ubuntu-clock-app/utopic-3.0/view/head:/app/worldclock/WorldCityList.qml#L353 looks like where the raw string is being saved

Changed in ubuntu-clock-app:
milestone: none → 3.4
Changed in ubuntu-clock-app:
milestone: 3.4 → 3.5
Changed in ubuntu-clock-app:
status: Confirmed → Triaged
Changed in ubuntu-clock-app:
assignee: nobody → Bartosz Kosiorek (gang65)
status: Triaged → In Progress

Fix committed into lp:ubuntu-clock-app at revision 336, scheduled for release in ubuntu-clock-app, milestone 3.5

Changed in ubuntu-clock-app:
status: In Progress → Fix Committed
Víctor R. Ruiz (vrruiz) on 2015-08-26
tags: added: touch-l10n
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers