Support 12h or 24h time display format

Bug #1388931 reported by dobey on 2014-11-03
102
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Clock App
Medium
Unassigned
Ubuntu UX
Medium
Unassigned
indicator-datetime (Ubuntu)
Medium
Renato Araujo Oliveira Filho
ubuntu-system-settings (Ubuntu)
Wishlist
Unassigned

Bug Description

Updating this bug based on the comments and dupes.

There should be a setting in the Time & Date settings control panel to select 12 or 24 hour display format. This should be honored in the indicator, greeter and clock app.

gsetting com.canonical.indicator.datetime time-format controls this

dobey (dobey) on 2014-11-03
tags: added: regression
Nekhelesh Ramananthan (nik90) wrote :

Thanks for the bug report. Let me take some time to report some of my findings below,

1. As you correctly pointed out, a lot of people back then informed me that the 12h/24h mode settings should be something present in the settings application. As such it was removed from the clock app. Also it wasn't included in the new design by the designers.

2. The clock app doesn't change settings system wide like the user timezone, local settings (12h/24h) since it runs confined and I doubt it would be given the freedom to do so. Infact at the moment, the clock app settings page shows the user timezone which on clicking would take the user to the Time&Date section of the settings app where they can change their timezone.

So ideally I would like to see these settings appear in the Time&Date section of the settings app which the clock app can then perhaps link to. I am adding ubuntu-ux project to this bug report to get the feedback of the designers.

Changed in ubuntu-clock-app:
milestone: none → postrtm
importance: Undecided → Medium
Pat McGowan (pat-mcgowan) wrote :

The design for the phone does not include such a setting per use cases at https://wiki.ubuntu.com/TimeAndDate#Phone

Nekhelesh Ramananthan (nik90) wrote :

Oh! That's a bit strange since Android allows users to change the time-format in the settings app and it seems like a trivial requirement. Can we get the opinion of mpt and any other designers and accordingly update the bug status?

dobey (dobey) wrote :

Not only Android, but every phone I've owned that I recall, had a way to toggle between 12h or 24h format. Also, Ubuntu supports this on my workstation and laptop, so I see no reason why we'd want to get rid of that as we move toward a converged experience. That wiki page also includes no rationale as to why it shouldn't be there.

Sebastien Bacher (seb128) wrote :

That's not in the settings doesn't, closing that component. That can be reopened if the design change

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Wishlist
status: New → Won't Fix
description: updated
Matthew Paul Thomas (mpt) wrote :

I didn't include a 12-/24-hour setting, or any other time/date format settings, in System Settings because I was told they would be extremely difficult to implement. But from bug 1392699 they may not be so difficult after all.

As I said in bug 1236203, though, the Clock could reasonably have a 12-/24-hour toggle all by itself until we get one in System Settings. One way of doing this (not the only way!) would be for tapping on the clock face to toggle not just between analog and digital, but between analog, 12-hour digital, and 24-hour digital.

dobey (dobey) wrote :

Well, I'd like to have 24h time across the system, not just in the clock app (which i don't ever really use). What I want is the time in the indicator and lock screen to be 24h.

So maybe we could get a design for such a toggle in system settings and use this bug as the one for needing to implement that?

Matthew Paul Thomas (mpt) wrote :

Since this bug report is already about the clock app, and bug 1392699 already covers System Settings, I suggest we leave them both where they are.

dobey (dobey) on 2014-11-14
no longer affects: clock-app
summary: - No setting for 12h or 24h clock format any more
+ [clock] No setting for 12h or 24h clock format any more
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Giorgio Venturi (giorgio-venturi)

I suggest the clock app to inherit the preference in the Settings app, rather than having a specific in app setting.

Systems settings bug here
https://bugs.launchpad.net/bugs/1392699

Changed in ubuntu-ux:
status: Triaged → Won't Fix
Nekhelesh Ramananthan (nik90) wrote :

As per the comment above by Giorgio, the clock app designer, I am marking it Wont-Fix for clock app as well.

Changed in ubuntu-clock-app:
status: New → Won't Fix
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: Won't Fix → Confirmed
Charles Kerr (charlesk) on 2016-06-14
Changed in indicator-datetime (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → Medium
status: New → Confirmed
description: updated
description: updated
summary: - [clock] No setting for 12h or 24h clock format any more
+ Support 12h or 24h time display format
Changed in ubuntu-clock-app:
status: Won't Fix → Confirmed
Changed in indicator-datetime (Ubuntu):
assignee: Charles Kerr (charlesk) → Renato Araujo Oliveira Filho (renatofilho)
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Bill Filler (bfiller)
Changed in canonical-devices-system-image:
milestone: none → 13
Changed in canonical-devices-system-image:
milestone: 13 → backlog
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers