Installation fails due to useless immediate configuration error when "Install Third-Party Drivers" is selected

Bug #1871268 reported by andresgenovez on 2020-04-07
718
This bug affects 133 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned
apt (Debian)
Fix Released
Unknown
apt (Ubuntu)
High
Unassigned
Bionic
Medium
Unassigned
Focal
High
Unassigned
Groovy
Medium
Unassigned

Bug Description

[Impact]
Installations that really succeeded would then fail because APT could not immediately configure a package. Which is a pointless way to fail at that point, because everything did work out anyway.

We have two changes that help address this:

* The first one stops immediately configuring multi-arch siblings (e.g. libc6:i386 when it's configuring libc6:amd64). This was not necessary, and caused all the libc6:i386 failures here.

* The second change sort of also supersedes the first one: It just ignores any errors from immediate configuration, relying on the fact that it's checked and rectified at a later point if there are unconfigured packages (which is what made all those failures happen spuriously after having successfully installed everything).

[Test case]
We have one test case in EIPP format in the Debian bug 973305 which was only helped by the second change, not the first one. Run /usr/lib/apt/planners < eipp.log and check there are no errors.

TODO: It's unclear if the APT from proposed installed in the live session will fix the installer, needs investigation, but would make a useful test case.

[Regression potential]
It's imaginable that we missed something somewhere and some path that checked for a set error doesn't check it anymore, and we report success when we hit an error, but it seems unlikely.

Behavior of --simulate changes. This used to fail before as well, and will now only produce a warning. We don't believe that is a reason of concern.

[Groovy SRU]
The groovy SRU is a sync of the 2.1.11 micro release from Debian unstable which also incorporates changes to the documentation: A typo fix, replacing focal with groovy in examples, and minor Dutch manual pages translation updates.

We do not have test cases for the documentation changes, and we do not consider there to be a huge regression potential. As long as they build, they should be readable - maybe some words are wrong in the translation, who knows.

[Original bug report]
Test Case
1. Install Ubuntu Desktop on hardware with an nVidia card and select to install 3rd party drivers
2. Proceed with installation

The following error message is displayed in /var/log/syslog
/plugininstall.py: Verifying downloads ...
/plugininstall.py: Failed to find package object for /cdrom//pool/main/g/gcc-defaults/gcc_9.3.0-1ubuntu2_amd64.deb: "Version: '9.3.0-1ubuntu2' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxcrypt/libcrypt-dev_4.4.10-10ubuntu4_amd64.deb: "Version: '4.4.10-10ubuntu4' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/g/gcc-defaults/g++_9.3.0-1ubuntu2_amd64.deb: "Version: '9.3.0-1ubuntu2' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/z/zlib/zlib1g_1.2.11.dfsg-2ubuntu1_i386.deb: "Version: '1.2.11.dfsg-2ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxau/libxau6_1.0.9-0ubuntu1_i386.deb: "Version: '1.0.9-0ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxdmcp/libxdmcp6_1.1.3-0ubuntu1_i386.deb: "Version: '1.1.3-0ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libx11/libx11-6_1.6.9-2ubuntu1_i386.deb: "Version: '1.6.9-2ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxext/libxext6_1.3.4-0ubuntu1_i386.deb: "Version: '1.3.4-0ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/l/lm-sensors/libsensors5_3.6.0-2ubuntu1_i386.deb: "Version: '3.6.0-2ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libx11/libx11-xcb1_1.6.9-2ubuntu1_i386.deb: "Version: '1.6.9-2ubuntu1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxdamage/libxdamage1_1.1.5-1_i386.deb: "Version: '1.1.5-1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxfixes/libxfixes3_5.0.3-1_i386.deb: "Version: '5.0.3-1' not found."
/plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxxf86vm/libxxf86vm1_1.1.4-1build1_i386.deb: "Version: '1.1.4-1build1' not found."
/plugininstall.py: Downloads verified successfully
ubiquity: Error in function: install
/plugininstall.py: Exception during installation:
/plugininstall.py: apt_pkg.Error: E:Could not configure 'libc6:i386'. , E:Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
/plugininstall.py:

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubiquity 20.04.9
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CasperVersion: 1.442
Date: Mon Apr 6 20:17:07 2020
InstallCmdLine: file=/cdrom/preseed/xubuntu.seed only-ubiquity initrd=/casper/initrd quiet splash ---
LiveMediaBuild: Xubuntu 20.04 LTS "Focal Fossa" - Beta amd64 (20200402)
ProcEnviron:
 LANGUAGE=es_EC.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_EC.UTF-8
 LC_NUMERIC=C.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

andresgenovez (andresgenovez) wrote :
Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
tags: added: rls-ff-incoming
Pierre Equoy (pieq) wrote :

Facing a crash that looks similar.

In ubiquity install.trace file, I can see:

    apt_pkg.Error: E:Could not configure 'libc6:i386'. , E:Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Device: Dell Vostro 5590
Image: Focal 20.04 beta
Install: connected to the Internet (using an Ethernet cable)
Install options:
 - erase disk and install Ubuntu
 - use LVM partitioning
 - use encryption

I installed 20.04 a few weeks ago on the same device and didn't face this issue.

Also, I tried booting in "safe graphics mode" for the install but it didn't help.

Pierre Equoy (pieq) wrote :

Forgot to mention I'm using Ubuntu image, not Xubuntu.

summary: - Clean Install first time
+ Installation fails with Could not configure 'libc6:i386'. , E:Could not
+ perform immediate configuration on 'libgcc-s1:i386'
Changed in glibc (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Pierre Equoy (pieq) wrote :

If the exact same installation process is followed *without being connected to the Internet*, the installation can be completed successfully.

Matthias Klose (doko) wrote :

UbiquitySyslog reads:

Apr 7 01:14:40 xubuntu /plugininstall.py: Verifying downloads ...
Apr 7 01:14:41 xubuntu /plugininstall.py: Failed to find package object for /cdrom//pool/main/g/gcc-defaults/gcc_9.3.0-1ubuntu2_amd64.deb: "Version: '9.3.0-1ubuntu2' not found."
Apr 7 01:14:41 xubuntu /plugininstall.py: Failed to find package object for /cdrom//pool/main/libx/libxcrypt/libcrypt-dev_4.4.10-10ubuntu4_amd64.deb: "Version: '4.4.10-10ubuntu4' not found."
Apr 7 01:14:41 xubuntu /plugininstall.py: Failed to find package object for /cdrom//pool/main/g/gcc-defaults/g++_9.3.0-1ubuntu2_amd64.deb: "Version: '9.3.0-1ubuntu2' not found."
Apr 7 01:14:47 xubuntu /plugininstall.py: Downloads verified successfully
Apr 7 01:14:48 xubuntu ubiquity: Error in function: install
Apr 7 01:14:48 xubuntu /plugininstall.py: Exception during installation:
Apr 7 01:14:48 xubuntu /plugininstall.py: apt_pkg.Error: E:No se pudo configurar «libc6:i386», E:No se pudo realizar la configuración inmediata de «libgcc-s1:i386». Consulte la página de manual con «man 5 apt.conf» bajo «APT::Immediate-Configure» para más información. (2)
Apr 7 01:14:48 xubuntu /plugininstall.py:

apparently some downloads failed, and ubiquity seems to ignore that errror, and tries to continue. how is libc6:i386 involved with that? out of sync mirrors?

Changed in glibc (Ubuntu):
status: Confirmed → Incomplete
description: updated
Dimitri John Ledkov (xnox) wrote :

So, we have by-hand calculated list of packages that are included from the i386 repo onto the amd64.

Dimitri John Ledkov (xnox) wrote :

And we need to update it.

erio (eri0) wrote :

I have a i5 4th generation and a NVIDIA GTX 970, I hit this bug trying to install 20.04 from the Beta build.

Changed in ubuntu-cdimage:
status: New → Fix Released
Changed in glibc (Ubuntu Focal):
status: Incomplete → Invalid
Changed in ubiquity (Ubuntu Focal):
status: Confirmed → Invalid
Rajat Pandita (rajat-pandita) wrote :

This is a new observation, This did not happen before, The install is however successful, and I can login fine. Hope this helps

Doug Brunelle (dougbrunelle) wrote :

I had this installer crash just now. (Apr 19, 2020)

* Computer: MSI GT72 6QD laptop, 16MB RAM, Nvidia GTX970M video. Installing to a 1TB SATA SSD drive.
* Used the installation option to use Internet connection to install third-party software (wired Ethernet connection to router)
* Already have Ubuntu Studio 19.10 and Windows 10 on a separate PCI-E SSD.

Note: I got thru the partitioning section, login name setup, and the installer progress showed being about 3/4 done (installing system message) when the crash occurred.

Steve Langasek (vorlon) wrote :

Doug, this was fixed by including the missing i386 packages in a newer image. What image did you see this issue with? You need to be using the latest daily image to get the fix.

Bill (franksmcb) (franksmcb) wrote :

This is occurring on the the Ubuntu MATE 20.04 Focal Final release. 20200419

Occurs during the installation and the installer crashes.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1871268

tags: added: iso-testing
Steve Langasek (vorlon) wrote :

I have verified that the libgcc-s1:i386 binary package is included in the package pool including on the Ubuntu Mate 20200419 daily image. Can someone who is experiencing this issue please attach their full syslog from the live environment, so that we can reconfirm what's going on?

Installation went fine for me with my GT 640M LE prime setup with the 20200420 daily image.

Bill (franksmcb) (franksmcb) wrote :

I have installed using the latest 20200420 image of Ubuntu MATE and this issue is not occurring, installation completes successfully.

Have GTX 1660 and did an install of latest 20200420 and did not experience error as reported, but have attached tarball of /var/log/ from live environment, if it can be useful.

RTX2070, still seeing this with the image I downloaded 1 hour ago. Ethernet was connected and I chose to download packages during installation.

thrantir (thrantir) wrote :

I got the same error with an image downloaded on saturday, with the image downloaded 20 minutes ago the problem didn't happen

Perke Valo (perkevalo) wrote :

my computor crashed when I tried to make a 32 bit ghost drive ti wine..couldent boot at all so I did install a new one moohahahh

Changed in glibc (Ubuntu Focal):
status: Invalid → Incomplete
status: Incomplete → New
status: New → Incomplete
status: Incomplete → New
Changed in ubiquity (Ubuntu Focal):
status: Invalid → Confirmed
Steve Langasek (vorlon) on 2020-04-21
Changed in glibc (Ubuntu Focal):
status: New → Invalid
Changed in ubiquity (Ubuntu Focal):
status: Confirmed → Invalid
Steve Langasek (vorlon) wrote :

@kn4llfrosch please indicate which image you downloaded, not just when you downloaded it.

Also, without the log files that I previously requested, we are not going to be able to further debug any remaining failures which are not reproducible for the developers.

tags: added: id-5e8f3d0fc3884a8778101b63

Got this while installing from a daily build of groovy-desktop-amd64 from 2020-06-02. System connected to the internet, updates while installing enabled, third-party installs enabled and I've got an NVIDIA card as well.

Vadim Zeitlin (vz-ubuntu) wrote :

Although this is marked as "Invalid" for 20.04, this problem has somehow started happening in GitHub Actions Ubuntu 20.04 virtual environment since today (2020-07-24), even though it worked correctly before. I don't know if attaching the entire build log is desirable, but as the result of running these commands

2020-07-24T22:46:28.8786226Z sudo dpkg --add-architecture i386
2020-07-24T22:46:28.8786352Z sudo apt-get update
2020-07-24T22:46:28.8786474Z sudo apt-get --assume-yes install \
2020-07-24T22:46:28.8786604Z automake bc bsdmainutils bzip2 curl cvs default-jre \
2020-07-24T22:46:28.8786724Z g++-mingw-w64-i686 g++-multilib git jing libarchive-tools \
2020-07-24T22:46:28.8786866Z libtool libxml2-utils libxslt1-dev make patch pkg-config rsync \
2020-07-24T22:46:28.8787006Z shellcheck sudo trang unzip wine32 wget xsltproc

I get, after many snipped lines, the following error:

2020-07-24T22:50:38.3418072Z Processing triggers for libc-bin (2.31-0ubuntu9) ...
2020-07-24T22:50:38.4346359Z Processing triggers for libgdk-pixbuf2.0-0:i386 (2.40.0+dfsg-3) ...
2020-07-24T22:50:38.4858494Z Processing triggers for wine (5.0-3ubuntu1) ...
2020-07-24T22:50:40.0498037Z E: Could not configure 'libc6:i386'.
2020-07-24T22:50:40.0499968Z E: Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
2020-07-24T22:50:40.0526698Z ##[error]Process completed with exit code 100.

and there don't seem to be any other errors in the output until these lines, so I have no idea why does this happen.

FWIW the same step of this workflow succeeds when run in Ubuntu 18.04-based GitHub virtual environment, but it doesn't have sufficiently up-to-date packages for building this software, so I can't use it and would really appreciate any workaround for this problem under 20.04.

Vadim Zeitlin (vz-ubuntu) wrote :

P.S. I've just finally found a workaround myself: doing "apt install libgcc-s1:i386" first, before installing anything else (but after "apt update"), allows the installation to succeed.

Jackson Doak (noskcaj) wrote :

A crash has redirected me to this bug using today's xubuntu 20.10 image. Attached is /var/log. This is on a Thinkpad T530 with nvidia graphics

Changed in ubiquity (Ubuntu):
assignee: nobody → faris aboobacker (fariskp)
assignee: faris aboobacker (fariskp) → nobody

I just got this error while attempting to install Ubuntu 20.04.1 LTS, which I downloaded this afternoon. I managed to get through the partitioning and username setting parts, but it crashed after that and I was redirected to this page.
I am using a ThinkPad P14s with NVIDIA graphics, I enabled update downloading during installation and third-party software installation. Any help would be appreciated.

Rafly (froyonion) on 2020-09-23
Changed in ubuntu-cdimage:
assignee: nobody → Rafly (froyonion)
assignee: Rafly (froyonion) → nobody

Same error occurs with Kubuntu 20.04 & 20.04.01 and Xubuntu 20.04.01 -- this error occurs at 90-91% of the way through the install process. Suspect it's related to my video card: ASUS NVIDIA STRIX-GTX1050TI-04G-GAMING graphics card. This card worked perfectly up until last week with 20.04 Xubuntu and Kubuntu. All 64-bit. And it still works fine with Mint20. Guess I need to get a cheaper, crappier video card if I want to use *buntu going forward. {sigh}

Trevin Corkery (trevinlc1997) wrote :

This happened to me last night while trying to install Ubuntu on my desktop. It crashed and redirected me here.

One feature that I enabled was ZFS.

Desktop Specs:
Ryzen 3700x
GTX 1080ti
GSkillz Trident Z 8GB DDR4 3200mhz x2
Samsung 970 PRO
x370 Taichi

Tianon Gravi (tianon) wrote :

I'm running into this building a Docker image that's "FROM ubuntu:20.04" and just trying to install libc6:i386. Here's the simplest reproducer I've come up with:

```
$ docker pull ubuntu:20.04
20.04: Pulling from library/ubuntu
Digest: sha256:cbcf86d7781dbb3a6aa2bcea25403f6b0b443e20b9959165cf52d2cc9608e4b9
Status: Image is up to date for ubuntu:20.04
docker.io/library/ubuntu:20.04

$ docker run --rm ubuntu:20.04 sh -c 'dpkg --add-architecture i386 && apt-get update -qq && apt-get install -y libc6:i386'
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  gcc-10-base:i386 libc6 libcrypt1:i386 libgcc-s1:i386 libidn2-0:i386
  libunistring2:i386
Suggested packages:
  glibc-doc locales glibc-doc:i386 locales:i386
The following NEW packages will be installed:
  gcc-10-base:i386 libc6:i386 libcrypt1:i386 libgcc-s1:i386 libidn2-0:i386
  libunistring2:i386
The following packages will be upgraded:
  libc6
1 upgraded, 6 newly installed, 0 to remove and 1 not upgraded.
Need to get 5871 kB of archives.
After this operation, 15.2 MB of additional disk space will be used.
...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
E: Could not configure 'libc6:i386'.
E: Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
```

Looking at my GitHub Actions logs, it was working fine two days ago (Sep 21) and was broken starting yesterday (Sep 22), in case that helps narrow down which uploads might have caused the breakage.

Brian Murray (brian-murray) wrote :

On an Ubuntu Desktop system (which had not been updated for a while) I was able to recreate this by trying to install libc6:i386.

...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
E: Could not configure 'libc6:i386'.
E: Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Interestingly no apport crash report was generated.

Brian Murray (brian-murray) wrote :

If libc-bin has been updated to 2.31-0ubuntu9.1 there is no such issue.

The following NEW packages will be installed:
  gcc-10-base:i386 libc6:i386 libcrypt1:i386 libgcc-s1:i386 libidn2-0:i386 libunistring2:i386
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,159 kB of archives.
After this operation, 15.2 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://192.168.10.7/ubuntu focal/main i386 gcc-10-base i386 10-20200411-0ubuntu1 [19.0 kB]
Get:2 http://192.168.10.7/ubuntu focal/main i386 libgcc-s1 i386 10-20200411-0ubuntu1 [49.8 kB]
Get:3 http://192.168.10.7/ubuntu focal/main i386 libcrypt1 i386 1:4.4.10-10ubuntu4 [90.9 kB]
Get:4 http://192.168.10.7/ubuntu focal-updates/main i386 libc6 i386 2.31-0ubuntu9.1 [2,571 kB]
Get:5 http://192.168.10.7/ubuntu focal/main i386 libunistring2 i386 0.9.10-2 [377 kB]
Get:6 http://192.168.10.7/ubuntu focal/main i386 libidn2-0 i386 2.2.0-2 [51.4 kB]
Fetched 3,159 kB in 0s (27.7 MB/s)
Preconfiguring packages ...
Selecting previously unselected package gcc-10-base:i386.
(Reading database ... 259734 files and directories currently installed.)
Preparing to unpack .../0-gcc-10-base_10-20200411-0ubuntu1_i386.deb ...
Unpacking gcc-10-base:i386 (10-20200411-0ubuntu1) ...
Selecting previously unselected package libgcc-s1:i386.
Preparing to unpack .../1-libgcc-s1_10-20200411-0ubuntu1_i386.deb ...
Unpacking libgcc-s1:i386 (10-20200411-0ubuntu1) ...
Selecting previously unselected package libcrypt1:i386.
Preparing to unpack .../2-libcrypt1_1%3a4.4.10-10ubuntu4_i386.deb ...
Unpacking libcrypt1:i386 (1:4.4.10-10ubuntu4) ...
Selecting previously unselected package libc6:i386.
Preparing to unpack .../3-libc6_2.31-0ubuntu9.1_i386.deb ...
Unpacking libc6:i386 (2.31-0ubuntu9.1) ...
Selecting previously unselected package libunistring2:i386.
Preparing to unpack .../4-libunistring2_0.9.10-2_i386.deb ...
Unpacking libunistring2:i386 (0.9.10-2) ...
Selecting previously unselected package libidn2-0:i386.
Preparing to unpack .../5-libidn2-0_2.2.0-2_i386.deb ...
Unpacking libidn2-0:i386 (2.2.0-2) ...
Setting up gcc-10-base:i386 (10-20200411-0ubuntu1) ...
Setting up libcrypt1:i386 (1:4.4.10-10ubuntu4) ...
Setting up libgcc-s1:i386 (10-20200411-0ubuntu1) ...
Setting up libc6:i386 (2.31-0ubuntu9.1) ...
Setting up libunistring2:i386 (0.9.10-2) ...
Setting up libidn2-0:i386 (2.2.0-2) ...
Processing triggers for libc-bin (2.31-0ubuntu9.1) ...

hong (tjdxph) wrote :

When i install it i failed like this problem

Adam (zyl0) wrote :
Download full text (8.0 KiB)

Same happened to me. I suppose I will reattempt with the non-proprietary drivers and see if that will work out. Running an nVidia 1060 in an MSI laptop, SSD, 32GB ram, and was attempting to install the Voyager distro. The bug report directed me here, so here is my two cents. Sorry for the length I tried to cut it wherever it seemed to become relevant.

Sep 24 09:57:16 xubuntu ubiquity: Error in function: install
Sep 24 09:57:16 xubuntu /plugininstall.py: Exception during installation:
Sep 24 09:57:16 xubuntu /plugininstall.py: apt_pkg.Error: E:Could not configure 'libc6:i386'. , E:Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
Sep 24 09:57:16 xubuntu /plugininstall.py:
Sep 24 09:57:16 xubuntu ubiquity:
Sep 24 09:57:16 xubuntu ubiquity: #015Get:66 http://us.archive.ubuntu.com/ubuntu focal/main i386 libxcb-randr0 i386 1.14-2 [18.0 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:67 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-5.4.0-48-generic amd64 5.4.0-48.52 [14.5 MB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:68 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-5.4.0-48-generic amd64 5.4.0-48.52 [8889 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:69 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-modules-extra-5.4.0-48-generic amd64 5.4.0-48.52 [38.6 MB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:70 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-generic amd64 5.4.0.48.51 [1896 B]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:71 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-image-generic amd64 5.4.0.48.51 [2744 B]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:72 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-48 all 5.4.0-48.52 [11.0 MB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:73 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-5.4.0-48-generic amd64 5.4.0-48.52 [1255 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:74 http://us.archive.ubuntu.com/ubuntu focal-updates/main amd64 linux-headers-generic amd64 5.4.0.48.51 [2612 B]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:75 http://us.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 linux-modules-nvidia-450-5.4.0-48-generic amd64 5.4.0-48.52 [11.5 MB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:76 http://us.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 nvidia-kernel-common-450 amd64 450.66-0ubuntu0.20.04.1 [18.6 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:77 http://us.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 linux-modules-nvidia-450-generic-hwe-20.04 amd64 5.4.0-48.52 [5476 B]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:78 http://us.archive.ubuntu.com/ubuntu focal-updates/main i386 mesa-vulkan-drivers i386 20.0.8-0ubuntu1~20.04.1 [3456 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:79 http://us.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 nvidia-compute-utils-450 amd64 450.66-0ubuntu0.20.04.1 [121 kB]
Sep 24 09:57:16 xubuntu ubiquity: #015Get:80 http://us.archive.ubuntu.com/ubuntu focal-updates/restricted ...

Read more...

Stewart menday (stewartmenday) wrote :

Just got this error, some further info,

GFX card - Nvidia Titan RTX
CPU - i9-10900X
MB - ASRock x299 Gaming K6
Installed OS - Win10 and Ubuntu 18.04, both installed to separate M.2 drives
Trying to install 20.04.01 to a 3rd M.2 drive

The install appears to be usable after the crash.
If you don't update drivers during install it will install without error.
If you don't update drivers during install, the installed system is unusable due to no/crazy screen output.

Erwin (erwindeboer) wrote :

Same error

Tried to install Ubuntu 20.04.1

Ryzen 3600

Nvidia 1660 super

Changed in glibc (Ubuntu Focal):
status: Invalid → In Progress
assignee: nobody → Balint Reczey (rbalint)
Zach Malter (zmalter99) wrote :

Same error as well.

Ubuntu 20.04.1
Intel i7-8700k
RTX 2080
Z370 GAMING PRO CARBON

Balint Reczey (rbalint) wrote :
Download full text (4.5 KiB)

Easily reproducible on a system with libc6=2.31-0ubuntu9:

# apt install -o Debug::pkgPackageManager=True libc6:i386
...
Do you want to continue? [Y/n]
Beginning to order
Done ordering
  SmartUnPack libc6:amd64 (replace version 2.31-0ubuntu9 with 2.31-0ubuntu9.1) immediately
  Ignore not-installed version 2.31-0ubuntu9 of libc6:i386 for libc6:amd64 Breaks on libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN > (!= 2.31-0ubuntu9.1)
    SmartUnPack libc6:i386 (install version 2.31-0ubuntu9.1)
    Ignore already dealt-with version 2.31-0ubuntu9 of libc6:amd64 for libc6:i386 Breaks on libc6:amd64 < 2.31-0ubuntu9 -> 2.31-0ubuntu9.1 @ii umU > (!= 2.31-0ubuntu9.1)
    SmartConfigure libc6:amd64 (2.31-0ubuntu9.1)
    Found ok dep libgcc-s1:amd64 < 10-20200411-0ubuntu1 @ii mK >
    Found ok dep libcrypt1:amd64 < 1:4.4.10-10ubuntu4 @ii mK >
      SmartConfigure libc6:i386 (2.31-0ubuntu9.1)
      Unpacking libgcc-s1:i386 to avoid loop libc6:i386 Depends on libgcc-s1:i386 < none -> 10-20200411-0ubuntu1 @un umN >
        SmartUnPack libgcc-s1:i386 (install version 10-20200411-0ubuntu1) immediately
          SmartConfigure libgcc-s1:i386 (10-20200411-0ubuntu1)
          Unpacking gcc-10-base:i386 to avoid loop libgcc-s1:i386 Depends on gcc-10-base:i386 < none -> 10-20200411-0ubuntu1 @un umN > (= 10-20200411-0ubuntu1)
            SmartUnPack gcc-10-base:i386 (install version 10-20200411-0ubuntu1) immediately
              SmartConfigure gcc-10-base:i386 (10-20200411-0ubuntu1)
          Configure already unpacked libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN >
            SmartConfigure libc6:i386 (2.31-0ubuntu9.1) (Only Correct Dependencies)
            Package libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN > loops in SmartConfigure, but it isn't unpacked yet
            Package libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN > loops in SmartConfigure, but it isn't unpacked yet
            Could not satisfy libc6:i386 Depends on libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un umN > (>= 1:4.4.10-10ubuntu4)
      Unpacking libcrypt1:i386 to avoid loop libc6:i386 Depends on libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un umN > (>= 1:4.4.10-10ubuntu4)
        SmartUnPack libcrypt1:i386 (install version 1:4.4.10-10ubuntu4) immediately
          SmartConfigure libcrypt1:i386 (1:4.4.10-10ubuntu4)
          Configure already unpacked libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN >
            SmartConfigure libc6:i386 (2.31-0ubuntu9.1) (Only Correct Dependencies)
            Configure already unpacked libgcc-s1:i386 < none -> 10-20200411-0ubuntu1 @un umN >
              SmartConfigure libgcc-s1:i386 (10-20200411-0ubuntu1)
              Configure already unpacked libc6:i386 < none -> 2.31-0ubuntu9.1 @un pumN >
                SmartConfigure libc6:i386 (2.31-0ubuntu9.1) (Only Correct Dependencies)
Skipping already done gcc-10-base:i386
...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
E: Could not configure 'libc6:i386'.
E: Could not perform immediate configuration on 'libgcc-s1:i386'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
root@ff-glibc-i386:~# echo $?
100
root@ff-glibc-i386:~#

Apart from the error messages and the exit code 100 ...

Read more...

Changed in glibc (Ubuntu Focal):
status: In Progress → Invalid
Changed in apt (Ubuntu):
importance: Undecided → High
Rahul Shial (rahulshial) wrote :

Dell L502X laptop / 256gb SSD / 16GB RAM
Windows 10 OS
Dual boot - Ubuntu 20.04.01 installation crashes with libc6:i386 configuration error.

At my wits end trying to make this work.

Balint Reczey (rbalint) on 2020-09-24
Changed in glibc (Ubuntu Bionic):
status: New → Invalid
status: Invalid → Fix Released
Changed in ubiquity (Ubuntu Bionic):
status: New → Invalid
Changed in apt (Ubuntu Bionic):
status: New → Invalid
Changed in apt (Ubuntu Focal):
status: New → Confirmed
Changed in apt (Ubuntu):
status: New → Confirmed
Hoa (thuythumattroi1999) on 2020-09-25
Changed in ubuntu-cdimage:
assignee: nobody → Hoa (thuythumattroi1999)
Steve Langasek (vorlon) on 2020-09-25
Changed in ubuntu-cdimage:
assignee: Hoa (thuythumattroi1999) → nobody
Changed in ubiquity (Ubuntu):
assignee: nobody → pooria aghapour (pan2020)
Changed in ubiquity (Ubuntu):
assignee: pooria aghapour (pan2020) → nobody
Hoang Van Linh (linhbka) on 2020-09-26
information type: Public → Public Security
Balint Reczey (rbalint) on 2020-09-26
tags: added: regression-update
Balint Reczey (rbalint) on 2020-09-26
Changed in glibc (Ubuntu Focal):
assignee: Balint Reczey (rbalint) → nobody
Steve Langasek (vorlon) on 2020-09-27
information type: Public Security → Public
Steve Langasek (vorlon) on 2020-09-27
no longer affects: ubiquity
Changed in ubiquity (Ubuntu):
assignee: nobody → Le Tran Bao Loc (dominiclc)
status: Invalid → New
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2020-09-27
no longer affects: ubiquity (Ubuntu)
no longer affects: ubiquity (Ubuntu Bionic)
no longer affects: ubiquity (Ubuntu Focal)
toipon (toipon) on 2020-09-28
Changed in apt (Ubuntu):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in glibc (Ubuntu):
status: Invalid → Fix Released
assignee: nobody → toipon (toipon)
assignee: toipon (toipon) → nobody
Balint Reczey (rbalint) on 2020-09-28
Changed in apt (Ubuntu):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Bionic):
status: Invalid → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Released → Confirmed
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
Changed in glibc (Ubuntu):
assignee: nobody → Black Mage Zeraf (blackmagezeraf)
status: Invalid → Confirmed
Changed in glibc (Ubuntu):
assignee: Black Mage Zeraf (blackmagezeraf) → nobody
Steve Langasek (vorlon) on 2020-09-28
Changed in glibc (Ubuntu):
status: Confirmed → Invalid
hedfi helmi (helmi7) on 2020-09-29
Changed in glibc (Ubuntu):
status: Invalid → Confirmed
Changed in glibc (Ubuntu):
assignee: nobody → tran xuan truong (xu-truong)
bianca souza (bibigenio) on 2020-09-29
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Committed
Changed in glibc (Ubuntu):
status: Confirmed → Fix Committed
Changed in glibc (Ubuntu Focal):
status: Invalid → Fix Committed
Steve Langasek (vorlon) on 2020-09-29
Changed in glibc (Ubuntu):
assignee: tran xuan truong (xu-truong) → nobody
Steve Langasek (vorlon) on 2020-09-29
Changed in glibc (Ubuntu Focal):
status: Fix Committed → Invalid
Changed in glibc (Ubuntu):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Bionic):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Committed → Confirmed
Changed in glibc (Ubuntu):
assignee: nobody → lesbats fabrice (flesbats)
Steve Langasek (vorlon) on 2020-09-29
Changed in glibc (Ubuntu):
assignee: lesbats fabrice (flesbats) → nobody
Diana Voicu (dianavoicu) on 2020-09-30
Changed in glibc (Ubuntu):
assignee: nobody → Diana Voicu (dianavoicu)
Changed in glibc (Ubuntu):
assignee: Diana Voicu (dianavoicu) → nobody
ChienDV (chiendv) on 2020-10-01
Changed in apt (Ubuntu):
status: Confirmed → Incomplete
Changed in apt (Ubuntu Bionic):
status: Confirmed → Incomplete
Changed in apt (Ubuntu Focal):
status: Confirmed → Incomplete
Changed in glibc (Ubuntu):
status: Confirmed → Incomplete
Changed in apt (Ubuntu Focal):
status: Incomplete → Fix Committed
Changed in glibc (Ubuntu):
status: Incomplete → Fix Committed
Changed in apt (Ubuntu Bionic):
status: Incomplete → Fix Committed
Changed in apt (Ubuntu):
status: Incomplete → Fix Committed
Balint Reczey (rbalint) on 2020-10-01
Changed in glibc (Ubuntu):
status: Fix Committed → Invalid
Changed in glibc (Ubuntu Focal):
status: Invalid → In Progress
assignee: nobody → Balint Reczey (rbalint)
Changed in apt (Ubuntu):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Bionic):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Bionic):
status: Confirmed → Invalid
status: Invalid → Confirmed
tags: removed: rls-ff-incoming
elouan (elouan44444) on 2020-10-01
Changed in glibc (Ubuntu):
assignee: nobody → elouan (elouan44444)
status: Invalid → Confirmed
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Steve Langasek (vorlon) on 2020-10-01
Changed in glibc (Ubuntu):
status: Fix Committed → Invalid
assignee: elouan (elouan44444) → nobody
Changed in apt (Ubuntu Bionic):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu):
status: Fix Committed → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Committed → Confirmed
Balint Reczey (rbalint) on 2020-10-01
Changed in glibc (Ubuntu Focal):
assignee: Balint Reczey (rbalint) → nobody
status: In Progress → Invalid
Changed in apt (Ubuntu Focal):
importance: Undecided → High
description: updated
Changed in glibc (Ubuntu):
status: Invalid → Fix Committed
Steve Langasek (vorlon) on 2020-10-02
Changed in glibc (Ubuntu):
status: Fix Committed → Invalid
Changed in glibc (Ubuntu):
status: Invalid → Fix Committed
Balint Reczey (rbalint) on 2020-10-02
summary: - Installation fails with Could not configure 'libc6:i386'. , E:Could not
- perform immediate configuration on 'libgcc-s1:i386'
+ Installation fails when "Install Third-Party Drivers" is selected with
+ Could not configure 'libc6:i386'. , E:Could not perform immediate
+ configuration on 'libgcc-s1:i386' message
summary: - Installation fails when "Install Third-Party Drivers" is selected with
- Could not configure 'libc6:i386'. , E:Could not perform immediate
- configuration on 'libgcc-s1:i386' message
+ Installation fails when "Install Third-Party Drivers" is selected
Changed in glibc (Ubuntu):
status: Fix Committed → Invalid
description: updated
Changed in glibc (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → Fix Committed
Changed in apt (Ubuntu):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in glibc (Ubuntu):
status: Fix Committed → Fix Released
Changed in glibc (Ubuntu Focal):
status: Invalid → Fix Released
achraf (yaakoub2021) on 2020-10-02
Changed in glibc (Ubuntu):
assignee: nobody → achraf (yaakoub2021)
assignee: achraf (yaakoub2021) → nobody
Steve Langasek (vorlon) on 2020-10-02
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
Changed in apt (Ubuntu):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Released → Confirmed
Changed in glibc (Ubuntu Focal):
status: Fix Released → Invalid
payam ghaffari (payamgh) on 2020-10-02
Changed in glibc (Ubuntu):
assignee: nobody → payam ghaffari (payamgh)
Steve Langasek (vorlon) on 2020-10-03
Changed in glibc (Ubuntu):
assignee: payam ghaffari (payamgh) → nobody
Changed in glibc (Ubuntu Focal):
status: Invalid → Confirmed
Andrzej Jonczy (andree0) on 2020-10-03
Changed in apt (Ubuntu):
assignee: nobody → Andrzej Jonczy (andree0)
status: Confirmed → New
Changed in glibc (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in glibc (Ubuntu):
status: Invalid → Fix Released
Changed in apt (Ubuntu):
status: New → Fix Released
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Bionic):
assignee: nobody → Andrzej Jonczy (andree0)
Changed in apt (Ubuntu Focal):
assignee: nobody → Andrzej Jonczy (andree0)
Changed in glibc (Ubuntu):
assignee: nobody → Andrzej Jonczy (andree0)
Changed in glibc (Ubuntu Bionic):
assignee: nobody → Andrzej Jonczy (andree0)
Changed in glibc (Ubuntu Focal):
assignee: nobody → Andrzej Jonczy (andree0)
Steve Langasek (vorlon) on 2020-10-03
Changed in apt (Ubuntu):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in apt (Ubuntu Bionic):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in glibc (Ubuntu):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in apt (Ubuntu Focal):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in glibc (Ubuntu Bionic):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in glibc (Ubuntu Focal):
assignee: Andrzej Jonczy (andree0) → nobody
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
Changed in apt (Ubuntu):
status: Fix Released → Confirmed
Changed in glibc (Ubuntu Focal):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Released → Confirmed
Changed in glibc (Ubuntu Focal):
status: Confirmed → Invalid
Changed in glibc (Ubuntu):
assignee: nobody → Nyi Zaw Htet (nyizawhtet)
status: Invalid → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
Steve Langasek (vorlon) on 2020-10-06
Changed in glibc (Ubuntu):
assignee: Nyi Zaw Htet (nyizawhtet) → nobody
Chit San Maung (csm068) on 2020-10-06
Changed in apt (Ubuntu):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in glibc (Ubuntu Focal):
status: Invalid → Fix Released
Changed in glibc (Ubuntu):
status: Invalid → Fix Released
Steve Langasek (vorlon) on 2020-10-06
Changed in apt (Ubuntu):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Released → Confirmed
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
Changed in glibc (Ubuntu Focal):
status: Fix Released → Invalid
Changed in glibc (Ubuntu):
assignee: nobody → Harsh Dudhat (dudhat-harsh)
Changed in glibc (Ubuntu):
assignee: Harsh Dudhat (dudhat-harsh) → nobody
Changed in apt (Ubuntu):
status: Confirmed → In Progress
Balint Reczey (rbalint) on 2020-10-09
description: updated
Changed in apt (Ubuntu):
importance: High → Medium
Changed in apt (Ubuntu Focal):
importance: High → Medium
Changed in apt (Ubuntu):
importance: Medium → High
Changed in apt (Ubuntu Focal):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in glibc (Ubuntu):
status: Invalid → Fix Released
Changed in glibc (Ubuntu Focal):
status: Invalid → Fix Released
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
Changed in apt (Ubuntu Focal):
status: Fix Released → Triaged
Changed in apt (Ubuntu Bionic):
status: Confirmed → Triaged
Changed in glibc (Ubuntu Bionic):
status: Fix Released → Invalid
Changed in glibc (Ubuntu Focal):
status: Fix Released → Invalid
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
exelvi (exelvi) on 2020-10-11
Changed in ubuntu-cdimage:
assignee: nobody → exelvi (exelvi)
Steve Langasek (vorlon) on 2020-10-11
Changed in ubuntu-cdimage:
assignee: exelvi (exelvi) → nobody
tags: added: fr-779
Bayrmagnai (royalbayraa) on 2020-10-18
Changed in glibc (Ubuntu):
assignee: nobody → Bayrmagnai (royalbayraa)
assignee: Bayrmagnai (royalbayraa) → nobody
Changed in apt (Ubuntu):
status: In Progress → Fix Committed
description: updated
description: updated
Changed in glibc (Ubuntu):
assignee: nobody → KUNTAL KANTI SWAR (kkswar)
Steve Langasek (vorlon) on 2020-10-21
Changed in glibc (Ubuntu):
assignee: KUNTAL KANTI SWAR (kkswar) → nobody
summary: - Installation fails when "Install Third-Party Drivers" is selected
+ Installation fails due to useless immediate configuration error when
+ "Install Third-Party Drivers" is selected
Changed in apt (Debian):
status: Unknown → Fix Released
Timo Aaltonen (tjaalton) on 2020-10-23
Changed in apt (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-groovy
hossein (moghadasi) on 2020-10-26
Changed in glibc (Ubuntu):
assignee: nobody → hossein (moghadasi)
Changed in glibc (Ubuntu):
assignee: hossein (moghadasi) → nobody
Changed in glibc (Ubuntu):
assignee: nobody → Ahmed Mohamed Tayel (atayel18)
Steve Langasek (vorlon) on 2020-10-31
Changed in glibc (Ubuntu):
assignee: Ahmed Mohamed Tayel (atayel18) → nobody
Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
duong xuan minh (mrminh) on 2020-11-08
Changed in apt (Ubuntu):
assignee: nobody → duong xuan minh (mrminh)
Changed in apt (Ubuntu Groovy):
assignee: nobody → duong xuan minh (mrminh)
Changed in apt (Ubuntu Groovy):
assignee: duong xuan minh (mrminh) → nobody
Changed in apt (Ubuntu):
assignee: duong xuan minh (mrminh) → nobody
Changed in glibc (Ubuntu):
assignee: nobody → irakli chubinidze (skrdxx12)
Changed in glibc (Ubuntu):
assignee: irakli chubinidze (skrdxx12) → nobody
Simeon (simeon0806) on 2020-11-09
Changed in glibc (Ubuntu):
assignee: nobody → Simeon (simeon0806)
Changed in glibc (Ubuntu Focal):
assignee: nobody → Simeon (simeon0806)
Changed in apt (Ubuntu):
assignee: nobody → Simeon (simeon0806)
Steve Langasek (vorlon) on 2020-11-09
Changed in glibc (Ubuntu Focal):
assignee: Simeon (simeon0806) → nobody
Changed in glibc (Ubuntu):
assignee: Simeon (simeon0806) → nobody
Changed in apt (Ubuntu):
assignee: Simeon (simeon0806) → nobody
etr ange (etrange) on 2020-11-16
Changed in glibc (Ubuntu):
status: Invalid → Incomplete
Changed in apt (Ubuntu Bionic):
status: Triaged → Fix Released
Changed in apt (Ubuntu Focal):
status: Triaged → Fix Released
Changed in glibc (Ubuntu):
status: Incomplete → Fix Released
Steve Langasek (vorlon) on 2020-11-16
Changed in apt (Ubuntu Bionic):
status: Fix Released → Triaged
Changed in apt (Ubuntu Focal):
status: Fix Released → Triaged
Changed in glibc (Ubuntu):
status: Fix Released → Invalid
Mathew Hodson (mhodson) on 2020-11-23
no longer affects: glibc (Ubuntu)
no longer affects: glibc (Ubuntu Bionic)
no longer affects: glibc (Ubuntu Focal)
affects: glibc → ubuntu-translations
no longer affects: ubuntu-translations
Mathew Hodson (mhodson) on 2020-11-23
Changed in apt (Ubuntu Bionic):
importance: Undecided → Medium
Changed in apt (Ubuntu Groovy):
importance: Undecided → Medium
Mathew Hodson (mhodson) on 2020-11-23
Changed in apt (Debian):
status: Fix Released → Unknown
Changed in apt (Ubuntu):
status: Fix Released → Fix Committed
Changed in apt (Ubuntu Groovy):
status: Fix Committed → Triaged
Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
Changed in apt (Ubuntu Bionic):
status: Triaged → Incomplete
status: Incomplete → New
status: New → Fix Released
Changed in apt (Ubuntu Focal):
status: Triaged → Fix Released
Changed in apt (Ubuntu Groovy):
status: Triaged → Fix Released
Changed in apt (Ubuntu Groovy):
status: Fix Released → Triaged
Changed in apt (Ubuntu Bionic):
status: Fix Released → New
Changed in apt (Ubuntu Focal):
status: Fix Released → Triaged
enes (ekko52) on 2020-11-30
Changed in ubuntu-cdimage:
assignee: nobody → enes (ekko52)
Changed in apt (Ubuntu):
assignee: nobody → enes (ekko52)
Changed in apt (Ubuntu Focal):
assignee: nobody → enes (ekko52)
Changed in apt (Ubuntu Bionic):
assignee: nobody → enes (ekko52)
Changed in apt (Ubuntu Groovy):
assignee: nobody → enes (ekko52)
dann frazier (dannf) on 2020-11-30
Changed in ubuntu-cdimage:
assignee: enes (ekko52) → nobody
Changed in apt (Ubuntu):
assignee: enes (ekko52) → nobody
Changed in apt (Ubuntu Bionic):
assignee: enes (ekko52) → nobody
Changed in apt (Ubuntu Focal):
assignee: enes (ekko52) → nobody
Changed in apt (Ubuntu Groovy):
assignee: enes (ekko52) → nobody
Changed in apt (Ubuntu Bionic):
status: New → Confirmed
Changed in ubuntu-cdimage:
assignee: nobody → William Chin (wmchin2003)
Steve Langasek (vorlon) on 2020-12-04
Changed in ubuntu-cdimage:
assignee: William Chin (wmchin2003) → nobody
Shiroe (shiroe26102001) on 2020-12-04
Changed in ubuntu-cdimage:
assignee: nobody → Shiroe (shiroe26102001)
Steve Langasek (vorlon) on 2020-12-04
Changed in ubuntu-cdimage:
assignee: Shiroe (shiroe26102001) → nobody
Changed in ubuntu-cdimage:
assignee: nobody → Stanislav (stanislav1590)
Steve Langasek (vorlon) on 2020-12-06
Changed in ubuntu-cdimage:
assignee: Stanislav (stanislav1590) → nobody
AoimeDaiki (aomine-1122) on 2020-12-10
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Focal):
status: Triaged → Fix Released
Changed in apt (Ubuntu Groovy):
status: Triaged → Fix Released
dann frazier (dannf) on 2020-12-10
Changed in apt (Ubuntu Focal):
status: Fix Released → Triaged
Changed in apt (Ubuntu Groovy):
status: Fix Released → Triaged
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
Changed in apt (Ubuntu):
assignee: nobody → Joris Melis (joris-melis)
assignee: Joris Melis (joris-melis) → nobody
Changed in ubuntu-cdimage:
assignee: nobody → Abdelrahman Moharram (abd0)
Steve Langasek (vorlon) on 2020-12-13
Changed in ubuntu-cdimage:
assignee: Abdelrahman Moharram (abd0) → nobody
Changed in apt (Ubuntu):
assignee: nobody → Sebastián Astudillo (zhoku)
Changed in apt (Ubuntu):
assignee: Sebastián Astudillo (zhoku) → nobody
alvaro (alvariturituro) on 2020-12-16
Changed in ubuntu-cdimage:
assignee: nobody → alvaro (alvariturituro)
Steve Langasek (vorlon) on 2020-12-16
Changed in ubuntu-cdimage:
assignee: alvaro (alvariturituro) → nobody
Changed in apt (Ubuntu Focal):
status: Triaged → Fix Released
Changed in apt (Ubuntu Groovy):
status: Triaged → Fix Released
assignee: nobody → Muhammad Raihan Abdul Mughnii (rrhanam)
Changed in apt (Ubuntu Focal):
assignee: nobody → Muhammad Raihan Abdul Mughnii (rrhanam)
assignee: Muhammad Raihan Abdul Mughnii (rrhanam) → nobody
Changed in apt (Ubuntu Groovy):
assignee: Muhammad Raihan Abdul Mughnii (rrhanam) → nobody
Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Released
Changed in apt (Ubuntu Groovy):
status: Fix Released → Triaged
Changed in apt (Ubuntu Focal):
status: Fix Released → Triaged
Changed in apt (Ubuntu Bionic):
status: Fix Released → Confirmed
status: Confirmed → New
Changed in apt (Ubuntu Bionic):
status: New → Confirmed
Changed in apt (Ubuntu Focal):
importance: Medium → High
milestone: none → ubuntu-20.04.2
119 comments hidden view all 199 comments
Oliver Grawert (ogra) wrote :

@kosharskiy this is completely unrelated to this installer bug (which is about configuring packages prior to/during install time), you should open a new bug for your issue ...

No, i'm faced this installer bug and it redirected me to this bug report. But i've found configuration when i can install OS, but i can't update my freshly installed system because it will not boot

Burak (metinburak) wrote :

Asus Ryzen 7 4800H geforce gtx 1660ti install third party drivers ubuntu 20.04 installation crashed and i have been directed here. Hope it will be solved in a short time. Very bad not to be able to install an OS directly to a user level pc in 2020 space flight age.

Peter Klein (pdklein800) wrote :

I have performed the installation several times. It only happens with either a BT 4 or a BT 5 dongle. Bluetooth 4 is CRS. Bluetooth 5 is mediatek.

I got this same bug when trying to reinstall Ubuntu 20.10.04 LTS after a dual boot Windows install had killed my ubuntu. I have Nvidia and I did chose to download drivers during install. How do we solve this problem? Is there a valid workaround?

Also I hate to say this but how on earth is this bug classified as "Fix Released" despite happening on a fresh Ubuntu image install?

star hvh (starhvh) on 2020-12-22
Changed in apt (Ubuntu):
assignee: nobody → star hvh (starhvh)
Steve Langasek (vorlon) on 2020-12-22
Changed in apt (Ubuntu):
assignee: star hvh (starhvh) → nobody
Changed in apt (Ubuntu):
assignee: nobody → ahmedtarek (ahmedtarek156)
Changed in apt (Ubuntu Bionic):
assignee: nobody → ahmedtarek (ahmedtarek156)
Changed in apt (Ubuntu Focal):
assignee: nobody → ahmedtarek (ahmedtarek156)
Changed in apt (Ubuntu Groovy):
assignee: nobody → ahmedtarek (ahmedtarek156)
status: Triaged → Incomplete
Changed in ubuntu-cdimage:
assignee: nobody → ahmedtarek (ahmedtarek156)
Steve Langasek (vorlon) on 2020-12-27
Changed in apt (Ubuntu Groovy):
status: Incomplete → Triaged
Changed in ubuntu-cdimage:
assignee: ahmedtarek (ahmedtarek156) → nobody
Changed in apt (Ubuntu Bionic):
assignee: ahmedtarek (ahmedtarek156) → nobody
Changed in apt (Ubuntu):
assignee: ahmedtarek (ahmedtarek156) → nobody
Changed in apt (Ubuntu Focal):
assignee: ahmedtarek (ahmedtarek156) → nobody
Changed in apt (Ubuntu Groovy):
assignee: ahmedtarek (ahmedtarek156) → nobody
Deva Venga (devaone) on 2020-12-29
Changed in apt (Ubuntu):
assignee: nobody → Deva Venga (devaone)
Changed in apt (Ubuntu):
assignee: Deva Venga (devaone) → nobody
Changed in ubuntu-cdimage:
assignee: nobody → Pedro Tavares (cantattore)
Steve Langasek (vorlon) on 2021-01-02
Changed in ubuntu-cdimage:
assignee: Pedro Tavares (cantattore) → nobody
Eric Mintz (mintz-eric) wrote :

Cannot contribute much because the desktop is completely blank (except for the background) and a black bar at the top. There is no "Activities" control. Even worse, the mouse pointer is the spinning Ubuntu disk. I can click on the date, which is right.

I will reboot and see what happens. Please wish me luck.

jason mercer (jasdace) on 2021-01-05
Changed in ubuntu-cdimage:
assignee: nobody → jason mercer (jasdace)
dann frazier (dannf) on 2021-01-05
Changed in ubuntu-cdimage:
assignee: jason mercer (jasdace) → nobody
Parker Grytdal (pgrytdal) wrote :

Just hit this bug on Ubuntu MATE 20.10

Parker Grytdal (pgrytdal) wrote :

Tagging onto my previous post (https://bugs.launchpad.net/ubuntu-cdimage/+bug/1871268/comments/167) I am on a Nvidia GTX 2060

Changed in apt (Ubuntu Bionic):
status: Confirmed → Fix Committed
Changed in apt (Ubuntu Focal):
status: Triaged → Fix Committed
Changed in apt (Ubuntu Groovy):
status: Triaged → Fix Released
Changed in apt (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in apt (Ubuntu Bionic):
status: Fix Committed → Fix Released
Laurent Zibell (laurentzib) wrote :

Same problem with a Dell G5. Installing Ubuntu 20.04 from an USB stick with options "connected to the Internet" and "download third-party packages"

Changed in apt (Ubuntu Bionic):
status: Fix Released → In Progress
Changed in apt (Ubuntu):
status: Fix Released → In Progress
Changed in apt (Ubuntu Focal):
status: Fix Released → In Progress
Changed in apt (Ubuntu Groovy):
status: Fix Released → In Progress
Julian Andres Klode (juliank) wrote :

I think we have the final fix now that covers every case and not just the corner case with libc6:i386. It now just ignores those errors, which as we can see works out fine in the end, because the failures occur after installing because the error was never correctly propagated to the caller.

A later code segment actually checks that everything is configured, so this is as safe as we can get, and best of all, it can't really regress stuff, since it does not change the actual ordering :)

description: updated
Changed in apt (Ubuntu):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

14:32 < juliank> sil2100: everything is straight forward cherry-picked from master, which is 2.1.18

Changed in apt (Ubuntu):
status: Fix Committed → Fix Released

Hello andresgenovez, or anyone else affected,

Accepted apt into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/2.1.10ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in apt (Ubuntu Groovy):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello andresgenovez, or anyone else affected,

Accepted apt into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/2.0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in apt (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
1 comments hidden view all 199 comments

All autopkgtests for the newly accepted apt (2.1.10ubuntu0.2) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

reprotest/0.7.15 (amd64, arm64, s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#apt

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted apt (2.0.4) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

gcc-10/10.2.0-5ubuntu1~20.04 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#apt

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Changed in apt (Ubuntu Focal):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2021-01-15
Changed in apt (Ubuntu Focal):
status: Fix Released → Fix Committed
Changed in apt (Ubuntu):
assignee: nobody → islam elalani (i.s.l.a.m)
Changed in apt (Ubuntu Focal):
status: Fix Committed → Fix Released
dann frazier (dannf) on 2021-01-15
Changed in apt (Ubuntu Focal):
status: Fix Released → Fix Committed
Changed in apt (Ubuntu):
assignee: islam elalani (i.s.l.a.m) → nobody
Download full text (11.8 KiB)

There definitely seems to be an issue here:

[ 88.448840] ------------[ cut here ]------------
[ 88.448842] nouveau 0000:01:00.0: timeout
[ 88.448887] WARNING: CPU: 3 PID: 1177 at
/build/linux-hwe-5.4-hNUtrM/linux-hwe-5.4-5.4.0/drivers/gpu/drm/nouveau/nvkm/falcon/v1.c:313
nvkm_falcon_v1_clear_interrupt+0xe6/0x100 [nouveau]
[ 88.448887] Modules linked in: cmac bnep snd_hda_codec_hdmi
snd_soc_hdac_hdmi snd_hda_codec_realtek snd_hda_codec_generic snd_soc_dmic
snd_sof_pci snd_sof_intel_hda_common snd_soc_hdac_hda snd_sof_intel_hda
snd_sof_intel_byt snd_sof_intel_ipc snd_sof snd_sof_xtensa_dsp
snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi ledtrig_audio
snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine nls_iso8859_1 joydev
hid_multitouch 8250_dw mei_hdcp intel_rapl_msr x86_pkg_temp_thermal
intel_powerclamp coretemp kvm_intel snd_hda_intel snd_intel_dspcfg uvcvideo
kvm iwlmvm snd_seq_midi snd_seq_midi_event snd_hda_codec videobuf2_vmalloc
rapl input_leds snd_hda_core snd_rawmidi mac80211 videobuf2_memops btusb
snd_hwdep videobuf2_v4l2 btrtl videobuf2_common asus_nb_wmi btbcm asus_wmi
btintel intel_cstate libarc4 serio_raw sparse_keymap wmi_bmof videodev
snd_seq snd_pcm bluetooth iwlwifi mc snd_seq_device snd_timer snd
processor_thermal_device mei_me ecdh_generic intel_rapl_common
intel_lpss_pci ecc
[ 88.448901] cfg80211 intel_lpss idma64 mei virt_dma soundcore
intel_soc_dts_iosf intel_pch_thermal int3403_thermal int340x_thermal_zone
mac_hid int3400_thermal acpi_pad asus_wireless acpi_thermal_rel
sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4
algif_skcipher af_alg dm_crypt hid_generic usbhid nouveau i915
crct10dif_pclmul crc32_pclmul mxm_wmi ghash_clmulni_intel ttm i2c_algo_bit
aesni_intel drm_kms_helper crypto_simd syscopyarea sysfillrect nvme
sysimgblt cryptd fb_sys_fops glue_helper drm r8169 ahci nvme_core realtek
libahci i2c_hid wmi video hid pinctrl_cannonlake pinctrl_intel
[ 88.448913] CPU: 3 PID: 1177 Comm: gnome-shell Not tainted
5.4.0-62-generic #70~18.04.1-Ubuntu
[ 88.448914] Hardware name: ASUSTeK COMPUTER INC. TUF Gaming
FX705GE_FX705GE/FX705GE, BIOS FX705GE.302 11/16/2018
[ 88.448929] RIP: 0010:nvkm_falcon_v1_clear_interrupt+0xe6/0x100 [nouveau]
[ 88.448930] Code: 45 b0 48 8b 40 10 48 8b 78 10 48 8b 5f 50 48 85 db 74
1b e8 3c 35 d6 c7 48 89 da 48 89 c6 48 c7 c7 ba c7 af c0 e8 2a 7f 70 c7
<0f> 0b eb a8 48 8b 1f eb e0 e8 fc 81 70 c7 66 90 66 2e 0f 1f 84 00
[ 88.448930] RSP: 0018:ffffb912c1447a08 EFLAGS: 00010282
[ 88.448931] RAX: 0000000000000000 RBX: ffff9b3ad8cfdb70 RCX:
0000000000000006
[ 88.448931] RDX: 0000000000000007 RSI: 0000000000000096 RDI:
ffff9b3add8d78c0
[ 88.448932] RBP: ffffb912c1447a58 R08: 00000000000003e9 R09:
0000000000000004
[ 88.448932] R10: 000000000000002c R11: 0000000000000001 R12:
ffff9b3aca5aab00
[ 88.448933] R13: 0000000000000010 R14: ffffffffffffff92 R15:
00000000ffffffff
[ 88.448933] FS: 00007ff79ae03ac0(0000) GS:ffff9b3add8c0000(0000)
knlGS:0000000000000000
[ 88.448934] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 88.448934] CR2: 000000c42085b000 CR3: 0000000850710002 CR4:
00000000003606e0
[ 88.448935] Call Trace:
[ 88.448950] ...

Leon Pappas (nephilim9) wrote :
Download full text (11.8 KiB)

I don't believe that this is fixed. I am still getting errors:

[ 88.448840] ------------[ cut here ]------------
[ 88.448842] nouveau 0000:01:00.0: timeout
[ 88.448887] WARNING: CPU: 3 PID: 1177 at
/build/linux-hwe-5.4-hNUtrM/linux-hwe-5.4-5.4.0/drivers/gpu/drm/nouveau/nvkm/falcon/v1.c:313
nvkm_falcon_v1_clear_interrupt+0xe6/0x100 [nouveau]
[ 88.448887] Modules linked in: cmac bnep snd_hda_codec_hdmi
snd_soc_hdac_hdmi snd_hda_codec_realtek snd_hda_codec_generic snd_soc_dmic
snd_sof_pci snd_sof_intel_hda_common snd_soc_hdac_hda snd_sof_intel_hda
snd_sof_intel_byt snd_sof_intel_ipc snd_sof snd_sof_xtensa_dsp
snd_hda_ext_core snd_soc_acpi_intel_match snd_soc_acpi ledtrig_audio
snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine nls_iso8859_1 joydev
hid_multitouch 8250_dw mei_hdcp intel_rapl_msr x86_pkg_temp_thermal
intel_powerclamp coretemp kvm_intel snd_hda_intel snd_intel_dspcfg uvcvideo
kvm iwlmvm snd_seq_midi snd_seq_midi_event snd_hda_codec videobuf2_vmalloc
rapl input_leds snd_hda_core snd_rawmidi mac80211 videobuf2_memops btusb
snd_hwdep videobuf2_v4l2 btrtl videobuf2_common asus_nb_wmi btbcm asus_wmi
btintel intel_cstate libarc4 serio_raw sparse_keymap wmi_bmof videodev
snd_seq snd_pcm bluetooth iwlwifi mc snd_seq_device snd_timer snd
processor_thermal_device mei_me ecdh_generic intel_rapl_common
intel_lpss_pci ecc
[ 88.448901] cfg80211 intel_lpss idma64 mei virt_dma soundcore
intel_soc_dts_iosf intel_pch_thermal int3403_thermal int340x_thermal_zone
mac_hid int3400_thermal acpi_pad asus_wireless acpi_thermal_rel
sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4
algif_skcipher af_alg dm_crypt hid_generic usbhid nouveau i915
crct10dif_pclmul crc32_pclmul mxm_wmi ghash_clmulni_intel ttm i2c_algo_bit
aesni_intel drm_kms_helper crypto_simd syscopyarea sysfillrect nvme
sysimgblt cryptd fb_sys_fops glue_helper drm r8169 ahci nvme_core realtek
libahci i2c_hid wmi video hid pinctrl_cannonlake pinctrl_intel
[ 88.448913] CPU: 3 PID: 1177 Comm: gnome-shell Not tainted
5.4.0-62-generic #70~18.04.1-Ubuntu
[ 88.448914] Hardware name: ASUSTeK COMPUTER INC. TUF Gaming
FX705GE_FX705GE/FX705GE, BIOS FX705GE.302 11/16/2018
[ 88.448929] RIP: 0010:nvkm_falcon_v1_clear_interrupt+0xe6/0x100 [nouveau]
[ 88.448930] Code: 45 b0 48 8b 40 10 48 8b 78 10 48 8b 5f 50 48 85 db 74
1b e8 3c 35 d6 c7 48 89 da 48 89 c6 48 c7 c7 ba c7 af c0 e8 2a 7f 70 c7
<0f> 0b eb a8 48 8b 1f eb e0 e8 fc 81 70 c7 66 90 66 2e 0f 1f 84 00
[ 88.448930] RSP: 0018:ffffb912c1447a08 EFLAGS: 00010282
[ 88.448931] RAX: 0000000000000000 RBX: ffff9b3ad8cfdb70 RCX:
0000000000000006
[ 88.448931] RDX: 0000000000000007 RSI: 0000000000000096 RDI:
ffff9b3add8d78c0
[ 88.448932] RBP: ffffb912c1447a58 R08: 00000000000003e9 R09:
0000000000000004
[ 88.448932] R10: 000000000000002c R11: 0000000000000001 R12:
ffff9b3aca5aab00
[ 88.448933] R13: 0000000000000010 R14: ffffffffffffff92 R15:
00000000ffffffff
[ 88.448933] FS: 00007ff79ae03ac0(0000) GS:ffff9b3add8c0000(0000)
knlGS:0000000000000000
[ 88.448934] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 88.448934] CR2: 000000c42085b000 CR3: 0000000850710002 CR4:
00000000003606e0
[ 88.448935] Call Trac...

Tried to install 2021-01-17... Failure. But I could get into terminal mode. What to add to complete the installation.

It would be useful to have a patch/script file that I could run in terminal mode that would perform all the corrections.

Julian Andres Klode (juliank) wrote :

I updated my focal to 2.0.4 and groovy to 2.1.10ubuntu0.2, and ran /usr/lib/apt/planners/apt on the eipp.log file and there are no errors any more.

tags: added: verification-done verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-focal verification-needed-groovy
Shamindra (wy-354) on 2021-01-19
Changed in ubuntu-cdimage:
assignee: nobody → Shamindra (wy-354)
Iain Lane (laney) on 2021-01-19
Changed in ubuntu-cdimage:
assignee: Shamindra (wy-354) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 2.1.10ubuntu0.2

---------------
apt (2.1.10ubuntu0.2) groovy; urgency=medium

  [ JCGoran ]
  * Fix "extended_states" typo in apt-mark(8) (Closes: #969086)

  [ Jordi Mallach ]
  * Fix typo in Catalan translation.

  [ Julian Andres Klode ]
  * doc: Bump Ubuntu release from focal to groovy
  * pkgnames: Correctly set the default for AllNames to false, and do not
    exclude virtual packages if --all-names is specified (LP: #1876495)
  * Remove expired domain that became nsfw from debian/changelog
  * patterns: Terminate short pattern by ~ and ! (LP: #1911676)
  * Improve immediate configuration handling (LP: #1871268)
    - Do not immediately configure m-a: same packages in lockstep
    - Ignore failures from immediate configuration. This does not change the
      actual installation ordering - we never passed the return code to the
      caller and installation went underway anyway if it could be ordered at a
      later stage, this just removes spurious after-the-fact errors.

  [ Frans Spiesschaert ]
  * Dutch manpages translation update (Closes: #970037)

  [ Américo Monteiro ]
  * Portuguese manpages translation update (Closes: #968414)

  [ Helge Kreutzmann ]
  * German program translation update (Closes: #977938)

  [ Vangelis Skarmoutsos ]
  * Greek program translation update

 -- Julian Andres Klode <email address hidden> Thu, 14 Jan 2021 12:29:25 +0100

Changed in apt (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apt has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 2.0.4

---------------
apt (2.0.4) focal; urgency=medium

  [ Julian Andres Klode ]
  * Merge 2.0.2ubuntu0.1 and 2.0.2ubuntu0.2 security updates with 2.0.3
    release.
  * pkgnames: Correctly set the default for AllNames to false, and do not
    exclude virtual packages if --all-names is specified (LP: #1876495)
  * Remove expired domain that became nsfw from debian/changelog
  * patterns: Terminate short pattern by ~ and ! (LP: #1911676)
  * Improve immediate configuration handling (LP: #1871268)
    - Do not immediately configure m-a: same packages in lockstep
    - Ignore failures from immediate configuration. This does not change the
      actual installation ordering - we never passed the return code to the
      caller and installation went underway anyway if it could be ordered at a
      later stage, this just removes spurious after-the-fact errors.

  [ JCGoran ]
  * Fix "extended_states" typo in apt-mark(8) (Closes: #969086)

apt (2.0.3) focal; urgency=medium

  [ Frans Spiesschaert ]
  * Dutch manpages translation update (Closes: #956313)

  [ David Kalnischkies ]
  * Add correct std namespace to nullptr_t

  [ Julian Andres Klode ]
  * Reinstate * wildcards (Closes: #953531) (LP: #1872200)
  * apt list: Fix behavior of regex vs fnmatch vs wildcards
  * debian/gbp.conf: We're in the 2.0.y branch
  * CI: Test on ubuntu:focal, not debian:unstable

 -- Julian Andres Klode <email address hidden> Thu, 14 Jan 2021 12:49:00 +0100

Changed in apt (Ubuntu Focal):
status: Fix Committed → Fix Released

I'im using ubuntu image ,booted to usb using rufus

Daham Soysa (dahamsoysa) on 2021-01-23
Changed in ubuntu-cdimage:
assignee: nobody → Daham Soysa (dahamsoysa)
Steve Langasek (vorlon) on 2021-01-23
Changed in ubuntu-cdimage:
assignee: Daham Soysa (dahamsoysa) → nobody
Changed in apt (Ubuntu):
assignee: nobody → Hunter Temple (xdieagainx)
Steve Langasek (vorlon) on 2021-01-24
Changed in apt (Ubuntu):
assignee: Hunter Temple (xdieagainx) → nobody
rew (r-e-wolff) wrote :

Guys..... What I don't get is that it is 2021 now, this bug has been reported (in 2019) and is tagged "fixed" and still the installer "crashed" and tells me it is this bug that is happening.....

This happens to me on a "clean" machine. I unplugged my harddisk, only have an SSD installed now. The installer image I downloaded yesterday (jan 23 2021).

John Chittum (jchittum) wrote :

reinstall attempted today. CD image downloaded on 20210124 and USB created via Rufus on Windows. Attempted install, indicated Install Third-Party Drivers. Crashed at the very end, after updating packages. hardware is a System 76 Gazelle (2019).

Jerry May (qd0t) wrote :

Install attempted today. CD image downloaded on 2021-01-23 and USB created via Rufus on Windows. Attempted install, indicated Install Third-Party Drivers. Crashed at the very end, after updating packages.

System is HP Omen 17-cb0070nr video=nVidia GeForce RTX2060
SecureBoot is OFF LegacyBoot is NOT enabled

But works just fine on HP Probook 6460b.
Next step: try with InstallThirdPartyDrivers DISABLED.

On January 24, 2021 12:12:19 AM PST, rew <email address hidden> wrote:
>Guys..... What I don't get is that it is 2021 now, this bug has been
>reported (in 2019)

It was not reported in 2019, it was reported in 2020.

The bug did not affect Ubuntu 20.04 at GA release time. The bug was noticed and escalated only once there was an SRU of glibc in focal-updates newer than what was on the release media, and took time to fix in apt.

There has not yet been a point release of focal with this fixed version of apt. It will be included in 20.04.2 which will be released in 2 weeks.

> and is tagged "fixed" and still the installer
>"crashed" and tells me it is this bug that is happening.....

It is marked fixed in apt. It is not marked fixed in ubuntu-cdimage.

The bug is fixed in daily images of focal, but these are not recommended for general use as they have the -proposed pocket enabled which is not the case for release images.

B. C. Schmerker (bcschmerker) wrote :

I confirm this problem still active in the latest Release ISO images for 20.04.1-LTS. Obviously a regression consistent with the ~vorlon observation(s) -- didn't happen in 19.04 or 19.10. Involves PluginInstall.py failing to find exact versions of several packages, although I's unable to screen-shot prior to Installer terminating. Even with the ~qd0t workaround, openlp crashes on open, which didn't happen on 18.04.4-LTS.

Attempted clean install on four partitions: /boot (ext2), 4 GiB swap, /home (ext4), / (ext4)
emachines/acer EL1210-09 (Acer DA078L)
Advance Micro Devices Athlon 64 LE-1620 (P/N AD1620IAA5DH)
nVIDIA nForce 780a MCP (C77 64-bit geForce GPU in northbridge)
msi GT610-1GD3-LP (nVIDIA GF119 64-bit GPU, 1 GiB DDR3 VRAM)

Anton (anton7) wrote :

Until the new images are available:
Just update apt of the live system before installing and the installation should work.

For those who don't know how to:
Start Live-System/ISO-Image with internet connected
Choose "Try Ubuntu"
Open "Terminal"
Type:
 sudo apt-get update
 sudo apt-get install apt
Then start installation of Ubuntu with your favourite options - even with third party drivers.

Thanh Nguyen (32nguyen) on 2021-01-28
Changed in ubuntu-cdimage:
assignee: nobody → Thanh Nguyen (32nguyen)
Steve Langasek (vorlon) on 2021-01-28
Changed in ubuntu-cdimage:
assignee: Thanh Nguyen (32nguyen) → nobody
Ralph Houston (ralphjfh) wrote :

Also have an NVidia graphics card and opted for 3rd party drivers. Will now try again without them.

Ralph Houston (ralphjfh) wrote :

Very superficial report, but methodical.
Installed and booted OK this time, from install as similar as possible to process that encountered bug.
Differences:
1. Installed from livedisk Ubuntu still running after install failure, rather than direct from boot.
2. Did not create partitions, but reformatted (same) destination.
3. Did not ask for proprietary third party drivers.
So suspect the issuse is indeed in the the drivers and probably the NVidia one, from past experience.

B. C. Schmerker (bcschmerker) wrote :

No longer affects openlp 2.4.0 and 2.4.6, which OpenLP at GitLab has declared a WontFix. Awaiting 2.9.1 (unreleased as of 29 January 2021) for focal-proposed, groovy-proposed, and hirsute-proposed. I's able to get the EL1210-09 fully up by cherrypicking packages appropriate for nVIDIA 390.nn from the focal Repository, post-installation with nouveau.

Changed in apt (Ubuntu):
assignee: nobody → Hamid Heravi (hamid-heravi)
Steve Langasek (vorlon) on 2021-01-30
Changed in apt (Ubuntu):
assignee: Hamid Heravi (hamid-heravi) → nobody
Andrius KL (andrewdaman) on 2021-02-01
Changed in ubuntu-cdimage:
assignee: nobody → Andrius KL (andrewdaman)
dann frazier (dannf) on 2021-02-01
Changed in ubuntu-cdimage:
assignee: Andrius KL (andrewdaman) → nobody
Changed in ubuntu-cdimage:
assignee: nobody → davi gouvea santos (davi33)
Steve Langasek (vorlon) on 2021-02-02
Changed in ubuntu-cdimage:
assignee: davi gouvea santos (davi33) → nobody
Changed in ubuntu-cdimage:
assignee: nobody → jacqueline fairgrieve (jac9)
Steve Langasek (vorlon) on 2021-02-03
Changed in ubuntu-cdimage:
assignee: jacqueline fairgrieve (jac9) → nobody
Alf HP Lund (alf-c) wrote :

Confirming bug as of today on HP ZBook 15 G3 with NVIDIA M2000M with disk image downloaded yesterday from ubuntustudio.org https://cdimage.ubuntu.com/ubuntustudio/releases/20.04.1/release/ubuntustudio-20.04.1-dvd-amd64.iso.torrent

Alf HP Lund (alf-c) wrote :

Even though the installer crashed, powering off the machine and restarting sent me to a 'Perform MOK management' menu where I had to input my chosen password from the relevant step in the installation process. After that rebooting took me to the Grub menu and I could successfully start Ubuntu Studio.

After login there was a short flickering on the screen which I suspect could be the NVIDIA driver failing and falling back to the intel HD Graphics 530.

Leon Pappas (nephilim9) wrote :

I went along withe the whole mokutil route to get the NVidia drivers to
work but that failed to rectify the problem.

The GUI started having huge issues (Second monitor stopped working. GUI
would freeze and need a reboot). Tried reverting back to Nouveau and in
the process lost my server.. Gui stopped working completely.

Luckily I could still access the drive contents. and installed on a new
drive. Still not working 100% Second screen is detected but does not
work. I get a black screen with a white mouse pointer. I can drag a
window onto the monitor but if I release it it's gone. (I can't see
where it is to drag it back)

On 2021/02/04 20:37, Alf Haakon Lund wrote:
> Even though the installer crashed, powering off the machine and
> restarting sent me to a 'Perform MOK management' menu where I had to
> input my chosen password from the relevant step in the installation
> process. After that rebooting took me to the Grub menu and I could
> successfully start Ubuntu Studio.
>
> After login there was a short flickering on the screen which I suspect
> could be the NVIDIA driver failing and falling back to the intel HD
> Graphics 530.
>

information type: Public → Public Security
information type: Public Security → Public
affects: ubuntu-cdimage → ubuntubudgie
Steve Langasek (vorlon) on 2021-02-09
affects: ubuntubudgie → ubuntu-cdimage
rgonnering (roger-gonnering) wrote :

I have a new HP Envy TE-01 with Windows. Tried to load Ubuntu Studio 20.04 to dual boot. Installation crashed.

Samaun Parvez (parvez1) on 2021-02-13
Changed in ubuntu-cdimage:
assignee: nobody → Samaun Parvez (parvez1)
Steve Langasek (vorlon) on 2021-02-13
Changed in ubuntu-cdimage:
assignee: Samaun Parvez (parvez1) → nobody
Sebcio7 (sebcia7) wrote :

Installation of version 20.10 crashed on Acer Aspire V Nitro

Magnus Falk (jamfalk) wrote :

Hello,
The installer crashed during installation of Jamulus OS on my Seagate BarraCuda 510 M2 SSD from USB live image. The bug was already reported (3rd party drivers) but I have some extra hardware info in attached JamulusOS.txt-file if needed.
Thanks for an excellent work!
Yours Magnus Falk in Oslo, Norway

Changed in apt (Debian):
status: Unknown → Fix Released
Displaying first 40 and last 40 comments. View all 199 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.