Ubuntu Printer test page has old branding/isn't that useful

Bug #933489 reported by Paul Sladen on 2012-02-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bannertopdf
Undecided
Lars Karlitski
ubuntu-branding
Wishlist
Unassigned
cups-filters (Ubuntu)
High
Unassigned

Bug Description

(Filing here so that it doesn't get lost for another year!):

The current Ubuntu test page looks like:

  http://www.flickr.com/photos/nickj365/4125843224/
  /usr/share/system-config-printer/testpage-a4.ps (system-config-printer)
  /usr/share/system-config-printer/testpage-letter.ps (system-config-printer)

This uses the pre-2010 branding, and is sub-optimal because it uses up alot of ink (bug #298935). This page gets printed millions of times each year, so ideally it would be updated with the current Ubuntu branding, and hopefully make it more useful at the same time.

This was originally raised in the Ubuntu UK thread.

  "Ubuntu Printer test page"
  https://lists.ubuntu.com/archives/ubuntu-uk/2011-January/thread.html#28467

From which there were a number of suggestions, but definite PDFs/images produced afterwards.

  Same mailing list thread, but all in one page and linked to Popey's answer in particular:
  http://ubuntu.5.n6.nabble.com/Ubuntu-Printer-test-page-td1113087.html#postdropdown1113100

Ideally this really needs following up to try and incorporate some of the ideas raised into a new PDF.

Paul Sladen (sladen) wrote :

Subscribing Lars (via 'bannertopdf') since that's where it would need fixing.

description: updated
Lars Karlitski (larsu) on 2012-02-16
Changed in bannertopdf:
assignee: nobody → Lars Uebernickel (larsu)
status: New → Confirmed
Paul Sladen (sladen) wrote :

nb. Note to self (and other interested parties). William Jon McCann has started to collate a bunch of test pages at:

  https://live.gnome.org/GnomeOS/Design/Whiteboards/Printing/TestPage

Paul Sladen (sladen) on 2012-02-16
description: updated
description: updated
Paul Sladen (sladen) wrote :

Further nb. 'bannertopdf' is part of the 'cups-filters' package; the binary isn't in the path, but is in:

  /usr/lib/cups/filter/bannertopdf

Till Kamppeter (till-kamppeter) wrote :

The test page generated by bannertopdf is based on a template in the file /usr/share/cups/data/default-testpage.pdf which is also part of cups-filters. What has to be done is to replace /usr/share/cups/data/default-testpage.pdf in our cups-filters package by a branded file.

Adding cups-filters task ...

Changed in cups-filters (Ubuntu):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-12.04
Paul Sladen (sladen) wrote :

First version of a design from Emily Maher (Canonical Design). Nick Tait notes that:

  "It incorporates the following:

    CMYK, RGB and Greyscale colour blocks
    Ubuntu dot pattern
    Keyline for printer nozzle check"

  Emily has typeset the printer info in a set position using Ubuntu monospace.

Lars: can you auto-generate the bottom half from 'bannertopdf' at run-time?

Notes from looking at the PDF source:

  1. The RGB colours are being set using the 'K' command (CMYK colour operator), rather than 'RG' (RGB colour operator).
  2. There a massive load of RDF fluff that could be trimmed, including preview JPEGs
  3. Each dot is being drawn a separate push stack, set matrix, moveto 0,0 four arc commands, etc. This could be optimised a bit.
  4. The embedded font is referencing the name 'UbuntuMonospacedBeta'.

This are all minor technical issues and shouldn't affect the design/implementation.

Changed in ubuntu-branding:
status: Confirmed → Fix Committed
Paul Sladen (sladen) wrote :

Per Larsu request. Hand-hacked version of the above PDF with just the text at the top.

Paul Sladen (sladen) wrote :

Uncompressed version on which the manipulation was done. Converted to above with:

  $ pdftk emily-test-page-top-only-colourspace-operators.pdf output emily-test-page-top-only-colourspace-operators-compressed.pdf compress

in order to rebuild the stream lengths and xref. Following changes:

  1. Strip the XML metadata
  2. Use 'RG' and 'rg' operators for settings the RGB test colours; and 'G' and 'g' for the grayscale circle. Note that this will appear slightly differently on a monitor as the gamets are different, but it makes it marginally more useful as an actual test sheet since the test colours are being drawn in the right colourspace.
  3. Strip the non-free UbuntuMonoBeta embedded at the bottom. Fresh libre copies are available in the 'ttf-ubuntu-font-family' package (this leaves just subsetted UbuntuMedium).
  4. Remove the kerning overrides from the "Printer test page". It's better that if this is replaced, it still looks natural.
  5. Scatter some comments through out the drawing code to make later adjustment easier.
  6. Added some licensing information to the top: namely CC-BY-SA 3 (preferred libre content licence) and LGPL-2+ (same licence as 'cups-filters') to top.

Unfortunately the 'pdftk' rebuild is dropping that the copyright information. We can rebuild that later if required.

Carlo Piana (carlo-piana) wrote :

Seem a prototype circulated by Alan Pope

One of the things I'd miss if that was the test page, is the check on how shades are rendered and what the resolution is. also, the CUPS page shows the printable area. This is not a clever test page, this is a confirmation that printer prints in colors, which is more of a waste of ink because it's useless. What's in designers minds today? #fail methinks

Lars Karlitski (larsu) wrote :

Hi Carlo,

I wrote bannertopdf because the last few releases of Ubuntu didn't have a test page which showed printable margins and other important information. The attached page is the template onto which the margin and information is printed by bannertopdf.

What do you mean by shades? I don't think resolution is shown (it never was on CUPS' test page), please file a bug against bannertopdf if you want it.

cups-filters 1.0.2-1 with Ubuntu-branded test page uploaded.

Changed in cups-filters (Ubuntu):
status: Triaged → Fix Released
Lars Karlitski (larsu) wrote :

The new test page is the default in bannerotpdf upstream.

Changed in bannertopdf:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

Command for validating non-standard papersizes:

  lpr -P OJP8500 -o PageSize=Custom.595x421pt /usr/share/cups/data/testprint

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers