For some operators MMS is unreliable

Bug #1439101 reported by bailly on 2015-04-01
516
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
Ubuntu Mobile Phone
Undecided
Unassigned
messaging-app (Ubuntu)
Undecided
Unassigned
telephony-service (Ubuntu)
High
Unassigned

Bug Description

In France no MMS is received regardless of the operator used on bq aquaris E4.5 ubuntu Edition

For information, my operator is Free even if it seems it doesn't matter.

In the same time, let me tell you than I had detect than MMS didn't sent when WIFI is ON. I've read some other people who send the same information so it's seems to be a real bug.

Anyway, for resume, For send a MMS, it's OK whan WIFI is OFF, don'T if ON, and in all of case we don't receive MMS :-((

Thank's to you for fix it faster.

Sorry for my approximativ english.

Fabien

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in messaging-app (Ubuntu):
status: New → Confirmed
no longer affects: messaging-app

Same in Switzerland.

Olivier (ochaude) wrote :

I think it's a major bug. I'm just a basic user, but i can eventually provide screenshots of the terminal if needed (clearly explain the commands to type).

Olivier (ochaude) wrote :

The APN MMS is correctly filled. We all can send MMS, but can't receive.

Olivier (ochaude) wrote :

Having read several forums, I can say with little doubt that there's not a single BQ Aquaris user in France who receives MMS. It seems to be the same in Switzerland. I don't know about other countries.

BANTEGNIE René (f-rene) wrote :

Si au début avec mon BQ Aquaris E4.5 je ne recevais aucun MMS mais pouvais les envoyer, maintenant je ne peux ni les envoyer ni les recevoir. Je suis en France chez l'opérateur Free. Avec mes précédents smartphone, ZTE sous FirefoxOS et Samsung sous Android, je recevais et envoyais sans problème des MMS

description: updated
tags: added: bug-mms-send-receive
description: updated
description: updated
description: updated

Hi all,

I just would like to add something. My concern is about the criticity of this defect.
Many OS (I don't know if it is coming from the operator) transform a too long text message in MMS. Then, in that case, our BQ phone can't receive it and we miss some informations.
That's why I think this bug must go with a very high importance. You know, it is not like if something is missing, it is about not missing information coming to us ...

Thanks

Mathieu

tags: added: bq
Sebastien Bacher (seb128) wrote :

seems similar to bug #1417976, does it work if you turn wifi off? Maybe you can provide the info requested in the other bug?

Changed in telephony-service:
importance: Undecided → High
Olivier (ochaude) wrote :

For me, it doesn't work even when wifi is off.

no longer affects: messaging-app
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telephony-service (Ubuntu):
status: New → Confirmed
affects: telephony-service → telephony-service (Ubuntu)
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
importance: Undecided → High
milestone: none → ww21-2015
status: New → Confirmed
alban (dieteticien) wrote :

Hello,

Same thing.
I have a package / subscription to "Free.fr" without data.
SMS = OK to send and receive.
MMS = not OK ; not sent ; not received.

In test with data actived (enable DATA) = ok to send MMS.
Not OK to receive.
But data give additional charges = I need to disable data

Test with WiFi : not OK ; nothing with MMS.

Sorry for my poor English

---
Alban

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telephony-service (Ubuntu):
status: New → Confirmed
Olivier (ochaude) wrote :

My operator is SFR and it doesn't work either.

I send and receive mms without problem here in Switzerland (operator Sunrise).

Nicolas Adler (lenanfou) wrote :

Same here

Country : France
Operator : free
Mms :
- with wifi on : can't send and receive
- with wifi off : can only send

Tududu (timothee-haudebourg) wrote :

It strange because it worked one day last week. It doesn't any more.... (country : France, operator : bouyges telecom)
I can't receive or send any MMS.

David Lafond (david-lafond) wrote :

As for me, since May 8th, I can receive MMS. I never noticed the issue before, because I have my BQ only since last week. The strange thing is that I receive each MMS several times, at what seems random intervals. For instance, I had one at the following times :
May 9th, 14:42 (when my correspondant initially sent it)
May 9th, 20:45
May 10th, 08:30
May 10th, 09:36
May 10th, 16;03

I had several MMS from several correspondant this week-end, and it was the same, with different intervals.

I used default parameters for MMS:
NPA internet : Bouygues telecom
APN MMS : Same as internet

MMS sending worked well. Wifi was nearly always off.

Country: France, operator: Bouygues Telecom

prolinux (eibyove) wrote :

Hej

In Denmark (TDC) I can not receive MMS.

Kindly Ove

David Lafond (david-lafond) wrote :

Edit of Comment #17:

I am on OS version 19, as I have a problem with automatic updates.

Portugal:
MEO, Vodafone and WTF (NOS) don't receive MMS, I can send them.

Klaus (kzq-klaus) wrote :

I cant send and receive MMS on TDC network in Denmark.
Running 14.10(r22).

Pete Collier (peterjcollier) wrote :

Same in The UK.

Klaus (kzq-klaus) on 2015-05-19
information type: Public → Public Security
Kurt Jensby (kurt-jensby) wrote :

Hej

In Denmark (Teleplus ) I can not send or receive MMS.

Kindly Kurt

Hej, in Slovenia, latest upadate r22
I can send and receive SMS.
I can send MMS.
I can't receive MMS.
Operator Mobitel, Telekom Slovenije

Kurt Jensby (kurt-jensby) wrote :

dont know how i did that, sorry

Changed in ubuntu+mobile+phone:
status: New → Incomplete
Pat McGowan (pat-mcgowan) wrote :

need to retest with the update

Changed in canonical-devices-system-image:
assignee: Canonical Phone Foundations (canonical-phonedations-team) → John McAleely (john.mcaleely)
milestone: ww21-2015 → none
Changed in canonical-devices-system-image:
milestone: none → ww26-2015
John McAleely (john.mcaleely) wrote :

We believe we've fixed a number of MMS related bugs in the update, but not all. thanks for retesting.

Olivier (ochaude) wrote :

Sorry, no change for me with ubuntu phone 23. I still can't receive mms (operator SFR in France).

Mike (trulegobelin) wrote :

Nothing change to me with the french operator Orange, even with personal apn parameters.

Olivier (ochaude) wrote :

Hello. I’ve made three tests :

1) Tried to send a mms to myself. Never received.

2) Asked a friend to send me a photo. I received it, but the message is not filed under the name of my friend (in the contact list). Instead, it is marked as “Group”, including two contacts : the sender and myself.

3) Asked another friend to send me a photo. Never received.

Kurt Jensby (kurt-jensby) wrote :

i have used the following setup ( bare with me if it sounds strange )

1. phone - 1 Iphone 5s ( Danish telenor private)
2. phone - 1 Nokia Lumina 630 ( dual sim ready ) ( Danish telenor business )
3. phone - 1 BQ e4.5 Ubuntu Edition ( dual sim ready ) ( Danish Teleplus ) network from Danish TDC

i tried the following with wifi on and off , testing internet each time

try 1. sending from phone 1 to 2 and 3 , no mms for 3

try 2. sending from phone 2. to 1. and 3. , no mms for 3.

try 3. took sim from 2. and put into 3. second slot, sending mms from 1. to 2. and 3. ( both in BQ now ) , and no mms on it

try 4. took sim from 3. and put into 2. second slot , sending mms from 1. to 2. and 3. ( both in Nokia now ) and got both
mms ( just to make sure i could send mms at both in same phone )

try 5 , sending from 3. to 1. and 2. , no luck in sending

try 6. placeing 2. sim in 3. , and send to 1. with both sims , no luck in sending

i noticed when putting 2 sims in the BQ it Automatic put mms APN as the same as internet ??
i tried to click it to manual APN , but it went back to same as internet , might this be a bug also ??

i also noted that when i put the sim Card from the Nokia into the BQ, i had to put it roaming to get internet

Rafal (rafflo) wrote :

Nothing change to me with the polish operator Play, even with personal apn parameters.

Kurt Jensby (kurt-jensby) wrote :

update
i got a new simcard from my provider
and now i got mms working , with and without wifi
how ever they all comes from my self when looking at sender

I have Aquaris E 4.5 and I cannot receive any MMS - operator Slovak Telekom - Slovakia (+421 ...).
I have latest update (r23) - ubuntu 15.04

stefan ebener (stefan-ebener) wrote :

Just to complete the list of possible operators.

Sending and reciving of MMS is not working with Swisscom (Switzerland). wi-fi on/off and also adding APN infos manually there is no difference.

Release: Ubuntu 15.04 (r3)

Darkworm (eric-neveu) wrote :

I'm in france using a BQ aquaris, my carrier is SFR.

I've received my first MMS yesterday!

the sender is "myphonenumber"+1

dunno what it means....

Changed in canonical-devices-system-image:
milestone: ww26-2015 → ww34-2015
Rafal (rafflo) wrote :

I bought my BQ Aquaris 4.5 over 3 months ago and don't use it because of the MMS issue.
Don't you think that an issue affecting (sometimes blocking) users in France, Switzerland, Portugal, UK, Slovenia, Poland, Denmark etc. should be prioritized higher?

John McAleely (john.mcaleely) wrote :

I agree that MMS should have some priority: We've been fixing things in separate, more specific, bugs. So, as mentioned in #28, a number of bugs were fixed in ota4. Additionally these bugs:

bug #1417976

bug #1444840

Are fixed in ota-5, and will further improve MMS. unfortunately we discovered bug #1471740 quite late in the cycle so it may not make ota-5 (we'll know later in the week).

Notice how #1471740 might affect any operator at any time, so we need to get that fixed before we can clearly see what remains.

Just a comment about that defect.
I have a MX4 flashing with the rc-proposed channel and I managed to receive a MMS (with Orange network provider).
I still can't send MMS but reception seems to work fine ...

Rafal (rafflo) wrote :

It is more complicated. I can receive MMS from one operator and not from another (BQ Aquaris, stable channel)

janvi (janvibuntu) wrote :

Meizu MX4
Operator : Free
Sens = ok
Receive = faile

aizac (dimitri-aizac) wrote :

Meizu MX4
Form France
Version d'Ubuntu: Ubuntu 15.04 -armhf(2015611-173952)
Partie de l'image du périphérique: 20150608-6e66f3c
Version du périphérique ARALE_MEIZU

Operator: Orange
MMS send: I can send
MMS receive: I can't receive (i try from different phone and operator)

John McAleely (john.mcaleely) wrote :

Please note that the ota-5 bugs referred to in #39 are not in the stable image yet. It will be worth seeing how MMS works when that is released, early next week.

I will comment here when that is available.

denis f (madeinmars) wrote :

something new has happened:
I can receive MMS with my Bq Ubuntu Edition, ONLY if sent from another Ubuntu OS phone.
OS version is 24.In France, with Free as provider.
Personalized MMS settings:
APN MMS mmsfree
MMSC http://mms.free.fr

Rafal (rafflo) wrote :

It still doesn't fully work but after the upgrade I can receive MMS with one more combination of a sender & receiver network.

Foucrier (u-michel) wrote :

Since last update I can send MMS, with or without WiFi, and finally receive MMS!
BQ Aquaris 4.5 Ubuntu Edition, french operator "FREE Telecom"
Good job !

Work for me Now
After install the last system update i can now send and receive MMS.

BQ aquaris 4.5 and Free as Operator.

Nice Work Ubuntu :D

denis f (madeinmars) wrote :

Edit #45
everything works at last!
congrats Canonical!

Nothing has changed for me.
My operator (sosh/orange)told me the problem comes from my phone. for them everything is ok.
I can send mms but i don't receive.

BQ Aquaris - ubuntu v.24 -
Operator : Sosh/Orange

Chondoud (nicolas-eubriet) wrote :

Same for me.
No change after ota5 upgrade.
Can send mms, but can receive.

APN customized
BQ Aquaris - 15.04 r24
Operator : Sosh/Orange in France

Any advise? What is the Free APN setting you are using?

Thanks

Chondoud (nicolas-eubriet) wrote :

Sorry I sould wrote
Can send mms, but CAN'T receive.

Ivo Xavier (ivoxavier) wrote :

I was able to send and receive MMS. I'm on the BQ Aquaris (ota5). My network is MEO from Portugal.

Olivier (ochaude) wrote :

It is worst than ever. I still can't receive, and now i can't send mms anymore.

BQ Aquaris Ota 5
Apn customiszed
Operator SFR

Xavier Pelletier (xavpel) wrote :

Hello

If it helps

BQ Aquaris 4.5 Ubuntu Phone
Operator Virgin Mobile
Configuration MMS Needd

OK -> Nom: Virgin MMS
OK-> APN: virgin-mobile.fr
OK-> MMSC: http://virginmms.fr
OK-> Proxy MMS: 10.6.10.1
OK-> Port MMS: 8080
???-> MCC: 208
???-> MNC: 23

See https://communaute.virginmobile.fr/t5/tkb/articleprintpage/tkb-id/utiliser-mobile/article-id/73

Thanks for all

John McAleely (john.mcaleely) wrote :

Whilst I'm moving this meta-bug to ota-7, (since we can't retest everywhere), we landed a couple of critical fixes for MMS in ota-6.

Please retest when that is available. I will comment here when ota-6 is pushed to phones (so no need to test yet)

summary: - impossible receive MMS any operator on bq aquaris E4.5
+ For some operators MMS is unreliable
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Cyril Girard (darktux) wrote :

Hello,

OTA-6 is installed on my Meizu MX4 since yesterday but I can't received MMS. It was the same thing with OTA-5.
However I can send MMS with or without wifi. It is also OK with data.

My provider is Sosh by Orange, a french provider. Basic or custom APN, nothing happens.

Settings are :
APN = orange.acte
MMSC = http://mms.orange.fr
Proxy = 192.168.10.200
Port = 8080
User = orange
Password = orange

Any ideas ?

Thanks

aizac (dimitri-aizac) wrote :

MEIZU MX4 OTA-6

I can't received any SMS, with the same operator than Cyril Girard (SOSH by Orange)
no problem to send

Settings:

APN = orange.acte
MMSC = http://mms.orange.fr
Proxy = 192.168.10.200
Port = 8080
User = orange
Password = orange

Scuse for my poor english..
Thanks

aizac (dimitri-aizac) wrote :

Hello,

OTA-6 is installed on my Meizu MX4 since yesterday but I can't received MMS. It was the same thing with OTA-5.
However I can send MMS with or without wifi. It is also OK with data.

My provider is Sosh by Orange, a french provider. Basic or custom APN, nothing happens.

Settings are :
APN = orange.acte
MMSC = http://mms.orange.fr
Proxy = 192.168.10.200
Port = 8080
User = orange
Password = orange

Any ideas ?

Thanks

Same bug for me with the same provider

For those for which MMS is still failing *after OTA-6*, please report new bugs for the nuntium package mentioning your concrete operator

https://bugs.launchpad.net/ubuntu/+source/nuntium

Please attach a tarball with files in ~/.cache/upstart/ if possible.

If you do not mind to set you your system to writable, you can attach traces following the instructions in

https://github.com/sergiusens/network-test-session

Also, please add your APN settings and note that you need cellular data enabled for MMS to work.

John McAleely (john.mcaleely) wrote :

Sosh by Orange: bug #1490673

Original report was for Free Mobile which works fine now. There were additional comments for Sosh and Orange which are also fixed in OTA7. As Alfonso suggested in his latest comment, if you still have problems with MMS with OTA7, please file separate bug reports for each operator.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in telephony-service (Ubuntu):
status: Confirmed → Invalid
Changed in messaging-app (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu+mobile+phone:
status: Incomplete → Invalid
Eric (pedereri) wrote :

Hi
Is there any status update? I cannot receive any MMS on my meizu pro and in many cases they do not even get sent to me. My girlfriend tried to send me a picture, standing right next to me and I did not even get a sms saying that there was an error and that I should login to the companies website t receive the MMS, which is what usually happens when I do not have a signal.
Can I please get some information here?
Some more information about me. I live in Sweden and use Tele2

Pat McGowan (pat-mcgowan) wrote :

Please comment on bug #1532899 if that matches your symptoms. It has been noted that occasionally no message is received at all. Until now we thought this issue was isolated to the US.

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers