Comment 12 for bug 1627808

The bug is not "Invalid". We know its not a necessary extension, but that
was not the point. The point is it chimes by default and is ON by default,
because of which Firefox runs without e10s multiprocess. This makes all
default Ubuntu users run Firefox at lower performance than it can. I
suggest you keep the bug open and have it fixed in a proper way, which is
to either make the add-on a wen extension which is compatible with all
future Firefox releases.

On 28-Apr-2017 7:31 AM, "Shih-Yuan Lee" <email address hidden> wrote:

ubufox is not a necessary ext for firefox.
You should be able to remove it by `sudo apt-get purge xul-ext-ubufox".

--
You received this bug notification because you are subscribed to a
duplicate bug report (1658407).
https://bugs.launchpad.net/bugs/1627808

Title:
  Please enable e10s (multi-core CPU processing) support

Status in Ubufox Extension:
  Confirmed
Status in firefox package in Ubuntu:
  Invalid
Status in ubufox package in Ubuntu:
  Confirmed

Bug description:
  Would it be possible to determine whether this add-on is compatible
  with the e10s "electrolysis" feature of Firefox[1]?

  If it is, the manifest should say so: [2]

  This link may help when determining support: [3]

  Compatibility of this addon with e10s is required to enable the e10s
  feature, which brings many speedups and enhancements, on default
  configured ubuntu installations.

  Thank you!

  [1]: https://wiki.mozilla.org/Electrolysis
  [2]: https://developer.mozilla.org/en-US/Add-ons/Install_Manifests#
multiprocessCompatible
  [3]: https://developer.mozilla.org/en-US/Add-ons/Working_with_
multiprocess_Firefox

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubufox/+bug/1627808/+subscriptions