Workflow report: tsclient - on inputing a computer name then hitting enter, list stays on screen and steals input

Bug #270374 reported by zombiepig on 2008-09-15
184
This bug affects 17 people
Affects Status Importance Assigned to Milestone
tsclient
Medium
Unassigned
tsclient (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: tsclient

With the version of tsclient in intrepid, there's a strange bug. To reproduce:

- Launch tsclient and type in a computer name to connect to
- Immediately press 'enter' to connect, don't tab out of the field or use the mouse to select 'connect'
- The list box stays on screen while the connection proceeds, and refuses to disappear. It also steals all input, so mouse clicks and typing has no effect. Only way to clear it is to hit escape a few times to disconnect from the session, then close the drop down.

It works fine if you select another field before connecting, or if you use the mouse to press the connect button.

Related branches

Chorca (chorca) wrote :

Confirming this bug. The same thing happens to me. It only occurs when pressing enter from the computer name field, not if connect is clicked by the mouse. Here are two screenshots showing the issue.

Chorca (chorca) wrote :
david.barbion (david-barbion) wrote :

I can confirm this bug.

The mouse click focus gets lost.... sometime, using alt+tab allows you to switch to the tsclient remote host and then you can stop the connection from the remote host and permits to close the listbox.

GonzaloF (gfalinux) wrote :

Confirming this bug too... in my case, I have to change to a text terminal (Ctrl+Atl+Fn1) and manually kill rdesktop/tsclient because my system get's "locked"

Anyone has fixed this problem??? (other than clicking the button instead of hitting Enter key)

jrdnyquist (jody-cltonline) wrote :

Same problem for me. My workaround is to ssh into the box from another box (or use a virtual terminal as suggested above). Do "ps auxwf" and kill the tsclient PID parent that's just above the rdesktop child then the white box is destroyed and you can proceed with your RDP login.

Very annoying little issue.

foobert (foobert) wrote :

I'm also affected by this bug - Xubuntu 8.10 AMD64. I can repro in exactly the same scenarios as described by original reporter. My workaround is the same as GonzaloF (text terminal, kill tsclient PID).

Please let us know if there's any further testing / debug info any of us can provide - this is a rather annoying issue and I'd love to see it resolved.

svasie (svasie) wrote :

Same for me.

Cannot make mouse clicks when that happens, but i can use keyboard. If i close the RDP session using the keyboard, mouse control is recovered.

This happens with desktop effects on or off. The quick solution is to switch to a virtual console (Ctrl+Alt+F1), login, and type 'sudo killall tsclient', then hit Ctrl+d to logout.

brian mcgee (justinisnt) wrote :

Confirmed -- Ubuntu 8.10

I go to tty2 or where ever and do:

  killall tsclient

zoredache (francyci) wrote :

I also can confirm this bug on Intrepid.

I built the hardy source package for Intrepid and the bug went away.

The issue seems to be related to the patches that enable the Hildon interface

david.barbion (david-barbion) wrote :

With my system, it is not possible to switch to another tty (got a black screen)...
The only way to solve this is to end the session remotely...

Pekka Panula (grimdin) wrote :

Confirmed on Ubuntu 8.10, not appeared on 8.04 or earlier version.

Only when i know to get back input is to switch to text console and killall rdesktop and then back to desktop and press cancel on message dialog, that way i can get back my keyboard and mouse, etc.

Ben Clifford (bmclifford) wrote :

Also affected since upgrade from 8.04 to 8.10. I use Alt+F2 to run gnome-terminal to do killall tsclient rather than switch to a console to do it.

Changed in tsclient:
status: New → Confirmed
Roland Hieber (rohieb) wrote :

Same for me. I thought if it has anything todo with compiz, but when I disable it, it's still the same.

Ben Stokes (ben-ukstokes) wrote :

I confirm this bug. I have a workaround instead of sudo killall tsclient from another tty. If you press the windows key you can being up the start menu on the remote computer and log off. This releases the screen back to you. You can then reconnect by pressing OK instead of using the enter key.

Rob Q (quaglr) wrote :

I can also confirm this bug. Same problem and very very annoying I use Intrepid as my main desktop at work where I also manage about 300 windows servers :-(

However - I have a twin-view multimonitor setup, and I have found that if I open tsclient in my secondary monitor and connect I do not have the problem... It only occurs on my primary display. Odd, but true...

Ben Clifford (bmclifford) wrote :

I also have two monitors in twinview, but get the bug on either screen.

Rob Q (quaglr) wrote :

I use the nvidia driver (177.82) on x86_64 Intrepid.

Mick K (mjkemsley) wrote :

I have two monitors with the radeon (not fglrx) driver and it happens on either screen. From what I have seen it appears to happen on all computers independent of the video driver

zoredache (francyci) wrote :

The 0.150-1ubuntu5 version that drops the Hildon interface patch seems to fix this bug.

Mick K (mjkemsley) wrote :

Attached is a small patch I just wrote that seems to fix the problem. ( tsclient 0.150-1ubuntu3 )

Mick K (mjkemsley) wrote :

Compiled package with patch

Mick, I've tried the patched package and, at a first look, it seems to work well!
Thanks

xoroz (fferreira-osiatis) wrote :

I also update it and now it works fine.
Mick K Thanks so much these release!
Cheers

Great work! I can confirm this works on our machines. Will this work it's
way into the official repositories?

2009/2/23 Korax <email address hidden>

> Compiled package with patch
>
> ** Attachment added: "tsclient_0.150-1ubuntu4_i386.deb"
> http://launchpadlibrarian.net/22992140/tsclient_0.150-1ubuntu4_i386.deb
>
> --
> [intrepid] enter a computer name then hit enter, list stays on screen and
> steals input
> https://bugs.launchpad.net/bugs/270374
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "tsclient" source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: tsclient
>
> With the version of tsclient in intrepid, there's a strange bug. To
> reproduce:
>
> - Launch tsclient and type in a computer name to connect to
> - Immediately press 'enter' to connect, don't tab out of the field or use
> the mouse to select 'connect'
> - The list box stays on screen while the connection proceeds, and refuses
> to disappear. It also steals all input, so mouse clicks and typing has no
> effect. Only way to clear it is to hit escape a few times to disconnect from
> the session, then close the drop down.
>
> It works fine if you select another field before connecting, or if you use
> the mouse to press the connect button.
>

zoredache, I installed just the Jaunty 0.150-1ubuntu5 package in Intrepid with no other Jaunty packages or dependencies, and I still have the issue. Are you testing by typing in a computer name to connect to, then immediately pressing 'enter' without using the tab or mouse as described at the top of the page?

So, I believe we still need to push this resolution with the original developer. Mick, I can't test your package, as I'm running an AMD64 build. I'll have to compile from sources, unless you have a package already to go for the 64-bit arch as well..

Thanks!

Mick K (mjkemsley) wrote :

Hi Petie,

Attached is the amd64 build with this patch

Patched version (amd64) works for me too. Thanx!

AMD64 build w/patch appears to be working as intended. I can type in the
computer field and immediately press ENTER to connect - no focus / input
stealing. 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64
GNU/Linux

Thanks very much!

Steve

On Wed, Feb 25, 2009 at 4:19 PM, Mick K <email address hidden> wrote:

> Hi Petie,
>
> Attached is the amd64 build with this patch
>
>
> ** Attachment added: "tsclient_0.150-1ubuntu4_amd64.deb"
> http://launchpadlibrarian.net/23130175/tsclient_0.150-1ubuntu4_amd64.deb
>
> --
> [intrepid] enter a computer name then hit enter, list stays on screen and
> steals input
> https://bugs.launchpad.net/bugs/270374
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “tsclient” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: tsclient
>
> With the version of tsclient in intrepid, there's a strange bug. To
> reproduce:
>
> - Launch tsclient and type in a computer name to connect to
> - Immediately press 'enter' to connect, don't tab out of the field or use
> the mouse to select 'connect'
> - The list box stays on screen while the connection proceeds, and refuses
> to disappear. It also steals all input, so mouse clicks and typing has no
> effect. Only way to clear it is to hit escape a few times to disconnect from
> the session, then close the drop down.
>
> It works fine if you select another field before connecting, or if you use
> the mouse to press the connect button.
>

Thanks!

I updated the author's sourceforge buglist too and suggested your patch as the solution.

I have this bug on jaunty alpha 5.
ALT+F2 and then "killall tsclient" kill the remaining list and give me the mouse click control again...
waiting for an update

mcnicholls (nicholls-mc) wrote :

This one has been driving me mad for a while now too. It seems as though Mick K's patch fixes the issue, so I am submitting this patch to see if we can get it included for jaunty.

Nerd_bloke (nerd-bloke) wrote :

Here is the URL of the upstream bug, it should add a remote bug watch...

http://sourceforge.net/tracker/index.php?func=detail&aid=2592809&group_id=192483&atid=941574

Changed in tsclient:
status: New → Confirmed
Changed in tsclient (Ubuntu):
importance: Undecided → Medium
summary: - [intrepid] enter a computer name then hit enter, list stays on screen
- and steals input
+ tsclietnenter a computer name then hit enter, list stays on screen and
+ steals input
summary: - tsclietnenter a computer name then hit enter, list stays on screen and
+ tsclient enter a computer name then hit enter, list stays on screen and
steals input
tags: added: usability
summary: - tsclient enter a computer name then hit enter, list stays on screen and
- steals input
+ Workflow report
tags: added: metabug
tags: added: regression-potential
Mike Basinger (mike.basinger) wrote :

A package I built with the debdiff patch fixed the problem for me in Jaunty Beta.

CombatWombat (combatwombat) wrote :

Same for me in Jaunty beta. How long does this stupid bug need to live?

http://combatwombat.7doves.com/2009/03/30/fix-for-tsclient-hang-in-ubuntu-x86-jaun
For DEB built with diff on i386, Jaunty.

Sebastien Bacher (seb128) wrote :

thank you for your work there

tags: removed: metabug usability
Changed in tsclient (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tsclient - 0.150-1ubuntu6

---------------
tsclient (0.150-1ubuntu6) jaunty; urgency=low

  * 29_fix_listbox_steals_input_on_connect.patch: fix the connect list box
    being displayed when focused on computer name and pressing enter.
    Thanks to Mick K for the original patch. (LP: #270374)

 -- Michael Nicholls <email address hidden> Sun, 15 Mar 2009 16:53:49 +0000

Changed in tsclient (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Cyclops (rms) on 2009-08-26
Changed in tsclient:
status: Confirmed → Fix Committed
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.