Error: /Stage[main]/Ceph::Rgw::Keystone::Auth/Keystone_role Duplicate entry found with name Member

Bug #1777451 reported by wes hayutin on 2018-06-18
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Quique Llorente

Bug Description

https://logs.rdoproject.org/openstack-periodic/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset019-master/2d58909/undercloud/home/jenkins/overcloud_deploy.log.txt.gz#_2018-06-18_06_46_28

       "Warning: ModuleLoader: module 'ceph' has unresolved dependencies - it will only see those that are resolveOvercloud configuration failed.
2018-06-18 06:46:28 | END return value: 1
2018-06-18 06:46:28 | d. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'glance' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'manila' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'neutron' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'nova' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'oslo' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Warning: ModuleLoader: module 'mysql' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules",
2018-06-18 06:46:28 | "Error: Execution of '/usr/bin/openstack role create --format shell Member' returned 1: Conflict occurred attempting to store role - Duplicate entry found with name Member. (HTTP 409) (Request-ID: req-81510303-72a6-4cfd-a2eb-a2df9f9e1ae5)",
2018-06-18 06:46:28 | "Error: /Stage[main]/Ceph::Rgw::Keystone::Auth/Keystone_role[Member]/ensure: change from absent to present failed: Execution of '/usr/bin/openstack role create --format shell Member' returned 1: Conflict occurred attempting to store role - Duplicate entry found with name Member. (HTTP 409) (Request-ID: req-81510303-72a6-4cfd-a2eb-a2df9f9e1ae5)",
2018-06-18 06:46:28 | "Warning: /Stage[main]/Ceph::Rgw::Keystone::Auth/Keystone_user_role[swift@service]: Skipping because of failed dependencies",
2018-06-18 06:46:28 | "+ rc=6",
2018-06-18 06:46:28 | "+ set -e",
2018-06-18 06:46:28 | "+ '[' 6 -ne 2 -a 6 -ne 0 ']'",
2018-06-18 06:46:28 | "+ exit 6",
2018-06-18 06:46:28 | "2018-06-18 06:46:26,027 INFO: 78728 -- Finished processing puppet configs for keystone_init_tasks",
2018-06-18 06:46:28 | "2018-06-18 06:46:26,029 ERROR: 78727 -- ERROR configuring
keystone_init_tasks"

Related Change: https://review.openstack.org/#/c/572243/ possibly causing the issue

Changed in tripleo:
assignee: nobody → Quique Llorente (quiquell)
Quique Llorente (quiquell) wrote :

More info at Yatin's bug, marked as duplicated of this.

https://bugs.launchpad.net/tripleo/+bug/1777573

Includes fix: https://review.openstack.org/#/c/572243/

yatin (yatinkarel) wrote :

<<< https://bugs.launchpad.net/tripleo/+bug/1777573
We are seeing two issues after https://review.openstack.org/#/c/572243/ merged.
1) puppet-ceph(other puppet modules should also be affected) failing while creting keystone role "Member" using keystone_role provider.
2) discover-tempest-config-failing while creating "Member" role

<<< Includes fix: https://review.openstack.org/#/c/572243/
The fix is only for the tempestconf part,
For puppet-ceph and others:- https://review.openstack.org/#/c/576393/

tags: added: ale
tags: added: alert
removed: ale
Quique Llorente (quiquell) wrote :

Correct tempestconf review https://review.openstack.org/#/c/576356

Quique Llorente (quiquell) wrote :

To test the tripleo job https://review.openstack.org/576467

Changed in tripleo:
status: Triaged → In Progress
Quique Llorente (quiquell) wrote :

fs019 passing with reproducer and those patches.

Alex Schultz (alex-schultz) wrote :

Changes have been merged. Moving to fix released. Please reopen if there is still a problem

Changed in tripleo:
status: In Progress → Fix Released
Quique Llorente (quiquell) wrote :
Changed in tripleo:
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
tags: removed: alert
Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/puppet-keystone 13.3.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers