The requested note could not be parsed.

Bug #697996 reported by Mads Boserup Lauritsen on 2011-01-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
Medium
Matthew Rasmus

Bug Description

I am unable to open one specific note in Tomdroid on my SE xperia mini pro, running android v2.1.1

When I press the note this message appears
"Error: The requested note could not be parsed. If your see this error and are able to replicate it, please file a bug"

I started to use timestamps in this specific note, but after removing the stamp in Tomboy, I am still not able to open the note.

I have not been able to find any error log on the SD-card, so how do I submit more information so the bug is "understandable"?

Best regards
Mads Boserup Lauritsen

Tomdroid on Sony Ericsson xperia mini pro, running android v2.1.1, sync on U1.
Tomboy on Windows XP and Ubuntu 10.04, both sync on U1.

Related branches

wolfcub (nagulesan) wrote :

Same bug. I'm on HTC Desire, android v2.2. It appeared after I edited a note in the Ubuntu One web interface (https://one.ubuntu.com/notes) which I think messed up the formatting (which seems to be very buggy handling lists of lists). Will see if I can reproduce the steps and post.

I'm getting this error also, but in my case it is not connected to timestamp, but when there is a line with a bullet, but no text on it.

The bug can be reproduced by putting a "bullet" in the beginning of a line, syncing to Ubuntu One and after that trying to open with Tomdroid 0.4.1.

A note which triggers this bug can be downloaded here: http://dl.dropbox.com/u/2071830/1c7e931e-c38c-44f1-bcba-59ca9283b805.note

I attached a screenshot of the note.

Thanks for the reports. We will try to reproduce using your instructions.

Importance medium
Milestone 0.5

On 2011-01-17 6:14 AM, "Mikael Hartzell" <email address hidden> wrote:

I'm getting this error also, but in my case it is not connected to
timestamp, but when there is a line with a bullet, but no text on it.

The bug can be reproduced by putting a "bullet" in the beginning of a
line, syncing to Ubuntu One and after that trying to open with Tomdroid
0.4.1.

A note which triggers this bug can be downloaded here:
http://dl.dropbox.com/u/2071830/1c7e931e-c38c-44f1-bcba-
59ca9283b805.note

I attached a screenshot of the note.

** Attachment added: "Tomdroid_Bullet_Bug.jpg"

https://bugs.launchpad.net/tomdroid/+bug/697996/+attachment/1796502/+files/Tomdroid_Bullet_Bug.jpg

--
You received this bug notification because you are a member of Tomdroid
Maintainers, which is s...

Olivier Bilodeau (plaxx) wrote :

Looks like replying from gmail mobile didn't do as expected. Re-did first triage.

Changed in tomdroid:
importance: Undecided → Medium
milestone: none → 0.5.0
Matthew Rasmus (mrasmus) on 2011-01-24
Changed in tomdroid:
assignee: nobody → Matthew Rasmus (mrasmus)
Matthew Rasmus (mrasmus) wrote :

I'm pretty close to fixing the parsing error on the note Mikael provided (I actually got that note working, but I've found a few other cases in which an empty list item will break things). If everyone else with this problem could attach the note that's causing it, that would be super helpful!

For those looking for the location of the note-files, when they are synced on Ubuntu one this is where to look (remember to activate hidden files ... :-)

~/.local/share/tomboy

Took me a while to find...

The attached note, contains both timestamp and bullet-list. I do not know which one makes it crash, but in other notes I have the both and they do not crash.

Best regards,
Mads

Matthew Rasmus (mrasmus) wrote :

Thanks for the note, Mads. It looks like your particular parsing error is caused by bullet items that have been indented multiple times without any other list items leading up to their particular indent level. The attached screenshot demonstrates this. The first window shows a bullet list indented in a way that tomdroid expects, and the second window shows a bullet list that will create a parsing error on tomdroid.

I'm going to try to fix this problem, but, until a fix is released, you can avoid this error by moving all your bullet items down to the first indentation level.

sinarf (sinarf) wrote :

I have a note that trigger that error in tomdroid, but it is openned without issue in tomboy or on one.ubuntu.com.

Hope this can help.

Matthew Rasmus (mrasmus) wrote :

Thanks for the note! Unfortunately, this note is not triggering the error for me. Are you sure this is the correct one? If it is, could you try making a minor edit in the last line of the note in Tomboy, and try resynchronizing Tomboy and Tomdroid? If that fixes it, this might be related to some weirdness I've been seeing in my own testing.

Olivier Bilodeau (plaxx) wrote :

The fix is in, as Matthew said not sure if it'll fix your problem but it does fix list indentation problems. This will be in the next release. Try it then and let us know if it fixed it.

Changed in tomdroid:
status: New → In Progress
Olivier Bilodeau (plaxx) wrote :

I tried all the test notes in here and no one generated an error. If you can reproduce a crash or a visual problem compared to how Tomboy or U1 parses the note, please open a new ticket (as this one already tracked both date issues and list indentation issues).

Changed in tomdroid:
status: In Progress → Fix Committed
Olivier Bilodeau (plaxx) on 2011-09-06
Changed in tomdroid:
status: Fix Committed → Fix Released

The notes are now able to open, but visual bug,

I'll open a new ticket.

Thx, for fixing the issues :-)

The new bug for multiple indent with bullet list https://bugs.launchpad.net/tomdroid/+bug/842805

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers