Tomdroid does not correctly parses timezone info with a +

Bug #520543 reported by Bernd Hirschler on 2010-02-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
High
Olivier Bilodeau

Bug Description

Version 0.3.
After the start I try to import my notes from my sdcard, from folder tomdroid.
An error message pops up and is gone so fast that you can not read the error.

Olivier Bilodeau (plaxx) wrote :

Do you have the Android SDK installed on a machine? If so, you can try to check the logs by doing:

# adb logcat

with your device plugged in.

Otherwise, can you try with the notes in the test case?

Grab all the .note from:
http://bazaar.launchpad.net/%7Eplaxx/tomdroid/main/files/head%3A/xml-schema/complete-testcase/
and try with them. If it works, there's something in your notes that tomdroid doesn't like. Try to isolate that by removing notes from your note suite.

Lastly, what is your Android version and device?

Changed in tomdroid:
assignee: nobody → Olivier Bilodeau (plaxx)

Hi,

I had not much time, but i already tested some things. Your test notes do work.
I removed all my notes and only kept one, "Start here", did not work.
Made a single new note and it also did not work. I attached my testing
note.

SDK is currently not installed and i won't have the time to do more in
the next 2-3 weeks.

My phone is a Motorola Milestone with 2.0.1 and i had the chance to
test 0.3 also on a HTC Magic 1.6, both with the same outcome, again
only with one note.
Tried another time right now and the error message is not disappearing:
"Application is not responding
The application Tomdroid(process org.tomdroid) has stopped
unexpectedly. Pleas try again."

I also found a pre built package from someone who took it out of the
repository, after 0.2 and before 0.3 and it worked on my mobile phone
(also attached), did not test on the second phone. It seems to me the
importer function is having problems, because the prebuilt package
uses the old importer functions judging from the size of the package.
My version of Tomboy is 1.0.0.

Kind regards Bernd

--
MfG Bernd
:x

On Thu, Feb 11, 2010 at 18:47, Olivier Bilodeau
<email address hidden> wrote:
> Do you have the Android SDK installed on a machine? If so, you can try
> to check the logs by doing:
>
> # adb logcat
>
> with your device plugged in.
>
>
> Otherwise, can you try with the notes in the test case?
>
> Grab all the .note from:
> http://bazaar.launchpad.net/%7Eplaxx/tomdroid/main/files/head%3A/xml-schema/complete-testcase/
> and try with them. If it works, there's something in your notes that tomdroid doesn't like. Try to isolate that by removing notes from your note suite.
>
> Lastly, what is your Android version and device?
>
> ** Changed in: tomdroid
>     Assignee: (unassigned) => Olivier Bilodeau (plaxx)
>
> --
> Tomdroid does not import from sdcard
> https://bugs.launchpad.net/bugs/520543
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I suppose it's the same problem that i reported here : https://bugs.launchpad.net/tomdroid/+bug/521519
It lacks a '+' in the pattern dateCleaner on Note.java

Olivier Bilodeau (plaxx) wrote :

Edouard is right, it's a date with a + timezone that poses a problem.

I'll fix this and release 0.3.1.

Changed in tomdroid:
importance: Undecided → Medium
milestone: none → 0.3.1
status: New → Confirmed
Olivier Bilodeau (plaxx) on 2010-02-16
summary: - Tomdroid does not import from sdcard
+ Tomdroid does not correctly parses timezone info with a +
Changed in tomdroid:
importance: Medium → High
Olivier Bilodeau (plaxx) wrote :

I just committed proper error-handling. The exception is thrown to the threaded parser and a parse-error alert dialog is showed to the user.

Olivier Bilodeau (plaxx) wrote :

Note test case added to Tomdroid test suite.

Changed in tomdroid:
status: Confirmed → Fix Committed
Olivier Bilodeau (plaxx) wrote :

just uploaded a new APK to the release page, please give it a shot whenever you have a minute

Changed in tomdroid:
status: Fix Committed → Fix Released
Download full text (3.3 KiB)

Hi!

I still have problems, on the import of my messages, I guess, its due to my
notes.
I already connected with the "adb logcat" and can see the force close on my
screen, but there is no usable output on the cmd, at least for me.
Here is a truncated output:
....
V/Note ( 4757): new date: 2009-08-05T16:39:02.836+02:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-07T21:34:05.080+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-07T22:47:04.792+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-01-04T10:14:56.866+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-07T22:41:17.976+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2009-12-27T18:20:13.993+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-07T22:19:44.997+01:00
D/dalvikvm( 4757): GC freed 11110 objects / 6870176 bytes in 126ms
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2008-08-19T18:08:57.520+02:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
....
V/Note ( 4757): new date: 2008-09-03T15:18:25.203+02:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-03T15:31:47.833+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-02-26T13:09:31.246+01:00
I/ActivityManager( 1163): Process com.google.android.apps.uploader (pid
4393) has died.
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2010-01-04T10:14:56.858+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2009-08-21T15:09:40.202+02:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2008-11-25T17:20:55.408+01:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2008-09-17T17:36:55.225+02:00
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2009-12-30T10:03:23.282+01:00
D/dalvikvm( 4757): GC freed 12152 objects / 6779496 bytes in 73ms
D/Note ( 4757): I had to clean out extra sub-milliseconds from the date
V/Note ( 4757): new date: 2009-12-27T18:20:56.459+01:00

With this log I can not narrow the problem down further, deleting notes and
putting them back piece by piece in is not favourable.

--
MfG Bernd
:x

On Tue, Feb 16, 2010 at 05:32, Olivier Bilodeau
<email address hidden>wrote:

> Edouard is right, it's a date with a + timezone that poses a problem.
>
> I'll fix this and release 0.3.1.
>
> ** Changed in: tomdroid
> Importance: Undecided => Medium
>
> ** Changed in: tomdroid
> Status: New => Confirmed
>
> ** Changed in: tomdroid
> Miles...

Read more...

Olivier Bilodeau (plaxx) wrote :

Where is the error (stack trace) in the logs? If there isn't any, be specific about what you get on the screen (you need to force close or application has stopped unexpectedly).

And please file a new bug for your problem, as I identified this bug as a timezone issue (with duplicates) and resolved it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers