Notebook templates from Tomboy are treated as notes

Bug #360732 reported by Olivier Bilodeau on 2009-04-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Tomdroid
Fix Released
Medium
Unassigned

Bug Description

Notebook templates from Tomboy are treated as notes

Expected behavior: don't show them

pjv (pjv) wrote :

In Tomboy you set up notebooks. You can start a new note in a specific notebook with a notebook template. You have to create the custom notebook template first.

I haven't even created custom templates but I get them anyway for each notebook. In Tomdroid they are displayed as regular notes.

The expected behaviour would be the same as for Tomboy. Treat them as a special (inconspicuous) feature and don't display among regular notes.

Benoit Garret (benoit.garret) wrote :

I just uploaded a branch which parses tags and doesn't show the note templates in the main list.

I wouldn't even call it a half-assed attempt at it but I didn't really want to spend more time on this until the provider and collection are merged.

https://code.launchpad.net/~benoit.garret/tomdroid/parse-tags

Olivier Bilodeau (plaxx) wrote :

Can anyone attach a notebook template note? I try out Benoît's branch but I'm too lazy to start a notebook and add a template to it.

A convoluted note with a lot of addin tags, etc. would be really appreciated.

Current tomboy xml format documentation[1] doesn't even speak about Notebooks and addins.

[1] http://live.gnome.org/Tomboy/NoteXmlFormat

Changed in tomdroid:
importance: Undecided → Medium
status: New → Confirmed
Benoit Garret (benoit.garret) wrote :

I attached the default notebook template to the bug.

The parsing of tags is very rough, I'm just parsing what lies between <tag> and </tag> without regard to the possible hierarchy. I didn't really have a choice as I couldn't find documentation on the tag format in Tomboy.

Olivier Bilodeau (plaxx) wrote :

targeted for 0.4

Benoît, I looked at your parse-tags branch and it's good stuff! Let's aim to merge that for 0.4 and try to get more feedback on addin tags from the tomboy people just to make sure. Also I'm sure the sync story changes the approach for add-ins too.

Changed in tomdroid:
milestone: none → 0.4
Guilherme Salgado (salgado) wrote :

Since Benoit's changes don't work with either the sync-ui or web-sync branches, I've fixed this on a branch of sync-ui: https://code.edge.launchpad.net/~salgado/tomdroid/sync-ui

Olivier Bilodeau (plaxx) wrote :

I tried to reproduce using provided test note and I wasn't able to which is good.

It means Guilherme's changes have somehow been merged in the long series of changes that led to what's in lp:tomdroid now.

Changed in tomdroid:
status: Confirmed → Fix Committed
Olivier Bilodeau (plaxx) wrote :

fix released in 0.4.0

Changed in tomdroid:
status: Fix Committed → Fix Released

Hmm ever since I synced with 0.4.0 I now see two notebook templates as notes. Cannot get rid of them either.

Currently, the notebook templates are only skipped when you sync your
notes from the web, so this is, unfortunately, expected if you upgraded
Tomdroid but kept your existing notes.

If that's the case, you can delete your tomdroid notes and sync from the
web to get rid of the notebook templates.

If that's not the case, then there's a bug somewhere and we'd need to
investigate further.

The notes are visible from my regular Tomboy client 1.4.0 ever since my first sync with Tomdroid 0.4.0. I have since re-installed Tomdroid to 0.4.1 (pre) and these notes are not visible there. On the web these are not visible... well only through recent activity.

Recent activity

Privat Notebook Template was updated

Guilherme Salgado (salgado) wrote :

On Thu, 2010-10-14 at 15:05 +0000, ThomasNovin wrote:
> The notes are visible from my regular Tomboy client 1.4.0 ever since my
> first sync with Tomdroid 0.4.0. I have since re-installed Tomdroid to
> 0.4.1 (pre) and these notes are not visible there. On the web these are
> not visible... well only through recent activity.

Do you mean that re-syncing caused the notebook templates to disappear
as expected?

No..

First I did a sync after installing 0.4.0. Can't remember if templates were visible on Tomdroid then. However they became visible on Tomboy 1.4.0 after this sync.

Now I use 0.4.1 and I don't see these templates. I don't see them on Tomboy Web either.

I can only see them on Tomboy 1.4.0 (on two different computers) and I can't remove them.

So as I see it Tomdroid has done something which I cannot reverse.

Maybe this is a completely different issue than the original bug-report (so it seems now..).

Olivier Bilodeau (plaxx) wrote :

> they became visible on Tomboy 1.4.0 after this sync

Aren't templates always visible in Tomboy except in the tray icon note list?

> Now I use 0.4.1 and I don't see these templates. I don't see them on Tomboy Web either.

Nothing changed regarding notebook handling between 0.4.0 and 0.4.1 so you should be able to still reproduce the issue, if it's an issue.

> I can only see them on Tomboy 1.4.0 (on two different computers) and I can't remove them.
>
> So as I see it Tomdroid has done something which I cannot reverse.

I'm afraid it could also be Snowy or Tomboy that has done something.. I would need reproducible steps.

> Maybe this is a completely different issue than the original bug-report (so it seems now..).

Yes, this issue was for notebook being visible in the note-list, which they aren't anymore. If we do something to them that causes issues to Snowy / Tomboy please file a new issue.

Thanks Thomas for tracking this down!

In Tomdroid 0.5 (Tomboy 1.8) the notebook templates are showing up again in the AVD and also on my Phone. This occurs, when syncing with Ubuntu One and also with out Test SD-Card notes.
Can anybody confirm this behavior? Is this probably a regression, or have the Tomboy guys changed something here?

I just checked on my friends set-up (Tomdroid 0.5, Tomboy 1.2.2, Ubuntu One) and it seems not to be a problem there. So it is maybe related to the new version of Tomboy.

NoahY (noahy) wrote :

The problem is that 0.5 is not using NoteManager.getAllNotes(Activity activity, Boolean includeNotebookTemplates), it is accessing the ListAdapter directly. I've fixed this in my branch:

https://code.launchpad.net/~tomdroid-dev/tomdroid/note-editing-and-syncing

just by adding the boolean as a variable to the ListAdapter method, and checking for it:

 public static ListAdapter getListAdapter(Activity activity, String querys, Boolean includeNotebookTemplates) {

  String where = "(" + Note.TAGS + " NOT LIKE '%" + "system:deleted" + "%')";
  if (!includeNotebookTemplates) {
   where += " AND (" + Note.TAGS + " NOT LIKE '%" + "system:template" + "%')";
  }

  ...

It might be nice to allow this to be toggled in preferences, since some people might like to edit the templates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers