Wrong German translation of "holiday"

Bug #1484484 reported by Rüdiger Kupper
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Holidays Scope
Fix Released
High
Penk Chen
Today Scope
Fix Released
Undecided
Unassigned
Ubuntu Translations
Fix Committed
Undecided
Unassigned

Bug Description

The today scope can be configured to display the next holidays. The label has a wrong German translation.

The word "holidays" can have two meanings in English:
1. "official day without work" (German translation: "Feiertag" resp. "Feiertage" when referring to a single or few days; "Ferien" when referring to a longer period.)
2. "vacation" (German translation: "Urlaub", i.e. a holiday trip.)

Currently, the German translation reads "Urlaub", which is meaning no. 2 and obviously wrong in this context.
The correct translation in this context would be no. 1, but it may be difficult to decide if "Feiertag(e)" or "Ferien" should be used.

(see also bug #1429548 describing the same problem for Italian translation)

Tags: ota9 translate
Revision history for this message
Magdalena Mirowicz (magdalena-mirowicz) wrote :

removing Ubuntu UX as doesn't relate to design

no longer affects: ubuntu-ux
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

thanks for the translation bug report!

Please note that this is an issue with the Holidays child scope (not the Today scope which aggregates Holidays).

I've therefore added holidays as a task and marked Today scope task invalid.

Changed in today-scope:
status: New → Invalid
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Can Ubuntu Translators please review the translation of "holidays" as described above?

thanks a lot!

Changed in holidays:
status: New → Confirmed
Changed in holidays:
assignee: nobody → Alex Kaluzhny (alex-kaluzhny)
status: Confirmed → Triaged
importance: Undecided → High
tags: added: translate
Revision history for this message
Tobias Bannert (toba) wrote :
Revision history for this message
Tobias Bannert (toba) wrote :

I can not correct the translation, if no one knows what is right.
Feiertage and Ferien are not the same.
The current translation looks correct for me.

Revision history for this message
Torsten Franz (torsten.franz) wrote :

I think "Feiertage" is the right term for it. Yes "Feiertage" and "Ferien" are not the same. "Ferien" are only use in the context of school and university. I think "Urlaub" is not correct cause that is only the days for a individual person when she take her free days which are a dependency of the contract between her and her company.

Revision history for this message
Phillip Sz (phillip-sz) wrote :

I also think that someone should add an comment for the translators to explaine this.

Revision history for this message
schuko24 (gerd-saenger) wrote :

Having read all your comments, I agree to translate it with "Feiertag(e)".

Phillip Sz (phillip-sz)
Changed in holidays:
status: Triaged → Fix Committed
Revision history for this message
Peter Bittner (peter-bittner) wrote :

Note that I have adapted the translation of "Next Holiday" to "Nächster Feiertag". It looks like I can only suggest the translation, though. Someone needs to integrate it into the code base.

https://translations.launchpad.net/today-scope/trunk/+pots/today/de/4/+translate

Revision history for this message
Peter Bittner (peter-bittner) wrote :

See also the ubuntu-touch-coreapps mailing list at https://lists.launchpad.net/ubuntu-touch-coreapps/msg00892.html

Revision history for this message
Peter Bittner (peter-bittner) wrote :

@Phillip Sz (phillip-sz) I think adding explanations to translations is a feature that is missing in Launchpad's translation platform.

Revision history for this message
Phillip Sz (phillip-sz) wrote :

yeah, only the developer can add explatations.

Tobias Bannert (toba)
Changed in ubuntu-translations:
status: New → Fix Committed
Changed in today-scope:
status: Invalid → Fix Committed
Revision history for this message
Peter Bittner (peter-bittner) wrote :

The fix has been rolled out with OTA-8.

Changed in holidays:
status: Fix Committed → Fix Released
Revision history for this message
Rüdiger Kupper (ruediger.kupper) wrote :

It has been fixed in the today scope, but *not* in the holidays scope!
If you tap on the right arrow on the today scope, the holidays scope opens. The title of this scope still reads "Urlaub".
This translation should be fixed, too -- do we need another bug report for that, or will it be fixed as part of this one?

Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Hi Rüdiger.

I just checked [1] and the Holidays scope name is translated into German. The scope only needs to be released. I have just made a 1.2 version of the scope click pkg and we can release it.

Thanks for identifying this!

Cheers,
Kyle

[1] https://translations.launchpad.net/holidays/trunk/+pots/holidays/de/+translate?batch=10&show=all&search=holidays

Changed in today-scope:
status: Fix Committed → Fix Released
Changed in holidays:
status: Fix Released → Fix Committed
assignee: Alex Kaluzhny (alex-kaluzhny) → Penk Chen (penk)
Revision history for this message
Kyle Nitzsche (knitzsche) wrote :

Hi Penk,

Can you please release the holidays 1.2 scope to store? I attach it here for convenience but it is also in our clicks branch.

Thanks!

tags: added: ota9
Revision history for this message
Penk Chen (penk) wrote :

Click package uploaded to store. Mark as fix released.

Changed in holidays:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers