Thunar and Trash Applet report that Trash is empty when it is not

Bug #880533 reported by Gretha on 2011-10-23
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Xfce panel
New
Undecided
Unassigned
thunar
Confirmed
Medium
thunar (Ubuntu)
High
Unassigned
xfce4-panel (Ubuntu)
Undecided
Unassigned

Bug Description

System: Xubuntu 11.10, fully updated

The Thunar Trash icon in the xfce panel shows mouse-hover-balloon: "Wastebasket is empty", and the trash icon is displayed as the empty icon. Yet, the waste bin does contains one deleted file.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Mike Kupfer (mkupfer37) wrote :

Hrm, I'm still seeing this issue (icon shows empty trash, even though it contains 2 files) with today's 12.10 beta bits (xfdesktop4 4.10.0-1ubuntu1, thunar 1.4.0-1ubuntu2). So either 861267 was incorrectly marked fixed, or this is not a duplicate of 861267.

What's really annoying is that when I open up the Trash, I can see the 2 files, and I can Restore them, but the "empty trash" operation is grayed out.

This is trivial for me to reproduce: delete a file in Thunar, then log out and login again.

Mike Kupfer (mkupfer37) wrote :

Minor correction about "empty trash": it's grayed out if I right-click on the trash icon or if I right-click on the "Trash" widget in the pathbar. But it's invocable from the File menu.

Mike Kupfer (mkupfer37) wrote :

Under the assumption that 861267 is really fixed, I cleared the duplicate linkage.

Mike Kupfer (mkupfer37) wrote :

Workaround: restart xfdesktop. For example, I have an application autostart entry that does "xfdesktop --reload".

Mike Kupfer (mkupfer37) wrote :

Sorry... I didn't read the original description as closely as I should have, so I didn't realize this bug report was referring to the trash applet, not the desktop icon. (I do see the same issue, though, with the desktop trash icon: it's shown as empty when it actually contains something). My workaround (comment #5) only works for the desktop trash icon, not the panel icon.

With Thunar 1.5.2 from PPA, if you put a file in the trash, then trash is not empty and you can empty the trash.

But if you close the session et open it then thunar shows an empty trash and you can't empty it

In , 8-nick (8-nick) wrote :

Fixed in 60e9680.

Still an issue here with 1.6.0.

Closing all thunar windows and then opening a new one corrects the trash state. Alternatively calling 'gvfs-ls trash:' before opening thunar the first time also sets the correct trash state.

Still have this problem too with thuanr 1.6.0

In , 8-nick (8-nick) wrote :

Its a race, but the gvfs-trash daemon does not send a file-changed signal. With the idle it looked like it was fixed, but i can delay it too.

In , 8-nick (8-nick) wrote :

Delayed check to 2 seconds. Can someone check if this works?

Isn't working neither with xfdesktop nor with Thunar (1.6.1).

In , 8-nick (8-nick) wrote :

Code is checking for 15 seconds now with 3s intervals or files are found.

Sorry, but this is still not working with Thunar 1.6.2
But maybe this patch is not include in it

Travis Knight (dick-swift00) wrote :

12.04; 12.10; 13.04 all also exhibit this behavior from time to time (currently experiencing the "Empty Trash" icon on the desktop, but opening shows files/folders. Worse though is a recent update (I guess) to 13.04 has rendered the use of "Trash" inoperable:
From Thunar, keyboard "DEL" or right-click "move to trash" result in "Are you sure want to permanently delete...." Cancel/Delete choices.

Seems relevant to this bug vs. starting a new one...but I'm open to challenge there.

Still not fixed.

tags: added: trusty
Changed in thunar (Ubuntu):
importance: Undecided → High
pjotter (p-krawatski) wrote :

I have experienced this bug for some time in 12.04. And I can confirm still exists in the latest daily 14.04.

To reproduce the bug in daily 14.04:
1) Put a trash icon to one of the panels and enable the trash icon on the desktop.
2) Empty trash (all icons should indicate that the trash is now empty)
3) Create a dummy file and put it in the trash (All trash icons should indicate that something is in the trash)
4) Now, log off and log back in.
5) The Trash on the panel and in Thunar is showing 'empty' while the Trash on the desktop is showing full!

One way to resolve this problem is to put a dummy file in the trash and then immediately remove it. The status of the trash is the updated and all trash icons show the correct status.

A temporary workaround I have been using:

On startup, run fixtrash.sh:

#!/bin/sh
until pidof gvfsd-trash
do
  sleep 1
done
echo > ~/.local/share/Trash/files/fixtrash
rm ~/.local/share/Trash/files/fixtrash

Hope this helps.

*** Bug 10655 has been marked as a duplicate of this bug. ***

I cannot reproduce this issue anymore after telling xfdesktop(!) to display the trash icon on the desktop.

I cannot reproduce this issue anymore after I've changed the desktop settings and enabled the trash icon.

Xubuntu 14.04 (dev)

ToZ (toz) wrote :

Fresh Xubuntu 14.04 beta 2 install and am seeing the same thing. Desktop trash shows items, but thunar and panel trash icons show empty.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/880533

tags: added: iso-testing
Forest (foresto) on 2014-11-08
summary: - Thunar reports Trash Empty when it is not
+ Thunar and Trash Applet report that Trash is empty when it is not
Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.