Album art from images in the same folder not exposed

Bug #1372000 reported by Andrew Hayzen on 2014-09-21
78
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
Thumbnailer
Invalid
Undecided
Unassigned
mediascanner2 (Ubuntu)
High
James Henstridge

Bug Description

The music app reads the art property from mediascanner2 which, from my understanding, uses embedded art if there is any but falls back to using the online image provider by sending the album and artist.

However I, and probably others, have a lot of albums which have the cover art in a file within the same directory such as Folder.jpg or AlbumArt.jpg etc.

I propose for this to become the second option, with the online image provider as the last fallback.

In order of preference:
1) Embedded art
2) Art within the same folder
3) Online provided art

Related branches

Andrew Hayzen (ahayzen) wrote :

I wasn't sure if this should be reported against mediascanner or thumbnailer? so I have reported against both please mark as invalid where appropriate.

Jussi Pakkanen (jpakkane) wrote :

Is there a specification or list of common filenames for this use case?

Andrew Hayzen (ahayzen) wrote :

These are the filenames i've seen:
folder.jpg
.folder.jpg
cover.jpg
album.jpg
albumart.jpg
front.jpg
$artist - $album.jpg

I managed to find this question [0] on askubuntu, which was actually has an answer from James Henstridge :)

Note that it also states what Rhythmbox does:
'From where is artwork fetched?
Rhythmbox uses last.fm to look up artwork. If you have local image files, saved in the same directory as the audio file(s) with the filename "cover", "album", "albumart", ".folder", "folder" or "$artist - $album" Rhythmbox will use them instead of looking up a cover on last.fm. It will also use images extracted from file tags.'

0 - http://askubuntu.com/questions/123612/how-do-i-set-album-artwork

Changed in mediascanner2:
status: New → Invalid
Changed in thumbnailer:
status: New → In Progress
Michi Henning (michihenning) wrote :

Should we still integrate support for this into thumbnailer?

Andrew Hayzen (ahayzen) wrote :

We just had another duplicate report for this against music.

If still possible I would love to see this supported with the thumbnailer, I feel it is important in the move to convergence as we meet challenges with larger and more varied music library structures. And it is very useful for providing an image when the online source doesn't have one or overriding the online's suggestion.

Ruben Maes (ruben-maes96) wrote :

Also, I'd appreciate an option to entirely turn off internet lookup of albums. I don't like it that the names of all music in my collection are being sent to... where are they actually sent?

Michi Henning (michihenning) wrote :

Requests are sent to https://dash.ubuntu.com. It's basically a cache in front of another service that can provide artwork (currently 7digital).

The requests made by the thumbnailer contain the artist, album, and an API key. Even if dash.ubuntu.com would want to spy on your album collection (it doesn't), what it could learn would be limited to the information it gets from the incoming HTTP headers and the incoming connection.

Turning online art lookup off is possible, but only on a system-wide basis because the thumbnailer is shared among a number of applications and scopes. Making this option available would require design input though.

Cédric Bellegarde (gnumdk) wrote :

Wanted feature... Google music handles this since lollipop.

Changed in mediascanner2:
status: Invalid → In Progress
Changed in thumbnailer:
status: In Progress → Invalid
Ruben Maes (ruben-maes96) wrote :

A fix has been written but has been sitting unreviewed for more than 9 months ...
https://code.launchpad.net/~jpakkane/mediascanner2/standalone-art-uri/+merge/244588

Pat McGowan (pat-mcgowan) wrote :

@james Is this something you can pick up?

Changed in mediascanner2:
assignee: nobody → James Henstridge (jamesh)
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
milestone: none → ww46-2015
status: New → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
affects: mediascanner2 → mediascanner2 (Ubuntu)
James Henstridge (jamesh) wrote :

There are test packages for this in silo 40 if anyone wants to give them a try:

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-040

Things seem to work okay in my own testing (checking My Music scope and music-app). This is based on Jussi's earlier branch, with support extended to album art rather than just song art, and a small lookup cache added (i.e. so if you ask for art for every song in an album, it won't do the full directory scan each time).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mediascanner2 - 0.109+16.04.20151124.1-0ubuntu1

---------------
mediascanner2 (0.109+16.04.20151124.1-0ubuntu1) xenial; urgency=medium

  [ James Henstridge ]
  * If a folder contains an image file named
    {cover,album,albumart,.folder,folder}.{jpeg,jpg,png} use it as album
    art for songs in preference to online art if the songs do not have
    embedded art. (LP: #1372000)
  * Disable MountWatcher's callback during destruction so we don't call
    back into a partially destroyed class. (LP: #1492393)

  [ CI Train Bot ]
  * debian/libmediascanner-2.0-3.symbols: update to released version.
  * New rebuild forced.

 -- James Henstridge <email address hidden> Tue, 24 Nov 2015 08:56:52 +0000

Changed in mediascanner2 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers