dragging terminator window to the top of a KDE desktop screen fails to maximize it properly

Bug #1257319 reported by Julián Moreno Patiño on 2013-12-03
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Terminator
Low
Unassigned

Bug Description

Hello,

Dragging the terminator window to the top of a KDE desktop screen fails to maximize the window properly. Sometimes the window partially fills one screen or partially fills two screens when dual displays are used. However, the maximize button on the window functions properly and the window maximizes on one screen.

This behavior is exhibited only by terminator. Other updated applications do not exhibt this behavior.

This was reported in Debian in http://bugs.debian.org/731193

I attach some screenshots and the debug file.

Julián Moreno Patiño (junix) wrote :
Julián Moreno Patiño (junix) wrote :
Julián Moreno Patiño (junix) wrote :

Also affecting version 0.97 in Fedora 20 ( KDE spin )

essl (essl-main) wrote :

Double clicking on the title maximizes it much better but leaves a small margin between the window borders and the screen borders (annoying).
The same happens if maximized with a shortcut...
Dragging the window when maximized by shortcut/doubleclick actually drags the window but leaves the maximized flag on.
Dragging the terminator window to the top of the screen and then dragging again unchecks the maximized flag.

The drag to top xwininfo and xprop:

xwininfo
  Absolute upper-left X: 2169
  Absolute upper-left Y: 20
  Relative upper-left X: 0
  Relative upper-left Y: 0
  Width: 1914
  Height: 1053
  Depth: 32
  Visual: 0xec
  Visual Class: TrueColor
  Border width: 0
  Class: InputOutput
  Colormap: 0xc0004b (not installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners: +2169+20 --243+20 --243-7 +2169-7
  -geometry 239x69+2169+0

xprop
_NET_WM_ICON_GEOMETRY(CARDINAL) = 0, 226, 42, 88
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_MOVE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_CLOSE
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 2, 2, 23, 4
_NET_FRAME_EXTENTS(CARDINAL) = 2, 2, 23, 4
_NET_WM_DESKTOP(CARDINAL) = 0
WM_STATE(WM_STATE):
  window state: Normal
  icon window: 0x0
_NET_WM_STATE(ATOM) = _NET_WM_STATE_MAXIMIZED_VERT, _NET_WM_STATE_MAXIMIZED_HORZ
WM_HINTS(WM_HINTS):
  Client accepts input or input focus: True
  Initial state is Normal State.
  bitmap id # to use for icon: 0xc0006d
  bitmap id # of mask for icon: 0xc00070
  window id # of group leader: 0xc00001
XdndAware(ATOM) = BITMAP
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
_NET_WM_ICON(CARDINAL) = Icon (48 x 48):
_KDE_OXYGEN_BACKGROUND_GRADIENT(CARDINAL) = 1
_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 12582994
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
_NET_WM_USER_TIME(CARDINAL) = 153409646
_KDE_NET_WM_USER_CREATION_TIME(CARDINAL) = 62984054
_NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0xc00051
WM_CLIENT_LEADER(WINDOW): window id # 0xc00001
_NET_WM_PID(CARDINAL) = 26036
WM_LOCALE_NAME(STRING) = "en_US.UTF-8"
WM_NORMAL_HINTS(WM_SIZE_HINTS):
  program specified resize increment: 8 by 15
  program specified base size: 2 by 18
  window gravity: NorthWest
WM_PROTOCOLS(ATOM): protocols WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_CLASS(STRING) = "terminator", "Terminator"

Also there is no difference between the two states except the geometry of course...

Stephen Boddy (stephen-j-boddy) wrote :

Hi Bug subscribers, this is the maintainer (Steve Boddy) of Terminator, who took over from Chris.

In case you were not aware there has been a new release 0.98 of Terminator in the last few days which has many changes, fixes and updates. We also have an ongoing GTK3 port which uses a much more up-to-date libvte.

Even with the ~50 issues closed by that release, and discounting the ~90 outstanding wishlist items, we still have an unwieldy 95 bugs. With the oldest approaching it's 6th birthday and some that haven't seen any updates in nearly 5, it is time for a purge.

My intention is to try and get this list down to a minimum, and for that I need your help.

First I'm going to work through, oldest to newest, setting bugs to Incomplete, pending confirmation that they are still an issue. If after a month there is no feedback, the issue will get closed as Invalid. Here's where you come in. I can't always reproduce, or setting up (i.e. other distros) to even test takes a long time, so I'm going to try crowdsourcing this.

1. Get the latest release. Is it still an issue? If yes, set the confirmed-0.98 tag. For bonus points follow the guide http://gnometerminator.blogspot.com/2015/09/so-you-want-to-try-terminator-gtk3.html and see if the GTK3 branch has same issue, and set the confirmed-gtk3 or notaffected-gtk3 tag.

2. Can you reproduce with an empty/default config file? You can pass "-g temp_config" to do this without affecting your existing config. If you already have Terminator running, you'll need to pass -u as well to disable the DBus.

3. If able to, can you reproduce with another user/guest account?

4. If the issue does not already have clear, precise instructions to reproduce with minimal setup/steps, add them.

5. Put as much info about what you are running.
   * Software/library versions (libvte, gtk, pango, cairo, distro, desktop environment, language)
   * Screens (single or multi)
   * Any unusual / custom packages or configs that might be interacting.

6. If possible attach the config file, unless the issue also happens with an empty one, but mention that.

7. Attach the "-d" debug output from 0.98.

Some common things that cause incidents.

* Strange sizing issues or rapidly shrinking windows - Try turning off Window geometry hints.
* Input (esp. broadcasting duplicate chars etc) problems - Try killing IBus.
* Hand editing of the config file can cause various issues - Due to misunderstanding, incorrect structure or typos.
* Some issues are actually in libvte - This is why testing GTK3 is so important.
* segfaults - Unfortunately these are dying inside the C libraries, and it is usually beyond me to fix those.

Many thanks for your assistance, and hopefully this will get us closer to a bug-free Terminator.

Changed in terminator:
status: New → Incomplete
Charles Williams (charlwillia6) wrote :

So I did install terminator-gtk3-bzr and found that the issue of space (margin) around the window borders is minimized a little with the gtk version. Before I had about a 5px space between the bottom of the terminal and the right side of the terminal no matter what the terminal was against (window tiling). With the gtk3 version there is no extra space on the bottom of the window terminal, but there is still about a 3px space on the right side of the terminal that does not line up with other windows or the screen edge.

I am using xfce-4 with xfwm.

Stephen Boddy (stephen-j-boddy) wrote :

Could you all follow the advice in https://bugs.launchpad.net/terminator/+bug/1408040 and confirm if this is a duplicate of that issue?

I suspect you are seeing the same issue with window geometry hints and KDE desktop. These WGH have been disabled by default now, because I'm sick of seeing bug reports due to them doing "weird crap". If someone wants them desperately enough, they can re-enable, and either live with the quirks, or perhaps even fix them so they don't break sizing.

Changed in terminator:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers