Telepathy Indicator Service

Removing an entry from dconf entry /com/canonical/indicator/messages/applications does not have any effects and does not stick across logins

Reported by TomasHnyk on 2012-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Telepathy Indicator
Undecided
Unassigned

Bug Description

I use pidgin as my IM client (with pidgin patched to support the new messaging indicator from here https://launchpad.net/~jconti/+archive/gnome3 ) and so I wanted to remove the empathy entry from messagin menu. Uninstalling Empathy removes the ability to set global status (bug 1083564), so I tried to remove 'empathy.desktop' from /com/canonical/indicator/messages/applicationsin dconf-editor but it does not remove Empathy entry fom the indicator. Also, after logging out and logging int, "empathy.desktop" creeps back into /com/canonical/indicator/messages/applications. This is on up-to-date Ubuntu 12.10.

TomasHnyk (sup) on 2012-11-27
description: updated
TomasHnyk (sup) wrote :

Also note that the method suggested here http://askubuntu.com/a/15604/16234 - putting a blacklist entry to ~/.config/indicators/messages/applications-blacklist/ does not work either.

description: updated
Lars Uebernickel (larsu) wrote :

Hi Thomas, thanks for taking the time to report this bug.

Do you have telepathy-indicator installed on your system? It starts automatically when you log in and inserts empathy.desktop into the messaging menu. Please uninstall that package to make empathy disappear from the messaging menu. (This should be configurable from empathy's preferences dialog. We are tracking this as part of bug #941463.)

The blacklisting functionality has been removed in 12.10, because there are no applications in the menu by defaut anymore.

Changed in indicator-messages:
status: New → Incomplete
TomasHnyk (sup) wrote :

Thanks for a quick reaction, I really appreciate that. Indeed, removing telepathy-indicator and then removing "empathy.desktop" from dconf key works. However, I do not see how bug #941463 is related - it is about autostarting empathy, this one is about removing it from the messaging list.

I think that as long as such an option to remove an entry from messaging menu through dconf is present, it should work (what is the reason for adding "empathy.desktop" on each login? should not it be added once when installed?). To me it seems a bug in telepathy-indicator, but of course maybe I am mistaken.

TomasHnyk (sup) wrote :

(Or remove this key option from dconf altogehter and let the uninstallation of the application to be the only way to remove an application from the messaging menu, that would work as well. It just seems to me that if something is in dconf, it is made to be configurable and automatically overwriting configuration is not nice).

Lars Uebernickel (larsu) wrote :

The dconf key is the way that indicator-messages remembers which applications should be shown in the menu. Applications have to be able to overwrite it so that they can add themselves to the messaging menu.

Right, bug #941463 is indeed only tangentially related. The problem is that telepathy-indicator shouldn't be autostarted when empathy is not installed.

TomasHnyk (sup) wrote :

Right, but is it reasonable that empathy forces (via telepathy-indicator) itself into the menu everytime it is run?

Lars Uebernickel (larsu) wrote :

No, it should be configurable through empathy's preferences dialog.

Lars Uebernickel (larsu) wrote :

For quite some time now, telepathy-indicator only adds empathy to the messaging menu when empathy is running. This should fix this bug as well. Feel free to reopen it if you're still experiencing the issue in Trusty.

affects: indicator-messages → telepathy-indicator
Changed in telepathy-indicator:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers