empathy reports network error and requires killing telepathy-butterfly / telepathy-haze

Reported by Leandro on 2010-01-19
164
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Undecided
Unassigned
Telepathy Haze
New
Undecided
Unassigned
telepathy-butterfly
Confirmed
Medium
telepathy-butterfly (Ubuntu)
Medium
Unassigned
telepathy-haze (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: empathy

I'm getting frequent but random "Network error" messages from empathy when
trying to connect to my Yahoo! or MSN accounts. Most of the times it does not
connect, but sometimes it does. However, once it has the problem, I cannot connect
to the problematic account anymore. I have to close empathy, kill from the
terminal the telepathy-butterfly job, and open empathy again, in which case
it connects. After a while I can get disconnected again with "Network error".

There are other "Network error" problems reported in Karmic for specific protocols,
but I'm not sure if they report the same problem as me.

ProblemType: Bug
Architecture: amd64
Date: Tue Jan 19 14:35:40 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
NonfreeKernelModules: fglrx
Package: empathy 2.28.1.1-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: empathy
Uname: Linux 2.6.31-17-generic x86_64

Leandro (leandromartinez98) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Leandro (leandromartinez98) wrote :

The bug is reported upstream here:

https://bugzilla.gnome.org/show_bug.cgi?id=607468

Changed in empathy (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Triaged
Changed in empathy:
importance: Unknown → High
Omer Akram (om26er) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME.

Changed in empathy:
importance: High → Undecided
status: Unknown → New
status: New → Invalid
affects: empathy (Ubuntu) → telepathy-butterfly (Ubuntu)
Changed in telepathy-butterfly (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → New
Sary Muhammad (sary) wrote :

This issue effect me with : empathy 2.32.0.1-0ubuntu1 on Maverick .

ginalfa (ginalfa) wrote :

same here on maverick
I need to remove telepathy-butterfly to connect msn.

valkyr (locki) wrote :

Why doesn't terminal auto-complete recognise the process name, when "killall telepathy-butterfly" works?

I notice it's the only telepathy-* that's written in Python.

I can confirm this as well. Also, it is one of the main issues that prevents me from switching from pidgin to empathy since it happens quite often.

From Ubuntu Bug: Telepathy 0.5.14-1

I'm getting frequent but random "Network error" messages from empathy when
trying to connect to my Yahoo! or MSN accounts. Most of the times it does not
connect, but sometimes it does. However, once it has the problem, I cannot
connect
to the problematic account anymore. I have to close empathy, kill from the
terminal the telepathy-butterfly job, and open empathy again, in which case
it connects. After a while I can get disconnected again with "Network error".

There are other "Network error" problems reported in Karmic for specific
protocols,
but I'm not sure if they report the same problem as me.

More data of my machine is available at:
https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/509721

ProblemType: Bug
Architecture: amd64
Date: Tue Jan 19 14:35:40 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/empathy
NonfreeKernelModules: fglrx
Package: empathy 2.28.1.1-0ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: empathy
Uname: Linux 2.6.31-17-generic x86_64

Brian Curtis (bcurtiswx) wrote :

Moved to the appropriate upstream reporter and linked here.

Changed in telepathy-butterfly (Ubuntu):
status: New → Triaged
Changed in telepathy-butterfly:
importance: Unknown → Medium
status: Unknown → Confirmed
Hendy Irawan (ceefour) wrote :
Download full text (3.5 KiB)

Also happens with telepathy-haze (Yahoo).

After killing telepathy-haze, the Yahoo account works again.

Note before killing telepathy-haze.. changing the username works to connect to another YM account, but when I changed the username back to the problematic username, it gives "Disconnected - Network Error" again immediately (without any sign of progress of actually trying to connect to the network).

$ aptitude show empathy telepathy-haze

Package: empathy
State: installed
Automatically installed: no
Version: 2.32.1-0ubuntu1
Priority: optional
Section: gnome
Maintainer: Ubuntu Core Developers <email address hidden>
Uncompressed Size: 2.458k
Depends: libatk1.0-0 (>= 1.29.3), libc6 (>= 2.7), libcairo2 (>= 1.2.4),
         libcanberra-gtk0 (>= 0.4), libcanberra0 (>= 0.2), libdbus-1-3 (>=
         1.0.2), libdbus-glib-1-2 (>= 0.78), libdbusmenu-glib1 (>= 0.3.12),
         libebook1.2-9 (>= 2.30.3), libedataserver1.2-13 (>= 2.30.3),
         libenchant1c2a (>= 1.6), libfolks-telepathy0 (>= 0.1.9), libfolks0 (>=
         0.1.15), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1),
         libgconf2-4 (>= 2.31.1), libgcr0 (>= 2.26.0), libgdk-pixbuf2.0-0 (>=
         2.21.6), libgee2 (>= 0.5.2), libglib2.0-0 (>= 2.25.16),
         libgnome-keyring0 (>= 2.26.0), libgnutls26 (>= 2.7.14-0), libgp11-0 (>=
         2.24), libgstfarsight0.10-0 (>= 0.0.1), libgstreamer-plugins-base0.10-0
         (>= 0.10.0), libgstreamer0.10-0 (>= 0.10.4), libgtk2.0-0 (>= 2.21.8),
         libindicate-gtk2 (>= 0.2.2), libindicate4 (>= 0.3.3),
         liblaunchpad-integration1 (>= 0.1.17), libnm-glib2 (>=
         0.8~a~git.20090826t185111.79489be), libnotify1 (>= 0.5.0),
         libnotify1-gtk2.10, libpango1.0-0 (>= 1.18.0), libpng12-0 (>=
         1.2.13-4), libsoup2.4-1 (>= 2.4.0), libtasn1-3 (>= 1.6-0),
         libtelepathy-farsight0 (>= 0.0.6), libtelepathy-glib0 (>= 0.11.15),
         libtelepathy-logger1 (>= 0.1.2), libunique-1.0-0 (>= 1.0.0),
         libwebkit-1.0-2 (>= 1.1.15), libx11-6, libxml2 (>= 2.7.4), zlib1g (>=
         1:1.1.4), empathy-common (= 2.32.1-0ubuntu1),
         telepathy-mission-control-5, gnome-icon-theme (>= 2.30.0), dbus-x11,
         telepathy-logger
Recommends: telepathy-gabble, telepathy-salut, libdconf0, gvfs-backends,
            telepathy-haze, telepathy-butterfly, nautilus-sendto-empathy
Suggests: telepathy-idle, vino
Breaks: telepathy-butterfly (< 0.5.10)
Replaces: libempathy-gtk-common
Description: GNOME multi-protocol chat and call client
 Instant messaging program supporting text, voice, video, file transfers and
 inter-application communication over many different protocols, including: AIM,
 MSN, Google Talk (Jabber/XMPP), Facebook, Yahoo!, Salut, Gadu-Gadu, Groupwise,
 ICQ and QQ.

 This package contains the Empathy IM application and account manager.
Homepage: http://live.gnome.org/Empathy

Package: telepathy-haze
State: installed
Automatically installed: no
Version: 0.4.0-1ubuntu0.1
Priority: optional
Section: net
Maintainer: Ubuntu Developers <email address hidden>
Uncompressed Size: 229k
Depends: libc6 (>= 2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0...

Read more...

summary: - empathy reports network error and requires killing telepathy-butterfly
+ empathy reports network error and requires killing telepathy-butterfly /
+ telepathy-haze
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in telepathy-haze (Ubuntu):
status: New → Confirmed

Any update ?
Same issue on Oneiric

Stevy (stefan-bley-dd) wrote :

I confirm this for 11.10 (Oneiric)

On Fri, Dec 2, 2011 at 2:49 AM, Stevy <email address hidden> wrote:
> I confirm this for 11.10 (Oneiric)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (513346).
> https://bugs.launchpad.net/bugs/509721

In the past, when I was using MSN (more known as Windows Live
Messenger), I resolved this issue by removing the package
telepathy-butterfly.

However I think Google Talk is better than MSN, and the Windows Live
Messenger client is not good.

So I suggest you try Google Talk, it works in Empathy and in Windows too.

http://www.google.com/talk

--
Ioannis Vranos

http://www.cpp-software.net

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.