Screen doesn't dim/turn off [$50]

Bug #1373602 reported by Shelby Brinegar on 2014-09-24
120
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Switchboard Power Plug
Fix Released
High
Cody Garver

Bug Description

A problem I've encountered on Freya is an issue regarding the 'Dim screen when inactive' option in the power settings. No matter whether I have this option on or off, my screen never dims or turns off when I have the power cord connected. I can't close the laptop or it will go to sleep and stop what I'm doing, and if I leave it on, the screen doesn't dim or turn off.

I'm using an Asus S500CA with Intel Pentium processor and 4gb of ram. I've attatched a more thorough system info report

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.350+394~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
Uname: Linux 3.13.0-36-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Wed Sep 24 15:42:53 2014
InstallationDate: Installed on 2014-08-30 (25 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Shelby Brinegar (razzberrypi) wrote :
tags: added: system-settings
removed: third-party-packages
Jason Anderson (ertain) wrote :

A similar thing happens to me. My screen doesn't dim. What's interesting is that there is no longer a schema for "idle-dim-time" in gsettings. Also, in gsettings, some of the schema repeat. For instance, this is the output of "gsettings list-recursively | grep idle":

org.gnome.desktop.screensaver idle-activation-enabled true
org.gnome.desktop.session idle-delay uint32 300
org.gnome.settings-daemon.plugins.power idle-dim true
org.gnome.settings-daemon.plugins.power idle-brightness 970
org.gnome.settings-daemon.plugins.power idle-dim true
org.gnome.settings-daemon.plugins.power idle-brightness 970

I don't know why it repeats. It could be additional settings from the Gnome Control Center packages (they have the prefix "switchboard-plug-gcc" in the package manager).

I'm thinking that some of the settings have their wires crossed.

Changed in switchboard-plug-power:
status: New → Confirmed
Daniel Fore (danrabbit) wrote :

AFAIK, this feature was removed in GSD: https://git.gnome.org/browse/gnome-settings-daemon/commit/?id=58cb4eee64bbd8ca43111b1f80fdaacde8ad5f12

If it was patched back in or there is some way to work around it, I don't particular have a problem with it.

OP, please keep a report narrowed down to a single issue. It's not possible to properly track group reports.

Shelby Brinegar (razzberrypi) wrote :

I'm sorry I had 2 technical bugs filed under one report, but my main issue was that both of these problems existed. If it were only one, I probably wouldn't have filed a report because I could have worked with that.

And recently I discovered that even when I hit the button on my laptop to turn off the screen (fn+f7) the screen would remain on. The backlight would turn completely off, but when I shined a flashlight at the screen of my laptop, I could see all of my windows and everything. I could even control the mouse and use the computer normally, a bit hard to see, but it could be done. That's a major problem because while that display is on for hours of non-use, it could create ghosting or burn-in and permanantly damage the screen. I haven't noticed anything wrong with my screen, except that I've been spotting more and more dead pixels.

But anyways I found solutions to both of the issues!

First, to resolve the screen that never sleeps, install light-locker using apt-get or the software center. Open and configure the settings by running light-locker-settings in terminal.

Second, to resolve the always sleeping closed-lided laptop, install unity-control-center using apt-get or the software center. Open the control center using unity-control-center in terminal and go to the 'power' tab. There you will find the option to make the laptop do nothing when the lid is closed.

I thoroughly checked to make sure, and I can say that at least for me, these steps have resolved my issues completely. I checked several different applications, and light-locker was the only one that completely shut off my display.
Now hopefully my pixels will stop dying :)

I hope this has been helpful and takes care of your problems. Let me know if it does.

Kauliukas (6d61696c) wrote :

I can definitely confirm that "Dim screen when inactive" is definitely not working.

Also "power options" is way too limited if you are using a laptop.

PerfectCarl (name-is-carl) wrote :

At the moment when the the lid is closed, the current session is locked.
And this could be a problem for laptop owners like it was for me.

After months of closing my laptop lid instead of shutting it down I discovered that the locked screen pixels were burnt into my display.
Whatever the screen displayed, there was a "ghosted" image of the locked screen behind it.
For some display it can be fatal.

Luckily I managed to reset the pixels but I was very worried.
Since then I can't recommend anyone to close their laptop lids.

As this issue can damage your hardware, I bump the importance.

Note: I am talking about the fact that your display won't turn off after some time. But unfortunately it can result is the same issue. Wearing needlessly your screen and much loved pixels.

Changed in switchboard-plug-power:
importance: Undecided → High
Arnab Das (talktoarnab) wrote :

We all know elementary Freya does not have a power option for closing lid, by default it hibernates.
To deal with it i used a workaround in dconf editor to "do nothing" when lid is closed.
this was working well until recent update, where it is either hibernating or going into a "dead" state where its not waking up at all (its not shutting down).

Erasmo Marín (erasmo-marin) wrote :

This option is not working for me, I first tried doing it throug gnome-tweaks-tool but didn't worked. Also tried from dconf, but with no lucky. Then after some research, I found that the lid close action is now handled by systemd, so the solution is to set the option through Dbus. The problem, is that systemd can't handle AC/Battery actions, so I have no idea how to deal with this.

Here is some relevant information:
https://wiki.archlinux.org/index.php/Power_management

timonoj (timonoj-gmail) wrote :

What's the reason for the removal? I can't believe it was simplification of the UI on this case...

Erasmo Marín (erasmo-marin) wrote :

I think the removal is because it was not working, now an implementation through dbus is needed.

Jason Anderson (ertain) wrote :

So, when someone closes the lid, that action should tell the system via dbus to not make the laptop go to sleep? In other words, systemd has to tell the system via dbus, "Look, the lid's closed!," and so dbus has to tell the system for battery and AC stuff, "systemd has told me the lid has closed. So, uh, please don't go to sleep?"

Changed in switchboard-plug-power:
assignee: nobody → kay van der Zander (kay20)
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2015-09-18
Changed in switchboard-plug-power:
milestone: none → loki-beta1
Changed in elementaryos:
milestone: none → loki-beta1
Cody Garver (codygarver) on 2015-09-22
Changed in elementaryos:
importance: Undecided → Medium
Laksa (elru-lakusa) wrote :

[Slove]
Setting from dconf editor
org.gnome.settings-daemon.plugins.power

Laksa (elru-lakusa) wrote :

[SLOVED]
Setting from dconf editor
org.gnome.settings-daemon.plugins.power

Cody Garver (codygarver) on 2016-02-12
no longer affects: elementaryos
Cody Garver (codygarver) on 2016-02-23
Changed in switchboard-plug-power:
assignee: kay van der Zander (kay20) → nobody
status: In Progress → Confirmed

Narrowed the title and description of this report since there are other reports to track other issues. Also removed a lot of the narrative so we could see what exactly is the problem OP is reporting

summary: - Power settings functionality removed, and screen doesn't dim/turn off.
- (Freya) [$10]
+ Screen doesn't dim/turn off [$10]
description: updated
Daniel Fore (danrabbit) on 2016-05-03
summary: - Screen doesn't dim/turn off [$10]
+ Screen doesn't dim/turn off [$50]
Cody Garver (codygarver) on 2016-05-13
Changed in switchboard-plug-power:
assignee: nobody → Cody Garver (codygarver)
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2016-08-12
Changed in switchboard-plug-power:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions