impossible to set keyboard layout switch to alt+shift instead of alt+space

Bug #1444659 reported by Paul on 2015-04-15
248
This bug affects 60 people
Affects Status Importance Assigned to Milestone
Switchboard Keyboard Plug
Fix Released
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

impossible to set keyboard layout switch to alt+shift instead of alt+space

Related branches

Paul (chmykh-pv) on 2015-04-15
affects: pantheon-plugs → switchboard-plug-keyboard
Andrey Kolchenko (komex) wrote :

Also, you can't set Caps Lock (only terminal).

It seems that LeftAlt & LeftShift cannot be set as a keyboard shortcut at all. In other GTK desktops as GNOME 3.14 and Cinnamon 2.4 this option is enabled.

Maxim Taranov (png2378) wrote :

This is possible by using terminal

gsettings set org.pantheon.desktop.gala.keybindings switch-input-source "['<Alt>Shift_L', '<Alt>Shift_R', '<Shift>Alt_L', '<Shift>Alt_R']"

But this can't be done by using System Setting. This is amiss, because in WIndows and in the mass Linux distributions this shortcut is default and many people are used to it. This related to Shift+Ctrl and and other popular shortcuts.

Changed in switchboard-plug-keyboard:
status: New → Confirmed
Maxim Taranov (png2378) on 2015-12-03
tags: added: keyboard-layout
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Maxim Taranov (png2378) on 2016-05-26
tags: added: internationalization
Maxim Taranov (png2378) on 2016-06-23
Changed in switchboard-plug-keyboard:
status: Confirmed → In Progress
Maxim Taranov (png2378) on 2016-06-30
Changed in switchboard-plug-keyboard:
status: In Progress → Fix Committed
Changed in ubuntu:
status: Confirmed → Invalid
Daniel Fore (danrabbit) on 2016-08-12
Changed in switchboard-plug-keyboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers