Comment 32 for bug 245836

Kuisathaverat (kuisathaverat) wrote :

Finally i will put the instruction to make a bundle and a SDK to meke it on Mac OS X
You need installed macports to make the bundle and some packages , these are the install lines
$ sudo port install python25
$ sudo port install python_select
$ sudo python_select python25
$ sudo port install py25-macholib-devel
$ sudo port install py25-sip
$ sudo port install py25-pyqt4
$ sudo port install py25-py2app-devel
$ sudo port install py25-pyqt
When you have this packages installed you can uncompress the atacthment of this post is a directory with SubDownloader 9.0.3 and a script that makes py2app and a dmg image file. You only run build.sh and all will be make, it ask for a password to change the python version to 2.5, when the scripts exits put apple python as default.
To change the version of SubDownloader you only have to change the directory SubDownloader.