Stellarium crashes on night mode

Bug #596453 reported by Tobias Seyb on 2010-06-20
This bug affects 7 people
Affects Status Importance Assigned to Milestone

Bug Description

Stellarium 0.10.5 crashes/quits immediately when clicking night mode.

My system:
Stellarium 0.10.5
MacOS X 10.4.11

Related branches

tags: added: mac-os-x
removed: mac version
Kyle Owens (kylerowens) on 2010-07-19
tags: added: 10.04 ubuntu
removed: mac-os-x
Kyle Owens (kylerowens) wrote :

This was fixed for me when I installed the libqt4-sql-sqlite package instead of the libsqt4-dev package specified in the Build Dependencies page of the wiki

Don't know if this helps the issue on OSX

tags: added: mac-os-x
removed: 10.04 ubuntu
Leo Arias (elopio) wrote :

The bug reported refers to Mac OSX version. If it can be reproduced on Ubuntu feel free to report the issue against stellarium (ubuntu) package.


Changed in ubuntu:
status: New → Invalid
Bahram Shahrooz (shahrooz956) wrote :

I am running 0.10.5 on Mac OSX and I have the same problem, i.e., on night mode the program crashes.

Bogdan Marinov (daggerstab) wrote :

I think I've located the problem: the crash appears when the Oculars plug-in fails to load due to missing SQLite driver. It seems that the SQLite driver was not included in the Mac OS X package.

Could any of the Mac users please confirm this? Try disabling Oculars (Remove the tick from "Load at startup" for Oculars in Stellarium's Configuration window), restart Stellarium and report the result.

Bahram Shahrooz (shahrooz956) wrote :


Yes, it works! I am very new to astronomy; so I am not sure what I will be missing by disabling Osculars.


shelleyfrank (michael-pienaar) wrote :

Bogdan Marinov is correct. I've disabled the Ocular plug-in in settings and exited, restarted Stellarium and the night vision now works as it should without crash. Ironically, I've downgraded to 0.10.4 because I could live without the night vision feature, but missed the Ocular plug-in in 0.10.4, which is missing from the 0.10.5 toolbar even with Ocular enabled in settings. it'd be nice if the Ocular plug-in will work in the next release. Thanks for the help.

shelleyfrank (michael-pienaar) wrote :

Quote Bogdan Marinov: "It seems that the SQLite driver was not included in the Mac OS X package".

This is not true. The SQLite driver is included but seems to be malfunctioning.

I found a sollution albeit a temporary one:

Open the Stellarium 0.10.5 package and brows to Contents\ MacOS\ sqldrivers\.. and replace the libqsqlite.dylib file with libqsqlite.dylib from Stellarium 0.10.4. Run Stellarium 0.10.5 and the Ocular plug-in functions well plus Night Vision functions well.

I haven't tested any other features yet, but will keep you posted.

Bogdan Marinov (daggerstab) wrote :

Confirmed on Windows, too (by removing the SQLite driver DLL file from Stellarium's folder.)

I've committed a fix to the code that will prevent a crash if the driver is missing. The Mas OS X maintainer though should check why the driver was not included in the package.

Changed in stellarium:
importance: Undecided → High
status: New → Confirmed
Diego (diego-marcos) on 2010-07-30
Changed in stellarium:
assignee: nobody → Diego (diego-marcos)
serastrof (serastrof) wrote :
Download full text (31.4 KiB)

stellarium o.10.5 si chiude inaspettatamente quando si passa alla visione notturna.

Ho reinstallato un minuto fa il programma, il bug si ripete. Ecco quanto riporta il sistema:

Process: stellarium [619]
Path: /Volumes/stellarium-0.10.5/
Identifier: org.stellarium.Stellarium
Version: ??? (0.10.1)
Code Type: X86 (Native)
Parent Process: launchd [104]

Date/Time: 2010-08-11 02:40:47.145 +0200
OS Version: Mac OS X 10.6.4 (10F569)
Report Version: 6

Interval Since Last Report: 34465 sec
Crashes Since Last Report: 4
Per-App Interval Since Last Report: 12 sec
Per-App Crashes Since Last Report: 1
Anonymous UUID: 00C6CC2F-57D6-496D-8F1A-E554FA28B9AC

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000008
Crashed Thread: 0 Dispatch queue:

Thread 0 Crashed: Dispatch queue:
0 org.stellarium.Stellarium 0x00308fd2 OcularDialog::updateStyle() + 18
1 org.stellarium.Stellarium 0x0005a88e StelApp::setColorScheme(QString const&) + 174
2 org.stellarium.Stellarium 0x0005d96f StelApp::setVisionModeNight(bool) + 79
3 org.stellarium.Stellarium 0x001ded78 StelApp::qt_metacall(QMetaObject::Call, int, void**) + 152
4 QtCore 0x017f4d1a QMetaObject::activate(QObject*, QMetaObject const*, int, void**) + 570
5 QtGui 0x00ad4c44 QAction::toggled(bool) + 68
6 QtGui 0x00ad6e98 QAction::setChecked(bool) + 120
7 QtGui 0x00ad7f19 QAction::qt_metacall(QMetaObject::Call, int, void**) + 601
8 QtCore 0x017f4d1a QMetaObject::activate(QObject*, QMetaObject const*, int, void**) + 570
9 org.stellarium.Stellarium 0x0026f974 StelButton::toggled(bool) + 68
10 org.stellarium.Stellarium 0x0020ace0 StelButton::mousePressEvent(QGraphicsSceneMouseEvent*) + 96
11 QtGui 0x010fecfe QGraphicsItem::sceneEvent(QEvent*) + 1294
12 QtGui 0x011257db QGraphicsScenePrivate::sendEvent(QGraphicsItem*, QEvent*) + 283
13 QtGui 0x01126185 QGraphicsScenePrivate::sendMouseEvent(QGraphicsSceneMouseEvent*) + 1221
14 QtGui 0x0112e91f QGraphicsScenePrivate::mousePressEventHandler(QGraphicsSceneMouseEvent*) + 1887
15 QtGui 0x0112ed20 QGraphicsScene::mousePressEvent(QGraphicsSceneMouseEvent*) + 128
16 QtGui 0x0113d030 QGraphicsScene::event(QEvent*) + 1824
17 QtGui 0x00adc4bf QApplicationPrivate::notify_helper(QObject*, QEvent*) + 175
18 QtGui 0x00ae243b QApplication::notify(QObject*, QEvent*) + 379
19 QtCore 0x017ef492 QCoreApplication::notifyInternal(QObject*, QEvent*) + 98
20 QtGui 0x00adc5dc qt_sendSpontaneousEvent(QObject*, QEvent*) + 60
21 QtGui 0x01156fd9 QGraphicsView::mousePressEvent(QMouseEvent*) + 969
22 QtGui ...

treaves (treaves) wrote :

Oculars no longer uses SQLite; this bug should be closed. It's not that it's not valid, it's just simply no longer relevant (as-of the next release anyway).

treaves (treaves) on 2010-10-30
Changed in stellarium:
status: Confirmed → Invalid
Bogdan Marinov (daggerstab) wrote :

If the Oculars plug-in has been changed so that it no longer uses SQL, then...

Changed in stellarium:
assignee: Diego (diego-marcos) → nobody
status: Invalid → Fix Committed
Changed in stellarium:
milestone: none → 0.10.6
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers