object not centered in "telescopic" view mode

Bug #1484976 reported by gzotti on 2015-08-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Stellarium
Low
gzotti

Bug Description

Around r7818, I just found this annoying piece:

With atmosphere on, select and center a star on southeast, close to the horizon. Zoom in to very small FOV. It should be centered.

Now switch to "telescopic view" (equatorial coordinate frame). The star is no longer in center, and if zoomed fully in, it is even out of the upper screen border. Switch off atmosphere and it is centered. Culprit is in StelMovementMgr around line 713, (and maybe also L622 and/or elsewhere?)

v = objectMgr->getSelectedObject()[0]->getEquinoxEquatorialPos(core);

There should be a similar auto-refraction function like

->getAltAzPosAuto(core);

G.

2017-03: These lines are now 1017 and 1422.

Related branches

Changed in stellarium:
status: New → Confirmed
Alexander Wolf (alexwolf) wrote :

line 622 has same issue

Changed in stellarium:
milestone: 0.14.0 → 0.15.0
Nick Fedoseev (nick-ut2uz) wrote :

The vertical viewport offset feature is a very useful one for AltAz mode.
But this feature has absolutely no sense in EQ mode.

So, I have a proposal:
Do not cure this "object not centered" bug, but kill the offset for EQ mode, making the feature for AltAz mode only.

gzotti (georg-zotti) wrote :

Those things are unrelated!
And no, the offset may also be useful for equatorial mode.

Nick Fedoseev (nick-ut2uz) wrote :

Of course, this is only my opinion.
I see the only one purpose for vertical offset. it is a big FOV view in AltAz mode. It is really useful and looks great.
But try to use this feature in real life. For example, typical lecture for children. First, you show great AltAz view of the night sky. You tell about well known stars and constellations. Next, you show the moon. Why is it distorted? Hmm... Then turn On the Ocular View to show some galaxies... Why the half of ocular is below the screen border? Is it really what you want to show? Finally you go to the settings and switch off the feature as it makes any view in small FOV significantly distorted.

Just take attention, we even do not use EQ mode at all, but see how the potentially great feature causes problems.

As for poor me... who needs frequent switching between Ocular View, AltAz and EQ, who uses all the possible range of FOV...
I need a fast switch off the view offset, especially for EQ. If I really need vertical offset, then I need horizontal one as well there as I'd prefer shifting the picture on the diagonal.

Small FOV, ocular view, camera view, and EQ mode in general need viewport to be switched off. Perhaps sometimes the possibility of shifting the view is useful here as well, but it is definitely not the mainsteam. And current solution of switching the feature via F4 - Markings - mouse scroller looks unfriendly.

So, now, after imaging several scenarios of extensive work with the porgram, I'd like to propose even more strict limitation of viewport offset usage. It should be used for big FOVs in AltAz mode, perhaps smoothly changing the offset to zero along with FOV decrease.

Thanks for reading.

gzotti (georg-zotti) wrote :

You can always make two 1-line scripts and assign them to hotkeys. The screen offset has nothing to do with the bug described here and should be discussed elsewhere (SF forum or LP question department).

Alexander Wolf (alexwolf) wrote :

Well, the problem was introduced with altitude offset feature - currently altitude offset calculated for all mount frames as for horizontal coordinate system.

gzotti (georg-zotti) wrote :

The problem is unrelated to the viewport offset feature which is a totally different concept. Unrelated, as in "has nothing to do with it". Different reason. It has to do with some auto-refraction not working, as noted already in the code. If you set viewport offset (viewport offset, there is no altitude offset feature) to zero, the bug is still visible. Viewport offset has nothing to do with this bug.

I assign this to me now, but cannot promise when I have time. Not before April though.

Nicks idea is a feature request to automatically reset viewport offset during a zoom in, or inhibit viewport offset in equatorial mode because he does not see a reason to have it. There are reasons. This can only be useful as extra flag, like the automatically zooming out to config view position. I repeat, it is unrelated to the bug described in the bug description, and should be discussed as new wishlist entry.

Changed in stellarium:
assignee: nobody → gzotti (georg-zotti)
Alexander Wolf (alexwolf) wrote :

I didn't say that problem is related to the viewport offset feature. :) I said when problem has been introduced. In really I can see that shift is in horizontal coordinate system and this fact may be explained of 2 possible version: wrong apply of calculations for offset and refraction effect.

Changed in stellarium:
milestone: 0.15.0 → 1.0.0
no longer affects: stellarium/0.15
Changed in stellarium:
milestone: 1.0.0 → 0.16.0
gzotti (georg-zotti) on 2017-03-12
description: updated
gzotti (georg-zotti) on 2017-03-13
Changed in stellarium:
status: Confirmed → In Progress
gzotti (georg-zotti) wrote :

It took until r9179 to find time and fix this.

Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
milestone: 0.16.0 → 0.15.2
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers