StarlingX 2.0 Account is locked for user

Bug #1853093 reported by ANIRUDH GUPTA on 2019-11-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
High
yong hu

Bug Description

Brief Description
-----------------------------

StarlingX 2.0 Duplex Baremetal is installed which is up and running.

While using it for more than 30 mins regularly, horizon login fails with Invalid Credentials.
No change is done in any config file

When I tried to get a token a CLI, there is an error of "User Account Locked"

{"error":{"code":401,"message":"The account is locked for user: 230578cde382430a8adac399afab1230.","title":"Unauthorized"}}

After sometime, it gets login successfully without doing any changes

Issue
-------------------

The Account gets locked for user

Expected Behaviour
-------------------------------------

The Account should never get locked for the user

yong hu (yhu6) wrote :

what version of Cengn build were you running?
Which Horizon did you access? via port :8080 or :31000?

The issue might be similar to https://bugs.launchpad.net/starlingx/+bug/1853017

tags: added: stx.distro.openstack
Changed in starlingx:
importance: Undecided → High
assignee: nobody → yong hu (yhu6)
ANIRUDH GUPTA (anyrude10) wrote :

I am using the StarlingX 2.0 Release Branch

http://mirror.starlingx.cengn.ca/mirror/starlingx/release/2.0.0/centos/outputs/iso/

Horizon on 8080 is working fine, but on 310000 the issue is observed

yong hu (yhu6) wrote :

Are you using this helm chart?http://mirror.starlingx.cengn.ca/mirror/starlingx/release/2.0.0/centos/outputs/helm-charts/stx-openstack-1.0-17-centos-stable-versioned.tgz

If you want to disable the security policy, you can remove the following 3 lines in "~/charts/keystone/values" after you unzip this tgz file:

    security_compliance:
      # NOTE(vdrok): The following two options have effect only for SQL backend
      lockout_failure_attempts: 5
      lockout_duration: 1800

And as well, you need to upload and apply "stx-openstack" once more by "system application-upload" and "system application-apply" cmds.

ANIRUDH GUPTA (anyrude10) wrote :
yong hu (yhu6) wrote :

@Anirudh, have you ever changed the password for "admin" user?

The root cause for https://bugs.launchpad.net/starlingx/+bug/1853017 was found out, but it was triggered by admin password change.

In addition, please run "collect" cmd on 2 controllers and upload the generated log taralls for debugging.

tags: added: stx.2.0
yong hu (yhu6) on 2019-12-02
Changed in starlingx:
status: New → Incomplete
ANIRUDH GUPTA (anyrude10) wrote :

Hi Yong,

This issue occurred, even if there was no change in Password.

Since I was not hearing any prompt response and I was completely stuck, I had re-installed the StarlingX Setup. I'll share the "collect" logs once I generate the scenario again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers