Waiting for ever for cal_sh_wrj2

Bug #1046792 reported by Guillaume W. on 2012-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Shadow Robot's ROS interface, EtherCAT version
High
Unassigned

Bug Description

starting the EDC with sr_edc.launch (modified to use pr2-grant)
"Waiting for: cal_sh_wrj2" displays each second endlessly.

Restarting the sr_edc.launch solves the problem.

Occured three times since we have newest shadow_robot_ethercat driver (rev 558). always with wrj2

There should be a maximum tries or a restart of something automatically, or a message asking to restart the driver.

Ugo (ugocupcic) on 2012-09-06
Changed in sr-ros-interface-ethercat:
importance: Undecided → High
Toni Oliver (toliver-shadow) wrote :

The problem is due to poor implementation in pr2_bringup/calibrate.py. There's a "for name in waiting_for" and sometimes it happens that "waiting_for.remove(obj)" is invoked before the for loop has finished. Then it waits forever for the latest elements of the queue (normally cal_sh_wrj1, cal_sh_wrj2, but sometimes more, sometimes none).
I've sorted that out by adding a 0.5 sec delay in the first message published in sr_mechanism_controllers/srh_fake_joint_callibration_controller.cpp.

I filed a ticket for WG to solve this more properly:
https://code.ros.org/trac/wg-ros-pkg/ticket/5211

Changed in sr-ros-interface-ethercat:
status: New → Fix Committed
Changed in sr-ros-interface-ethercat:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.