Filename processing turns good chars to _

Bug #584603 reported by Benjamin Gruenbaum on 2010-05-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SoundConverter
Low
Pawel Ulita

Bug Description

Hello :)

I transcode filenames in hebrew,

The "Replace all messy characters" option turns all Hebrew characters to "_" characters

This is not a biggy, unmarking this option solves the problem (but also keeps me from enjoying it)

Perhaps teach the name processing function not to remove language characters but to remove other chars such as %#@! and so on... or maybe have a second checkbox for this situation

running Ubuntu 10.04, Gnome 2.30, SoundConverter 1.4.4

Great program btw, ty

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
status: New → Confirmed
importance: Undecided → Low
GautierPortet (kassoulet) wrote :

I'm not sure about the exact purpose of "Replace all messy characters", but I think it was added because some hardware players didn't see "funny" characters.
This option works by changing all character not in [A-Za-z0-9./_-] by "_", causing the problem you are reporting, since obviously, hebrew characters are not in the authorized list.
I don't really see the point at removing characters, especially if you already have unicode in the filename, what characters are you expecting to be removed ?
I just want to understand the usage pattern to see where to go with the problem.

Thank you for the report.

Benjamin Gruenbaum (benjamingr) wrote :

I was expecting characters like !@#$%^&*():"|{} and so on to be removed, These characters rarely occur when convert songs in Hebrew, however these "funny characters" do occur sometimes in english songs and I convert both name-types of files at the same time.

This isn't a big issue but I'd appreciate a fix

Changed in soundconverter:
assignee: GautierPortet (kassoulet) → Pawel Ulita (ulitapawel)
GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: Confirmed → Fix Committed
milestone: none → 2.1.2
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers