When encoding fails, original file is still deleted

Bug #1205828 reported by Ivo Anjo on 2013-07-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SoundConverter
Critical
GautierPortet

Bug Description

While I was trying to debug https://bugs.launchpad.net/soundconverter/+bug/913204 I noticed that if you have "Delete original file" in the preferences, the original file is deleted even when encoding fails.

This happens for instance with this file
http://thesixteendigital.com.s3.amazonaws.com/testfiles/Hallelujah%20lossless.m4a
from
http://www.thesixteendigital.com/testfiles/
that triggers the gstreamer bug.

This happens with latest 2.1.1 version.

Ivo Anjo (knuckles) on 2013-07-28
description: updated
Michael Schwendt (mschwendt) wrote :

How does encoding fail? Or decoding?

Ivo Anjo (knuckles) wrote :

Erm. I don't understand the question?

I try to convert the test file to flac, select delete original, and it fails (due to a gstreamer bug, and gstreamer spits and error), and SoundConverter still deletes the original file.

Besides the supplied test files, there are lots of error logs for the other bug, that triggered this one, as I linked above.

Michael Schwendt (mschwendt) wrote :

Be a little bit more positive, please.

The test files are useless, if conversion is successful. And here it is successful with Fedora 19 and a heavily patched SoundConverter 2.0.4 as well as a pristine 2.1.1. So, I couldn't reproduce the issue.

In other words, you run into a GStreamer error, which isn't recognized somehow. Interesting. That alters the test-case, however.

Ivo Anjo (knuckles) wrote :

I'm sorry if you don't think I'm being positive, and I'm glad to see that the bugfix for the gstreamer bug I reported was already deployed in Fedora, but I don't know what further information I can provide to help debug this.

The test sound was the same I supplied in the gstreamer bug report https://bugzilla.gnome.org/show_bug.cgi?id=705018 .

Changed in soundconverter:
milestone: none → 2.1.2
GautierPortet (kassoulet) wrote :

I reproduce the problem with Fedora 19 and SoundConverter 2.1.1.

Of course, it's impossible :)

Changed in soundconverter:
status: New → Confirmed
assignee: nobody → GautierPortet (kassoulet)
importance: Undecided → Critical
GautierPortet (kassoulet) wrote :

Oops :)

GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: Confirmed → Fix Committed
GautierPortet (kassoulet) wrote :

Good catch Ivo!

Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.