Histograms are displaying incorrectly.

Bug #1214556 reported by Ryan Ackerman on 2013-08-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SOFA Statistics
Critical
Grant Paton-Simpson

Bug Description

The dataset I used was (9.4, 5.4, 6.6, 5.4, 6, 9.4, 8.9, 10, 9, 15, 12, 7.2, 7, 9, 8.1). In the histogram, it displays several entries as high as 25, though no number in my dataset was close. I was able to have the histogram display properly by changing any one number to a 1.

I originally imported this dataset from Google Spreadsheets, but re-entered it by hand into SOFA with no effect. I generated a second random dataset of numbers between 0 and 10 (rounded to tenths), imported it into SOFA and found that again, the histograms were displaying higher numbers than existed in the dataset.

Changed in sofastatistics:
assignee: nobody → Grant Paton-Simpson (launchpad-p-s)
Changed in sofastatistics:
status: New → Confirmed
importance: Undecided → Critical
description: updated

The error occurs at the point where the decimal place value is set and bin sizes are rounded.

Changed in sofastatistics:
status: Confirmed → Fix Committed

Thanks Ryan for bringing this to my attention. I've separated the decimal point calculation into its own function and added a unit test to it. a new release is due out within about a week.

Thanks very much for your hard work! I've been really enjoying using this
in my classroom so far this year.

-Ryan Ackerman
Algebra II and AP Statistics
Heritage Hall, Oklahoma City

On Wed, Oct 9, 2013 at 2:10 PM, Grant Paton-Simpson <email address hidden>wrote:

> Thanks Ryan for bringing this to my attention. I've separated the
> decimal point calculation into its own function and added a unit test to
> it. a new release is due out within about a week.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1214556
>
> Title:
> Histograms are displaying incorrectly.
>
> Status in SOFA Statistics Open For All:
> Fix Committed
>
> Bug description:
> The dataset I used was (9.4, 5.4, 6.6, 5.4, 6, 9.4, 8.9, 10, 9, 15,
> 12, 7.2, 7, 9, 8.1). In the histogram, it displays several entries as
> high as 25, though no number in my dataset was close. I was able to
> have the histogram display properly by changing any one number to a 1.
>
> I originally imported this dataset from Google Spreadsheets, but re-
> entered it by hand into SOFA with no effect. I generated a second
> random dataset of numbers between 0 and 10 (rounded to tenths),
> imported it into SOFA and found that again, the histograms were
> displaying higher numbers than existed in the dataset.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/sofastatistics/+bug/1214556/+subscriptions
>

Changed in sofastatistics:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers