Slingshot Fails To Show Manually-Created .desktop Launchers

Bug #1103660 reported by Daniel Hobbs on 2013-01-23
This bug affects 5 people
Affects Status Importance Assigned to Milestone

Bug Description

A fresh install of Elementary OS Luna (64bit). I have installed some applications manually using the following cli:

xdg-desktop-menu install /mnt/data/Downloads/Minecraft/buildcraft.desktop --novendor

This works in other DE (such as GNOME Shell and E17), but not in Pantheon. I have edited the .desktop file as per other bugs (removing the OnlyShowIn line, adding "Application;" to the Categories line, etc). I have copied the .desktop file to /usr/share/applications, and changed it's properties to chmod 644, all to no avail (rebooting between each change).

Here is one of the offending .desktop files:

[Desktop Entry]
Comment=Minecraft 1.4.7 with Buildcraft Mod
Icon= /mnt/data/Downloads/Minecraft/minecraft.png

Please advise how to get Slingshot to recognise manually-created .desktop launchers.

Other applications installed from apt-get are added no problem, so there must be SOME way to do it

ProblemType: Bug
DistroRelease: elementary OS 0.2
Package: elementary-desktop 1.293-0~367~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-36.57-generic 3.2.35
Uname: Linux 3.2.0-36-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.1+elementary3~precise1
Architecture: amd64
CrashDB: elementary_meta
Date: Wed Jan 23 20:00:24 2013
InstallationMedia: elementary OS 0.2 "Luna" - Daily amd64 (20121231)
MarkForUpload: True
 PATH=(custom, no user)
SourcePackage: elementary-meta

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Hobbs (mr-dhobbs) wrote :
Cody Garver (codygarver) on 2013-02-06
affects: elementaryos → slingshot
Changed in slingshot:
status: New → Confirmed
Tigran Gabrielyan (tigrangab) wrote :

My custom .desktop files do show up. Can you try again with the latest stable slingshot?

Cody Garver (codygarver) on 2013-08-22
Changed in slingshot:
status: Confirmed → Incomplete
Daniel Hobbs (mr-dhobbs) wrote :

I am back running a fresh install of Luna 64bit. This issue still persists. I have even tried taking an existing (working) .deskop file, and only changing the "Exec=" line, but that still doesn't work.

An interesting issue, when I tried to find out the version of slingshot, I got this error:

$ slingshot-launcher --version
Unknown option --version
[_LOG_LEVEL_INFO 07:52:44.531678] Application.vala:77: Slingshot version: 0.7.4
[_LOG_LEVEL_INFO 07:52:44.531806] Application.vala:79: Kernel version: 3.2.0-52-generic
[_LOG_LEVEL_FATAL 07:52:44.550424] [GLib-GIO] This application can not open files.
[_LOG_LEVEL_FATAL 07:52:44.550477] Slingshot will not function properly.

Those lost two lines were in red text - could that be identifying the issue?

Thanks for any help


Tigran Gabrielyan (tigrangab) wrote :

That happens to me, too, but my desktop files load. Can you check the file permissions?

Where I do have an issue is with Catalyst control center. Its categories are like so when installed:


With that, it doesn't show. But if I change the category to just Settings it will. Try playing around with the categories config, but I think what I have is a different issue.

Jeremy Wootten (jeremywootten) wrote :

Which apps are displayed is governed by etc/xdg/, which is installed by slingshot. You can get ibus-setup to appear by explicitly including it in e.g. the System Tools section of this file:

  <!-- System Tools-->
  </Menu> <!-- End System Tools -->

Or by adding the category "System" or "Administration" to ibus-setup.desktop

It would also be possible to add the Category "Settings" to the System Tools section of, but this increases the number of applications appearing in this section significantly.

RabbitBot (rabbitbot-a) on 2013-10-05
Changed in slingshot:
status: Incomplete → Fix Committed
Cody Garver (codygarver) on 2013-10-05
Changed in slingshot:
status: Fix Committed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Slingshot because there has been no activity for 60 days.]

Changed in slingshot:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers