Sear is not using media files from system dir

Bug #176514 reported by Alexey Torkhov on 2007-12-15
4
Affects Status Importance Assigned to Milestone
WorldForge: Sear
Undecided
Unassigned
sear (Fedora)
Fix Released
Low

Bug Description

I have installed sear from fedora packages. After starting sear it downloaded media files update and put it in ~/.sear.
After that it was starting and complain about "File not found '/home/alex/.sear//sear-media-0.6//settler//skeleton.csf'".
I had to copy media files from system dir /usr/share/sear/sear-media-0.6 to my local ~/.sear/sear-media-0.6 to get rid of this error.

Description of problem:
I have installed sear from fedora packages. After starting sear it downloaded
media files update and put it in ~/.sear.
After that it was starting and complain about "File not found
'/home/alex/.sear//sear-media-0.6//settler//skeleton.csf'".
I had to copy media files from system dir /usr/share/sear/sear-media-0.6 to my
local ~/.sear/sear-media-0.6 to get rid of this error message.

Version-Release number of selected component (if applicable):
sear-0.6.3-5.fc8

How reproducible:
Always.

Steps to Reproduce:
Run sear from console. Login to server.

Actual results:
Error message "File not found
'/home/alex/.sear//sear-media-0.6//settler//skeleton.csf'". It continues to run
but in-game I don't see myself (my char).

Expected results:
Sear load files also from /usr/share/sear/sear-media-0.6

Additional info:
I reported also to their bugtracker https://bugs.launchpad.net/sear/+bug/176514.
But I'm unsure if this is not but of packaging.

Changed in sear:
status: Unknown → Confirmed
Simon Goodall (sgoodall) wrote :

This bug has been fixed in CVS for sometime now.
It is caused by early evaluation of a path string in the cal3d model definition file which it then used to find the files that make up the model.

Please try the cvs version of Sear, or I can potentially put together a patch against version 0.6.3.

Alexey Torkhov (atorkhov) wrote :

Thanks. I'm unsure is it how to compile sear, because I already updated to eris-1.3.13 to make ember, but sear seems to still requiring eris-1.3.12.

Simon Goodall (sgoodall) wrote :

You can try changing the ERIS_VERSION number in configure.ac to the required value, then re-run autogen.sh, configure etc.

I have not tried compiling Sear with this version, so there may be some problems if the api has changed.

I'll just try it now myself.

Simon Goodall (sgoodall) wrote :

Sear compiles and runs fine with eris 1.3.13.

Wart (wart-kobold) wrote :

A patch against sear 0.6.3 would be appreciated. I can add this patch to the Fedora package and push out an update rather quickly.

Indeed, sear does seem to be ignoring the previously installed media files.
Removing the sear-media package and letting sear download all media files to
~/.sear works, that is, the game runs and you see the characters and objects in
the game.

Thanks for the link to the bug report. I've added a comment asking for the
patch against 0.6.3. I'll also make sure that sear is using the latest version
of eris.

Simon Goodall (sgoodall) wrote :

See the attachment for a patch.

Wart (wart-kobold) wrote :

Thanks for the patch! I'm updating the Fedora package now...

sear-0.6.3-8.fc8, eris-1.3.13-1.fc8 has been pushed to the Fedora 8 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update sear eris'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2007-4644

Changed in sear:
status: Confirmed → Fix Committed

sear-0.6.3-8.fc8, eris-1.3.13-1.fc8 has been pushed to the Fedora 8 stable repository. If problems still persist, please make note of it in this bug report.

Changed in sear:
status: Fix Committed → Fix Released
Changed in sear (Fedora):
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.