Comment 4 for bug 597212

Grek-336 (kult01) wrote :

I have test the package screenkey_0.2_all.deb in a VirtualBox VM with a Live-DVD from Kubuntu 9.04 (Jaunty Jackalope) that use Python 2.6 but update-python-modules don't support .pulic files.

The installation fails with the folling output (sorry the language is german):

Wähle vormals abgewähltes Paket python-cairo.
(Lese Datenbank ... 188660 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke python-cairo (aus .../python-cairo_1.4.12-1.2ubuntu1_i386.deb) ...
Wähle vormals abgewähltes Paket python-gtk2.
Entpacke python-gtk2 (aus .../python-gtk2_2.14.1-1ubuntu1_i386.deb) ...
Wähle vormals abgewähltes Paket python-xlib.
Entpacke python-xlib (aus .../python-xlib_0.14-2_all.deb) ...
Richte python-cairo ein (1.4.12-1.2ubuntu1) ...

Richte python-gtk2 ein (2.14.1-1ubuntu1) ...

Richte python-xlib ein (0.14-2) ...

Verarbeite Trigger für python-support ...
Wähle vormals abgewähltes Paket screenkey.
(Lese Datenbank ... 188821 Dateien und Verzeichnisse sind derzeit installiert.)
Entpacke screenkey (aus .../screenkey_0.2_all.deb) ...
Richte screenkey ein (0.2) ...
Usage: update-python-modules [-v] [-c] package_directory [...]
       update-python-modules [-v] [-c] package.dirs [...]
       update-python-modules [-v] [-a|-f|-p]

update-python-modules: error: /usr/share/python-support/screenkey.public is not a directory
dpkg: Fehler beim Bearbeiten von screenkey (--install):
 Unterprozess post-installation script gab den Fehlerwert 2 zurück
Fehler traten auf beim Bearbeiten von:
 screenkey

The installation problem is not a problem of python 2.5 vs. python 2.6, it is a problem of update-python-moduls in package python-support 0.8.7 vs. 1.0.3