Can't use space bar in search bar when using french alternative keyboard

Bug #221112 reported by Creak on 2008-04-23
274
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Listen
Undecided
Unassigned
QuodLibet
Unknown
Unknown
Rhythmbox
Confirmed
Medium
SciTE
New
Undecided
Unassigned
libgnomekbd
Confirmed
Medium
xkeyboard-config
Fix Released
Medium
quodlibet (Ubuntu)
Undecided
Unassigned
rhythmbox (Ubuntu)
High
Didier Roche
xkeyboard-config (Ubuntu)
High
Didier Roche
Precise
High
Unassigned

Bug Description

[Impact]
In the fr(oss) keymap, both space and Ctrl + space return the same XLookupString, which prevents space from being used in some applications.

This had been fixed in lucid and maverick, but the patch appears to have been misplaced during the (rather major) update from 1.8 to 2.1, thus the reports of it regressing in comments #135 and #141, as well as dupe bug #938671.

[Development Fix]
Patch 128_fix_oss_ctrl_space_accelerator.patch fixed this problem in lucid and maverick, but was dropped in natty when we updated to upstream xkeyboard-config 2.1. However, the patch was also sent upstream and accepted there. So for quantal a cherrypick of that commit was backported.

[Stable Fix]
Since currently quantal is shipping the same xkeyboard-config version as precise, we can carry the same patch there as well.

[Test Case]
1. Set keyboard to fr(oss). (Note due to unrelated bug, you need to do this in your /etc/defaults/keyboard config file.)
2. Start rhythmbox
3. Do a song search
4. Type in a search term that includes a space character

Broken Behavior: Space triggers the play/pause function in rhythmbox
Fixed Behavior: A space character is inserted

[Regression Potential]
The patch is one we carried in lucid and maverick (when rhythmbox was the default music player IIRC), and has been upstream for a while. So I think it is a safe change.

Actually, I'm surprised there have not been more complaints about it lately. But during the interim we'd switched to banshee so perhaps users didn't notice it.

[Original Report]
I tried to search for "The Do" in the search bar, but the space bar didn't write a space. Instead, it played the currently selected song (space is the shortcut for playing/pausing the song). I've just installed the last Hardy release candidate.

ProblemType: Bug
Architecture: i386
Date: Wed Apr 23 19:30:12 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.11.5-0ubuntu6
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: rhythmbox
Uname: Linux 2.6.24-16-generic i686

Creak (romain-failliot) wrote :

I cannot reproduce.

Space shouldn't be the default, for exactly this reason. The defaut (at least for me) is ctrl + space. Make sure you aren't holding down your ctrl key accidentally (or something heavy isn't sitting on it). You can check the current shortcut under the control menu.

Does this help anything?

Changed in rhythmbox:
status: New → Incomplete
Creak (romain-failliot) wrote :

Well i retried and it does all the same... The space bar works like a charm in the other aplications.
Could it be possible that the french translation changed the shortcut?

Ludovic Lebègue (llebegue) wrote :

Same problem here with the default install and language English as default. (But a French keyboard layout)
This makes it impossible to search any information containing a space.

Ludovic Lebègue (llebegue) wrote :

Tried with a USA layout for the keyboard. The problem is still there.

Changed in rhythmbox:
status: Incomplete → Confirmed

Can both of you attach your xorg.conf files, or at least the relevant sections containing your keyboard layout?

"cp /etc/X11/xorg.conf ~/ " will put a copy in your home folder for attachment.

Ludovic Lebègue (llebegue) wrote :

Here is my xorg.conf

Creak (romain-failliot) wrote :

Here is mine

Ronan Jouchet (ronj) wrote :

Can confirm this. I've filed 222654 then found this bug. I've marked 222654 as duplicate of this.
I attach my xorg.conf

I have another request, as I still cannot reproduce this bug. Can you attach your %gconf file for your keyboard?
Use the terminal command "cp ~/.gconf/desktop/gnome/peripherals/keyboard/kbd/%gconf.xml ~/key-gconf.txt"
and upload the file "key-gconf.txt" to launchpad

merci beaucoup!

I forgot to mention, the key-gconf.txt file will be located in your home directory after entering that terminal command.

Changed in rhythmbox:
assignee: nobody → patrick-kilgore
Ludovic Lebègue (llebegue) wrote :

Here is the gnome keyboard config.

Reproduced and forwarded upstream. You can track any progress there at http://bugzilla.gnome.org/show_bug.cgi?id=530123

Thanks for helping make Ubuntu better!

Changed in rhythmbox:
assignee: patrick-kilgore → nobody
blahnotblahblah (coufan) wrote :

I solved the problem by commenting on a line in /etc/X11/xorg.conf :
Option "XkbVariant" "oss"

Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"
# Option "XkbVariant" "oss"
EndSection

Then I made slim system\quit\disconnect
And since the problem disappeared in codeblocks
I am satisfied!!!

Changed in rhythmbox:
status: Unknown → New
Sika (sikamikaniboots) wrote :

I have the same problem with Quod Libet and CodeBlocks.
Xev tells me that "space" key is pressed, but in these apps, everything happens like if ctrl+space was stroke (play/pause in quod libet, completion in codeblocks).
My xorg.conf :

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "fr"
 Option "XkbVariant" "oss"
 Option "XkbOptions" "lv3:ralt_switch"
EndSection

Don't you think this could be related to xkeyboard-config package (at least, not specific to rhythmbox) ?

Gnome default setup when Xorg keyboard is "fr"/"oss" leads to the "France Alternative" layout.

In this layout some application can't handle space caracter properly.
(See URL as some exemples).

Workaround is to force "France Alternative, latin9 only" in Gnome

or

change Xorg.conf replacing :

Option "XkbVariant" "oss"
by
Option "XkbVariant" "latin9"

Created an attachment (id=16310)
xorg.conf

Ludovic Lebègue (llebegue) wrote :

Some analysis on this bug

Xorg.conf :

Original one, not changed manually
Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "fr"
        Option "XkbVariant" "oss"
EndSection

In GNOME keyboard preferences :

- "France Alternative" set with the "Reset to defaults" button => Rhythmbox KO
- "France" set with "Add +" button and chose variant "Default"

Ludovic Lebègue (llebegue) wrote :

"France" set with "Add +" button and chose variant "Default" => Rhythmbox KO

Ludovic Lebègue (llebegue) wrote :

In GNOME Keyboard preferences :
 - "France Alternative, latin9 only" => This is ok for rhytmbox

At this point, a change in GNOME is enough to solve this problem.

I guess it's not related to Rhythmbox but rather to the GNOME keybord layout ...

Sebastien Bacher (seb128) wrote :

GNOME only applies xorg keyboard settings

First of all, GNOME represents whatever is in base.xml. There is default French layout and several variants (including "oss" and "oss_latin9"). User choses whatever he wants. So I am not really sure what is the essence of your complain.

From the user's point of view there was no choice made when installing Ubuntu 8.04 (just picked a French keyboard without knowing the underlying mechanism).
In the end some functions are altered.

According to what I understand (and I have no real knowledge of the process)

1- User install X => picks a keyboard
2- X is somehow configured with XkbdLayout and XkbdVariant in /etc/X11/xorg.conf
3- GNOME picks these value and reads the associated entries in /etc/X11/xkb/base.xml to use them as default.

Step 1 and 2 above => This is the responsability of the linux distribution to configure xorg.conf. In Ubuntu it seems that debconf is the xorg.conf creation tool (according to the comment). Is this tool responsible to pick "oss" instead of "latin9" ?

What do you think ?

Another idea here : Perhaps is it simply the "oss" variant that is faulty and does not behave as expected ?

(In that case it seems to trigger a "ctrl+space" when the user press "space")

This is actually distro-specific, xkeyboard-config has nothing to do with it. FWIW fr(oss) produces space when space is pressed.

Let's take the following assumptions :

1 - configure manually xorg.conf (no distro involved here) to put "fr" variant "oss"
2 - use GNOME who accurately detects "France Alternative"
3 - try to search something in Rhythmbox involving a "space" caracter.
4 - it fails as if "ctrl+space" was triggered instead of "space"

I'm just trying to figure where the bug is...

The point is as for now it actually seems to be in "oss" because of the manual configuration step.

How can we make sure ?

You can easily check. Try running xev utility and press space

Just made a check with xev.
Everything seems fine at xev level.

From xev point of view pressing space returns char 20 => which indeed is a space.

My latest idea about "oss" being the source of the problem is not the good one.

Did you try the configuration to reproduce the bug ?

That is :

=> xorg.conf such as the attachment I made
=> Set 'France Alternative' as default keyboard in GNOME.

then

launch rhythmbox and try to search with something including a space caracter.

Changed in rhythmbox:
status: New → Fix Released

> Everything seems fine at xev level.
It means XKB is not in charge. So, it is really not ours, as I expected.

> launch rhythmbox and try to search with something including a space caracter.
Tried. Works ok. But space is actually not entered into the search line - it triggers play/pause thing. Which I guess it the rhythmbox normal behaviour.

Changed in xkeyboard-config:
status: Unknown → Confirmed
Ludovic Lebègue (llebegue) wrote :

On a fresh Ubuntu install (or an upgrade from previous version). What modifies the InputDevice section of xorg.conf (this could be a lead to the solution...) ?

Sorry to reopen again this one.

The default behavior of Rhytmbox is not to start playing when space is entered. The real short cut for this is ctrl+space.

This is the faulty behaviour started it all.

As for now the workaround for this bug is to change xorg.conf parameters.

Shouldn't that be a xorg problem ? Where is this analysis bad ?

If you look in the URL I have included you may also see that the same problem occurs in Quod Libet and CodeBlocks. Meaning that it is not tightly linked to Rhytmbox. https://bugs.launchpad.net/xkeyboard-config/+bug/221112

I have no slightest idea. In all layouts I use (Russian, USA) space triggers play/pause in Rhythmbox. I suggest addressing further question to Rhythmbox developers. Both oss and latin9 define SPCE as space on first shift level. I suspect this is the issue with modifiers (Ctrl) handling in Rhythmbox (or GTK). But this is just my guess.

Battle48 (mamouth-download) wrote :

[quote/] In GNOME Keyboard preferences :
 - "France Alternative, latin9 only" => This is ok for rhytmbox

At this point, a change in GNOME is enough to solve this problem.

I guess it's not related to Rhythmbox but rather to the GNOME keybord layout ... [/quote]

I changed the keyboard configuration to France 'alternative latin9 only' but the problem is not gone when I try to use rythmnbox.

Any idea ?

Ludovic Lebègue (llebegue) wrote :

@Battle48 : Try "France (Legacy) Alternative" and restart Rhythmbox

Battle48 (mamouth-download) wrote :

@Ludovic Lebègue : Thank you very much ! It works to perfection now =)
Thank you so much for your help =)

Binoul87 (morantbenjamin) wrote :

I reported this bug too but you were all faster tha me :) . I'll try this trick later !

Binoul87 (morantbenjamin) wrote :

Ok, evrything's clear with France (legacy) alternative! thx

Changed in rhythmbox:
status: Fix Released → Invalid
Changed in libgnomekbd:
status: Unknown → New
Creak (romain-failliot) wrote :

I don't know for you, but if I use the "France (Legacy) Alternative", it works until I reboot my system. After that, everything I wrote with my keyboard gives me stuff like "æâ€êþÿûîœô" as if "Alt Gr" was always pressed.

Changed in libgnomekbd:
status: New → Invalid
Changed in xkeyboard-config:
status: Confirmed → Invalid
Changed in rhythmbox:
status: Unknown → New
Changed in rhythmbox:
importance: Undecided → Medium
Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Medium → Low
status: Confirmed → Triaged
Changed in libgnomekbd:
status: Invalid → New
Changed in rhythmbox:
status: Unknown → New
Changed in libgnomekbd:
status: Unknown → Confirmed
Changed in rhythmbox:
status: Unknown → Confirmed
Changed in rhythmbox:
assignee: desktop-bugs → seb128
assignee: seb128 → desktop-bugs
affects: rhythmbox (Ubuntu) → gtk+2.0 (Ubuntu)
affects: gtk+2.0 (Ubuntu) → rhythmbox (Ubuntu)
Martin Albisetti (beuno) on 2009-06-20
Changed in hundredpapercuts:
status: New → Invalid
Vish (vish) on 2009-08-24
affects: hundredpapercuts → null
Camille Appert (bibinou) on 2009-11-10
Changed in quodlibet (Ubuntu):
status: New → Confirmed
Mehdi Abaakouk (sileht) on 2010-02-24
Changed in listen:
status: New → Confirmed
Didier Roche (didrocks) on 2010-04-13
Changed in rhythmbox (Ubuntu):
importance: Low → High
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Didier Roche (didrocks)
Didier Roche (didrocks) on 2010-04-14
Changed in rhythmbox (Ubuntu):
status: Triaged → Invalid
Changed in quodlibet (Ubuntu):
status: Confirmed → Invalid
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in xkeyboard-config (Ubuntu):
status: Triaged → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Invalid → Confirmed
Changed in libgnomekbd:
importance: Unknown → Medium
Changed in rhythmbox:
importance: Unknown → Medium
vhin8899 (gothicvhin-13) on 2010-09-18
Changed in rhythmbox (Ubuntu):
status: Invalid → New
status: New → Confirmed
Didier Roche (didrocks) on 2010-09-20
Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Released
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Bryce Harrington (bryce) on 2012-05-17
description: updated
Bryce Harrington (bryce) on 2012-05-17
no longer affects: rhythmbox (Ubuntu Precise)
no longer affects: quodlibet (Ubuntu Precise)
Changed in xkeyboard-config (Ubuntu Precise):
importance: Undecided → Medium
status: New → Fix Committed
importance: Medium → High
tags: added: regression-release
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Bryce Harrington (bryce) on 2012-06-26
Changed in xkeyboard-config (Ubuntu Precise):
status: Fix Committed → Triaged
tags: added: verification-failed
removed: verification-done
134 comments hidden view all 214 comments

I had yet another good reason to revert to a "normal right [CTRL] key" on a Fedora this morning:

I was working in a terminal with several open terminal tabs. Switching between tabs is made using [Ctrl]-[PageUp] and [Ctrl]-[PageDown] - same goes with other Gnome tabbed apps, as well as Firefox and Chromium...

If you have a working right [Ctrl] key, switching tabs is easy, you just need 2 fingers from your right hand.

If you don't have a working right [Ctrl] key, you need both hands.

Having the broken right [Ctrl] key was so annoying at work, that I had to fix it immediately.

(In reply to comment #54)
> So, finally, is everybody happy with me removing that line:
>
> include "level5(rctrl_switch)"

No, just didn't see the point of restating what has already been written before

A level 5 map needs a level 5 switch, iso defined right ctrl as default level 5 switch so there is no better option available, and users who do not care about the fifth level can choose another spacebar variant since they are configurable.

Repeating :

1/ Standard French keyboard has NO [CtrlGr] key. It does have 2 normal [Ctrl] keys bearing the exact same label. The right [Ctrl] key actually is a right [Ctrl] key and no other modifier or whatever.

2/ There are quite a *lot* of common, daily used by professional IT staff, keyboard shortcuts or combinations such as [Ctrl]-[Arrows], [Ctrl]-[PageUp/Down], [Ctrl]-[Home], [Ctrl]-[End], plus all such combinations adding [Shift], then [Ctrl]-L, [Ctrl]-M...

-> All these day-long used combinations can be conveniently played with 2 (or 3) fingers when the right [Ctrl] key actually is a right [Ctrl] key, and changing this key breaks them all, needing people to start using both hands for typing what they have typed with 2 fingers for 30 YEARS ! And mistype. And mistype. And mistype.

3/ The issue with Rythmbox looks solved for long, and who wants to break professional use of a keyboard for a solved bug in a music player ?

4/ Nobody (normal user) I talked to has ever heard about a "level 5" story, nor do people give a damn.

5/ Everybody wanting to type non-breakable space in word processors (LibreOffice...) do it with [Ctrl]-[Shift]-[Space] and don't need a specifically modified right Ctrl for that.

6/ Breaking right [Ctrl] breaks other apps that specifically request it NOT to be broke, such as [VirtualBox] - again professional stuff.

Breaking the right [Ctrl] keys on the french keyboard is plain stupid, period.

I never heard of or used the level5 either, but to solve the issue could we maybe put it in another layout? For example something like "oss-level5"?

I personally have to patch the file on every package update and even if I'm used to that and have the patch ready now, it gets annoying. On my laptop the right Ctrl key is adjascent to the arrows and it's way more convenient to be able to move through words in a text using only the right hand.

Even though I've been an IT professional for the past 3O years, I went to a large computer store in France over lunch time, to find out if such thing as a [CtrlGr] key could possibly exist on a french keyboard.

Let me tell you : I couldn't find any.

OTOH, I was surprised to notice that some tablets with removable keyboards, as well as some ultrabooks with space-saver keyboards, did not have a right [Ctrl] key at all !

All have a left [Ctrl], left [Alt] and right [AltGr].

The vast majority of times, they have a right [Ctrl] key which is similar to the left one.

But sometimes there is no right [Ctrl] at all !

This single fact prohibits a standard keymap giving a different assignation to the right [Ctrl] key, because this key may well not even exist on a given keyboard ! Thus you cannot rely on it for any feature that could be positively necessary.

That makes Yet Another Good Reason™ to keep the good 'ole behaviour of having 2 similarily mapped [Ctrl] keys.

Gentlemen, I am really stuck at that point. I am refusing to make any changes before there is either some kind of agreement - or there are some minimally conclusive voting results.
I do not take any sides (I cannot have any personal opinion, not using French). I am just freezing the situation.

Download full text (3.8 KiB)

All answers ask to perform the change. How is that not an agreement? I was
hoping to get it in this release of Ubuntu. Alas.

2014-04-18 1:06 GMT+02:00 Sergey V. Udaltsov <email address hidden>:

> Gentlemen, I am really stuck at that point. I am refusing to make any
> changes before there is either some kind of agreement - or there are some
> minimally conclusive voting results.
> I do not take any sides (I cannot have any personal opinion, not using
> French). I am just freezing the situation.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/221112
>
> Title:
> Can't use space bar in search bar when using french alternative
> keyboard
>
> Status in libgnomekbd:
> Confirmed
> Status in Listen, a Music player and management:
> Confirmed
> Status in Quod Libet is a GTK+-based audio player written in Python.:
> Unknown
> Status in The Rhythmbox Music Management Application:
> Confirmed
> Status in SciTE - A free source code editor for Win32 and X:
> New
> Status in central project for keyboard configuration:
> Confirmed
> Status in “quodlibet” package in Ubuntu:
> Invalid
> Status in “rhythmbox” package in Ubuntu:
> Fix Released
> Status in “xkeyboard-config” package in Ubuntu:
> Fix Released
> Status in “xkeyboard-config” source package in Precise:
> Triaged
>
> Bug description:
> [Impact]
> In the fr(oss) keymap, both space and Ctrl + space return the same
> XLookupString, which prevents space from being used in some applications.
>
> This had been fixed in lucid and maverick, but the patch appears to
> have been misplaced during the (rather major) update from 1.8 to 2.1,
> thus the reports of it regressing in comments #135 and #141, as well
> as dupe bug #938671.
>
> [Development Fix]
> Patch 128_fix_oss_ctrl_space_accelerator.patch fixed this problem in
> lucid and maverick, but was dropped in natty when we updated to upstream
> xkeyboard-config 2.1. However, the patch was also sent upstream and
> accepted there. So for quantal a cherrypick of that commit was backported.
>
> [Stable Fix]
> Since currently quantal is shipping the same xkeyboard-config version as
> precise, we can carry the same patch there as well.
>
> [Test Case]
> 1. Set keyboard to fr(oss). (Note due to unrelated bug, you need to do
> this in your /etc/defaults/keyboard config file.)
> 2. Start rhythmbox
> 3. Do a song search
> 4. Type in a search term that includes a space character
>
> Broken Behavior: Space triggers the play/pause function in rhythmbox
> Fixed Behavior: A space character is inserted
>
> [Regression Potential]
> The patch is one we carried in lucid and maverick (when rhythmbox was
> the default music player IIRC), and has been upstream for a while. So I
> think it is a safe change.
>
> Actually, I'm surprised there have not been more complaints about it
> lately. But during the interim we'd switched to banshee so perhaps
> users didn't notice it.
>
> [Original Report]
> I tried to search for "The Do" in the search bar, but the space bar
> didn't write a space. Instead, it played the currently selected song...

Read more...

Sergey, you might want to check Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/1013881 , which is a "downstream reflection" of this one.

There are some other "loud voices" there that you might consider as taking part to the "vote" that you want.

I had in my office 2 peopl that complained about this, this month. Maybe you could count them as well ?

BTW Sergey, I'm a bit surprised that you want a "vote" to fix something that people complain about, when you didn't need any vote to break it in the first place...

Would you need a vote, I suggest that you put a survey system online by yourself on any web page that you'd like (so you know the vote is "impartial"), and we let people know about it...

If you asks for a vote, it sounds logical that you organize it.

I feel extremely uneasy because I am a user of free software and I am full of respect and gratitude for the people who make this possible, including of course Nicolas Mailhot. I am an amateur and I am conscious that I rely entirely on the work of devoted paid and unpaid professionals.

But in this case, I must crudely say, because it was hinted that we should have a vote: the vote already happened, here in Bugzilla, and in Launchpad, and elsewhere in many forums. The result obviously is: Nicolas Mailhot against the rest of the world.

I think the rest of the world constitutes a majority compared to Nicolas Mailhot alone. Therefore one should immediately revert to the last good version with two Control keys.

(In reply to comment #60)
> Gentlemen, I am really stuck at that point.

Allow me to sum it up.

 - Nicolas is the sole advocate of having Control_R mapped to Level5.
 - The rest of us want to go back to having both left and right Control behaving the same way.

I'm not quite sure how you want us to organize a vote or poll. French Linux users (just like non-French ones) use a variety of distributions (which, BTW, may not ship the changed version of xkeyboard-config), and may not even all use a French keyboard (I'd say roughly half of my Linux-using friends and coworkers are using US qwerty layouts or mac layouts).

Since apparently no hardware maker is following ISO standards, may I suggest creating new layouts such as "oss-iso" with Nicolas' changes?

As one of Gentoo's X11 maintainers, I am really tempted to just revert that change downstream. The few French users I have talked to were just as surprised as I was to lose their Control_R key for no apparent reason.

I could organize a poll on my blog but being aggregated only on Planet Gentoo, I wouldn't give much credit to any numbers I could find.

Creak (romain-failliot) wrote :

I'm French and I think left and right control keys should behave the same as in every other normal french layouts.

Here is a survey for those in here that want to give their opinion:
http://doodle.com/i3f5vpiaqk37ebms

I agree with Remi, I understand we want to follow the ISO standard, but if the standard isn't appreciated by most of the users, we should create a new "oss-iso" layout.

Creak (romain-failliot) wrote :

Hah... actually I'm the one that reported that bug 6 years ago! I didn't even remember...
I think it's time to close this bug once and for all. So please, vote ;)

Great ! Now the FR right [Ctrl] is B.R.O.K.E.N on Ubuntu 14.04 as well.

Given the number of french Ubuntu users (+ upcoming derivatives) I think you'll have your "vote" and "survey" very soon, just by taking a look at lauchpad bug entries and new comments on https://bugs.launchpad.net/bugs/1013881 - which are not reflected here - some of the latest ones being very hmmm... "vocal".

> Since apparently no hardware maker is following ISO standards, may I suggest
> creating new layouts such as "oss-iso" with Nicolas' changes?
Nicolas, what do you think?

Regarding the voting, is there generic popular Linux-oriented site in France? Like slashdot.org or smth...

1 comments hidden view all 214 comments

At my knowledge it is http://linuxfr.org/ the most famous and oldest site of that kind.
There is also others web sites, but they are more general, they have general computer related news (http://www.nextinpact.com/ http://www.clubic.com/ http://www.numerama.com/).

Download full text (3.7 KiB)

There is also ubuntu-fr.org
Le 27 avr. 2014 00:01, "Yvon TANGUY" <email address hidden> a écrit :

> At my knowledge it is http://linuxfr.org/ the most famous and oldest site
> of that kind.
> There is also others web sites, but they are more general, they have
> general computer related news (http://www.nextinpact.com/
> http://www.clubic.com/ http://www.numerama.com/).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/221112
>
> Title:
> Can't use space bar in search bar when using french alternative
> keyboard
>
> Status in libgnomekbd:
> Confirmed
> Status in Listen, a Music player and management:
> Confirmed
> Status in Quod Libet is a GTK+-based audio player written in Python.:
> Unknown
> Status in The Rhythmbox Music Management Application:
> Confirmed
> Status in SciTE - A free source code editor for Win32 and X:
> New
> Status in central project for keyboard configuration:
> Confirmed
> Status in “quodlibet” package in Ubuntu:
> Invalid
> Status in “rhythmbox” package in Ubuntu:
> Fix Released
> Status in “xkeyboard-config” package in Ubuntu:
> Fix Released
> Status in “xkeyboard-config” source package in Precise:
> Triaged
>
> Bug description:
> [Impact]
> In the fr(oss) keymap, both space and Ctrl + space return the same
> XLookupString, which prevents space from being used in some applications.
>
> This had been fixed in lucid and maverick, but the patch appears to
> have been misplaced during the (rather major) update from 1.8 to 2.1,
> thus the reports of it regressing in comments #135 and #141, as well
> as dupe bug #938671.
>
> [Development Fix]
> Patch 128_fix_oss_ctrl_space_accelerator.patch fixed this problem in
> lucid and maverick, but was dropped in natty when we updated to upstream
> xkeyboard-config 2.1. However, the patch was also sent upstream and
> accepted there. So for quantal a cherrypick of that commit was backported.
>
> [Stable Fix]
> Since currently quantal is shipping the same xkeyboard-config version as
> precise, we can carry the same patch there as well.
>
> [Test Case]
> 1. Set keyboard to fr(oss). (Note due to unrelated bug, you need to do
> this in your /etc/defaults/keyboard config file.)
> 2. Start rhythmbox
> 3. Do a song search
> 4. Type in a search term that includes a space character
>
> Broken Behavior: Space triggers the play/pause function in rhythmbox
> Fixed Behavior: A space character is inserted
>
> [Regression Potential]
> The patch is one we carried in lucid and maverick (when rhythmbox was
> the default music player IIRC), and has been upstream for a while. So I
> think it is a safe change.
>
> Actually, I'm surprised there have not been more complaints about it
> lately. But during the interim we'd switched to banshee so perhaps
> users didn't notice it.
>
> [Original Report]
> I tried to search for "The Do" in the search bar, but the space bar
> didn't write a space. Instead, it played the currently selected song (space
> is the shortcut for playing/pausing the song). I've just installed the last
> Hardy release candidate.
>
> Problem...

Read more...

2014-04-26 16:50 GMT-04:00 Sergey V. Udaltsov <email address hidden>:

> Regarding the voting, is there generic popular Linux-oriented site in
> France? Like slashdot.org or smth...
>

I think you are looking for http://linuxfr.org/

Okay, your "vote" is currently happening on

https://bugs.launchpad.net/bugs/1013881

with 4 new entries today (from different people), 100% of them saying :

« PLEASE GIVE US OUR RIGHT [CTRL] KEY BEHAVING AS A [CTRL] KEY BACK !!! »

To summarize further, AFAIK, there is ONE person in the world happy that the french right [CTRL] has been broke, 100% of the other french keyboard users who want their [CTRL] key back,...

...and the rest of the world doesn't use a french keyboard and doesn't care.

Nicolas, I understand the logic in your position about Level 5. But I see a number of unhappy people. Could we find some other level5 chooser?

(In reply to comment #66)

> Regarding the voting, is there generic popular Linux-oriented site in
> France? Like slashdot.org or smth...

There is a popular Linux-oriented site in France (linuxfr.org) and the final ajustments of this layout were done after discussion on this site.

I realise there is a vocal minority that does not like some of those choices but
1. the other alternatives used in the ancestors of this layout generated a lot more hate mail
2. because I knew there was no choice everyone would like spacebar layout is modular (and I'm the person who modularized it as part of the creation of this layout). People can choose the previous behaviour if they want and a few other possibilities were added as part of the modularization
3. so far no one proposed any better option appart from removing symbols which are necessary to write proper French (arguably proper French is not the same as C code). It's a lot easier to clamor for removal of the bits you do not use than to try to design a general-purpose solution without cutting corners

(In reply to comment #69)

> > Regarding the voting, is there generic popular Linux-oriented site in
> > France? Like slashdot.org or smth...
>
> There is a popular Linux-oriented site in France (linuxfr.org) and the
> final ajustments of this layout were done after discussion on this site.
>
> I realise there is a vocal minority that does not like some of those choices

A site like linuxfr.org may well be a vocal minority in itself. Nothing proves that linuxfr.org is representative of ordinary users. And even on linuxfr.org I have seen posts saying "where is my CRTL-R gone?" or "my keyboard is broken since some new version of Ubuntu".
In a way, suppressing one of the customary CTRL keys is intrinsically a minority point of view.
[Furthermore, the French layout for the Belgian keyboard depends on the French layout for the French keyboard. I do not see why a discussion on linuxfr.org should decide that Belgians have no use of right CTRL.]

> but
> 1. the other alternatives used in the ancestors of this layout generated a
> lot more hate mail

I doubt having a right CTRL key ever generated hate mail. That hate mail was about other questions.

> 2. because I knew there was no choice everyone would like spacebar layout is
> modular (and I'm the person who modularized it as part of the creation of
> this layout). People can choose the previous behaviour if they want and a
> few other possibilities were added as part of the modularization

We are not here discussing space bar, but right CTRL. Is right CTRL modular? Is there an option easily accessible to the ordinary user to restore right CTRL?

> 3. so far no one proposed any better option appart from removing symbols
> which are necessary to write proper French (arguably proper French is not
> the same as C code). It's a lot easier to clamor for removal of the bits you
> do not use than to try to design a general-purpose solution without cutting
> corners

The clamor is not against proper French of for removal of anything. Furthermore, how could an ordinary user "try to design a solution"? The user wants a common PC keyboard with CTRL keys, without having to write the code himself. The clamor is: do what you can to allow writing proper French —and thank you for your trying to do it— but leave the right CTRL.
-------
If no agreement can be reached, would it be possible to have the old layout accessible, even under another name? I do not know how many variants are allowed, by design, or by freedesktop conventions. Of course a new variant would be useless if it didn’t appear in the choices offered to an ordinary user by the most popular GNU Linux distributions.

Download full text (3.5 KiB)

(In reply to comment #69)
> (In reply to comment #66)
>
> > Regarding the voting, is there generic popular Linux-oriented site in
> > France? Like slashdot.org or smth...
>
> There is a popular Linux-oriented site in France (linuxfr.org) and the
> final ajustments of this layout were done after discussion on this site.

But this has the same pitfall as any volunteered survey, it isn't any kind of representative. I for example myself barely ever read a linuxfr article, and wouldn't participate or even see a survey there. That doesn't mean I'm not a French fr/oss user :)

Also note that people suffering from the situations are a lot more likely to do something and speak their mind than people perfectly happy with the situation. So probably "discussing" a problem is likely to only include opinion from people not happy with the current state, and people closely involved.

> I realise there is a vocal minority that does not like some of those choices
> but

Just to be fair, I see *no one* else here arguing towards keeping right Ctrl Level5 modifier -- but sure, as I state above, people happy with it won't see the discussion or care, so it may be biased.

> 1. the other alternatives used in the ancestors of this layout generated a
> lot more hate mail

If it broke people's apps (or apps broke with it, I don't care who's fault it is), I surely can understand people being angry. But similarly, since the change from this report broke people's right Ctrl key, I can understand they get angry.

> 2. because I knew there was no choice everyone would like spacebar layout is
> modular (and I'm the person who modularized it as part of the creation of
> this layout). People can choose the previous behaviour if they want and a
> few other possibilities were added as part of the modularization

And we thank you for your work. But I don't think it's realistic to think everyone can "choose the previous behavior" if it means editing the keymap. I already said it, but it took me quite some time to find what caused my right Ctrl key to no longer work and fix it, and I think it's fair to consider myself a quite advanced user.

If really reverting the addition of Level5 is not an option (but see below), please add an alternative layout.

> 3. so far no one proposed any better option appart from removing symbols
> which are necessary to write proper French (arguably proper French is not
> the same as C code).

The change in this particular report did not add or remove any symbol, it only moved one to Level5 because some apps couldn't handle <Ctrl>Space with this layout. And as I said earlier, most of the incriminated apps (at least that I know of) don't even use <Ctrl>Space anymore, rendering the change moot for them.

And even if we wanted to please those apps, we mayb be able to without adding a new modifier (Level5) and a key for it -- again, see (comment #46).

Also note that event though I admittedly don't use short-nbsp (I'm afraid I don't know the rules where this one should be used in French typography), I'm an heavy user of nbsp everywhere French typography tells me to do it. So no, I don't want to remove anything, don't worry -- but I'd like my rig...

Read more...

(In reply to comment #70)

> If no agreement can be reached, would it be possible to have the old layout
> accessible, even under another name?

The old layout was never removed and kept its historical name (fr latin9)

(In reply to comment #72)
> The old layout was never removed and kept its historical name (fr latin9)

No, we are speaking here of fr/oss, but before it got right Ctrl as level5 modifier (what this bug end up changing).

I bet everyone complaining here was very happy with fr/oss before this Level5 modifier -- at least I was, this map has so everything useful (and more) on handy locations :)

(In reply to comment #71)

> And even if we wanted to please those apps, we mayb be able to without
> adding a new modifier (Level5) and a key for it -- again, see (comment #46).

I'm pretty sure some of the other spacebar configurations available as xkb options do not require level5. They are not the default for fr(oss) because without level5 it is too easy to type a nbspc by mistake and random nbspc everywhere breaks lots of things (as reported by fr latin9 users).

Nicolas,

Where does the need to *have* a key for nbsp come from? Isn't a compose combo more appropriate and less error-prone?

Cheers

(In reply to comment #75)
> Nicolas,
>
> Where does the need to *have* a key for nbsp come from?

Because unlike in English most French punctuation symbols require a space (sometimes a short space) before. And if it's not a non-breakable space apps will perform line breaks at the wrong position and you'll end up with orphan sumbols at line starts

Online
http://fr.wikipedia.org/wiki/Espace_ins%C3%A9cable

Actual authoritative reverence (highly recommended if you want to work on any system with French inputs or outputs)
http://www.amazon.fr/Lexique-r%C3%A8gles-typographiques-lImprimerie-Nationale/dp/2743304820

Lack of non breakspace on French layouts on some OSes is such a basic problem OpenOffice/LibreOffice had to hardcode a nbspc combo but that does not help when writing in you MUA, your browser, your IM client, etc

> Isn't a compose
> combo more appropriate and less error-prone?

Compose is not appropriate for basic symbols you need to write pretty much any correct sentence in the target language. And adding a specific input method for one symbol just because some people can't live with the modifier ISO chose for level 5 is disproportionnate.

(In reply to comment #76)
> Compose is not appropriate for basic symbols you need to write pretty much
> any correct sentence in the target language. And adding a specific input
> method for one symbol just because some people can't live with the modifier
> ISO chose for level 5 is disproportionnate.

Woow, calm down guys. What's disproportionate is the reaction here! *before* the change this report introduced, and which many of us are trying to get reverted, *both* nbsp and nbspc were easily available:

nbsp AltGr+Shift+Space
nbspc Ctrl+Shift+Space

Reverting the change this report introduced would get this behavior. Please understand we just want to get nbspc moved back where it *was* (or for me, anywhere on a 1-4 level), not removed or anything. Also, realize that currently there is only *one* Level5-specific symbol, and that's nbspc, so we basically have a key only for that.

I'm at a loss as to what to do to help find a solution for everyone.

fr-oss is a great layout with many useful improvements over fr-latin9, but the missing ControlR is a deal breaker. I'm personally back to using the default "fr" layout and I'll advise users to do the same if they want their ControlR back.

@Ubuntu users listening in through Launchpad: use whatever control panel you have to select a layout that doesn't have the words "Alternative" or "variante".

Cheers

Created attachment 98826
Make Level 5 choosers more easily available

The patch makes existing options for Level 5 choosers more easily available by adding them to the rules. This is useful in its own right, irrespective of this bug. In context of this ongoing discussion, it would allow to change back to the old default, and allow users who prefer the current behaviour to use the options lv5:rctrl_switch and nbsp:level4n to get their preferred behaviour.

About a "short nbsp" in french, let's make it perfectly clear that there must be about a hundred professionnal typographists in the whole country who care about it - most of them not using Linux BTW - and the rest of the ~40 million computer users here don't give a shit about a "short nbsp" and don't even know what it is, feel perfectly happy with the "correct french" they write without it, and many of them just would like their fscking right [Ctrl] key back.

If a so thin minority of professional typographists that in no way represent the average french "Joe" user want this modifier, it's perfectly OK that they devise their own special layout for their on needs, but by no means impose it on the rest of us.

BTW, about the punctuation signs that, in French, requires a nbsp before them, i.e. " ; : ! ? " (for perfect typographic correctness, while usually few people know about this and nobody really cares...) :

Usual word processing programs, such as OpenOffice / LibreOffice, when configured to the french locale, add these typographically required nbsps automagically, so people actually do not have to type the nbsp, which makes the need for an easy entry of these still less of an issue.

Should we follow the slope of stealing a useful right [Ctrl] key for this, then me might well in the future steal the left one for the dash " - ", as in french, we typographically use at least 3 different lenghts for dashes. As previously, word processing software usually transforms the "normal dash" into the "typographically correct dash"... Nope, all this mess of quite complex and unusual characters is the very reason for which meta and compose keys exist in the first place...

Swâmi,

We've all laid out these arguments many times over. Yes, this issue is frustrating (and I regret having vented some of my own frustration in my first comments) but let's keep it civil.

There are proposed solutions. I, for one, think Andreas' proposal is the best way out of the current dead lock as it would allow each and everyone of us to configure the fr-oss layout the way we want it. It's now up to Sergey and Nicolas to decide how to move this forward.

Cheers

I too believe that Andreas' proposal is the right one. It permits people who really want the extra 5th level to be able to easily get it, while not breaking the 99% usual usage.

Just for the record, I had not seen the linuxfr discussion. I guess mostly only people who would want the extra 5th level did realize that it would steal the right control key. If a discussion happened on "are people fine with making the right control key the 5th level modifier by *default*", the result would be quite different, I believe.

At the risk of just making things worse ...

My €0.02 is that we should stick with level 5 right Control as being optional. This is a marginal (in terms of percentage of userbase that will ever see/use it) layout that people have to go out of their way to use, but still taking away a modifier is a pretty big and surprising step.

I've got sympathy with the non-breaking-space thing from a strict technical correctness point of view, however it just can't be essential for day-to-day usage if Windows requires you to enter it by the Unicode codepoint. If such a large percentage of the French-speaking world cope with it, then so can we.

I think Andreas's proposal is the only sensible one. Some people won't be happy with it, but if this discussion (and that of Bépo) has shown us anything, it's that you really can't please anyone when dealing with alternate French keyboard layouts.

FWIW after user complaints I've reverted this change in Debian's xkeyboard-config, to have right control behave normally again.

ok, Daniel and Julien put last two nails into that coffin. I removed right control as level5 modifier in git. Thank you everybody. Really sorry there is no perfect solution here...

Changed in xkeyboard-config:
status: Confirmed → Fix Released

the fix looks like it'll reintroduce some form of #9529? or was the use of level4n instead of level4nl intentional?

Displaying first 40 and last 40 comments. View all 214 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.