Right-Ctrl key broken on French OSS keyboard

Bug #1013881 reported by Emmanuel Castro on 2012-06-15
120
This bug affects 24 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
High
Bryce Harrington
Precise
High
Unassigned

Bug Description

Since the version 2.5-1ubuntu1.2 of the package xkb-data, the right CTRL key of the keyboard has ceased to work.
The problem started when APT has updated the xkd-data from 2.5-1ubuntu1 to 2.5-1ubuntu1.2.

If I switch back to 2.5.-1ubuntu1 using Synaptic, it works back.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xkb-data 2.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu9
Architecture: amd64
Date: Sat Jun 16 00:16:09 2012
Dependencies:

DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 003: ID 17ef:1003 Lenovo Integrated Smart Card Reader
MachineType: LENOVO 4243E69
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-25-generic root=UUID=f6981326-31fd-4eaf-b039-3a1e5f33dbc0 ro quiet splash vt.handoff=7
SourcePackage: xkeyboard-config
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/06/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8AET56WW (1.36 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4243E69
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8AET56WW(1.36):bd12/06/2011:svnLENOVO:pn4243E69:pvrThinkPadT520:rvnLENOVO:rn4243E69:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4243E69
dmi.product.version: ThinkPad T520
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.8-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3.1
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.19.0-0ubuntu1~xup1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Gnome default setup when Xorg keyboard is "fr"/"oss" leads to the "France Alternative" layout.

In this layout some application can't handle space caracter properly.
(See URL as some exemples).

Workaround is to force "France Alternative, latin9 only" in Gnome

or

change Xorg.conf replacing :

Option "XkbVariant" "oss"
by
Option "XkbVariant" "latin9"

Created attachment 16310
xorg.conf

First of all, GNOME represents whatever is in base.xml. There is default French layout and several variants (including "oss" and "oss_latin9"). User choses whatever he wants. So I am not really sure what is the essence of your complain.

38 comments hidden view all 152 comments

Do note that the bug was reported AFTER switching back to the last fully functional version of xkb-data.

The right CTRL key is wrongly assigned to Level5 (see the attached picture).

It seems to be linked to this modification in wkeyboard-config
http://bazaar.launchpad.net/~alexeyten/xkeyboard-config/master/revision/1477#symbols/fr

It don't know what it tries to solve, but actually it creates more pain.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
Dominique Meeùs (dominiquem) wrote :

With Belgian OSS, I have the same Ctrl-R changed into Level5 as Emmanuel Castro (his attached image 2012-06-16).

It is probably because the config file for Belgian OSS include French OSS.
http://bazaar.launchpad.net/~alexeyten/xkeyboard-config/master/view/1477/symbols/be line 69

Par ailleurs, pour revenir à un clavier qui marche :
– lancez Synaptics (installez le si besoin),
– sélectionnez le paquet xkb-data.
– allez dans le menu "Paquets | Forcer la version...", sélectionnez 2.5-1ubuntu1 (precise) à la place de 2.5-1ubuntu1.2, et appuyez sur le bouton "Forcer la version" ;
– et enfin fermez votre session et ouvrez-en une nouvelle.

Longue vie au Ctrl-droit !

Dominique Meeùs (dominiquem) wrote :

Thanks to Emmanuel Castro for the workaround (forcing a previous version).
The choice w

Dominique Meeùs (dominiquem) wrote :

Sorry, pushed some wrong key.

[The choice…] was between 2.5-1ubuntu1 (precise) and 2.5-1ubuntu2 (precise-proposed). On https://help.ubuntu.com/community/UbuntuUpdates, I read: « Enabling the proposed updates repository can break your system. It is not recommended for inexperienced users. » I didn’t know this. I unchecked Proposed in my updates choices for the future.

The update was introducing "level5(rctrl_switch)" in response to a long complicated discussion (https://bugs.freedesktop.org/show_bug.cgi?id=15804) about some applications using some Ctrl+space shortcut. To me it seems that everybody expects to have two Ctrl keys on a regular PC keyboard. Suppressing the right Ctrl should be an option for those who need it, not the default.

Thank you for the information.

I am puzzled by the way how the bug FreeDesktop bug 15804 was handled!
The correct way to solve the RhythmBox bug was to remove the line
include "nbsp(level4nl)"
not patching the keyboard with the ugly
include "level5(rctrl_switch)"

Ok, we are loosing the non-breaking space. Only people doing typesetting use it anyway. If the nbsp(level4nl) can't be solved for RhythmBox, maybe they should have their separate keyboard.

And what if instead of level 4, we put non-breaking space to level 3. I find it is more convenient (and I think I am not alone).

So, instead of:
    include "nbsp(level4nl)"
we put non-breaking space to level 3:
    include "nbsp(level3n)"

This gives us back the Right-Ctrl. It does not break RhythmBox behaviour any more. And people using non-breaking spaces will be happy.

Thanks to Domique Meeùs for his useful suggetions

Dave Gilbert (ubuntu-treblig) wrote :

High -> A problem with an essential hardware component (Keyboard)

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → High

Do you need help from me to solve the problem?

Cordially

Emmanuel Castro

2012/6/24 Dave Gilbert <email address hidden>

> High -> A problem with an essential hardware component (Keyboard)
>
>
> ** Changed in: xkeyboard-config (Ubuntu)
> Importance: Undecided => High
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/1013881/+subscriptions
>

Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Sebastien Bacher (seb128) wrote :

Hey Bryce, could you look at that bug?

I can't confirm the issue there using a fr oss layout on my french precise but maybe it depends of special configs or interactions

Changed in xkeyboard-config (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Bryce Harrington (bryce)

As stated previously (#9), the problem only appears when activating the
'precise-proposed' package source. However, if it is not solved now, the
problem will appear for every user using the French Oss keyboard (that is
most of French users).

2012/6/25 Sebastien Bacher <email address hidden>

> Hey Bryce, could you look at that bug?
>
> I can't confirm the issue there using a fr oss layout on my french
> precise but maybe it depends of special configs or interactions
>
> ** Changed in: xkeyboard-config (Ubuntu)
> Assignee: Canonical Desktop Team (canonical-desktop-team) => Bryce
> Harrington (bryce)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/1013881/+subscriptions
>

Sebastien Bacher (seb128) wrote :

Emmanual: reading the upstream bug we have the choice between

- having space input broken in media players (i.e rhythmbox)
- having rctrl broken
- having a layout that leads to wrongly input nbsp chars

neiher of those look to good and I'm not sure what's the best solution, I will need to check what lucid was doing but

- the rhythmbox issue was solved at this time (not sure if the fix was already breaking rctrl there)
- we really want the rhythmbox issue fixed, so if we have to choice we will pick one of the 2 other bugs
- I'm not sure how many users use rctrl, I'm french and I never used it nor saw people around me use ... are you left handed (I'm wondering if that reverses usage and if a lefty would use the right ctrl)?

until we get those questions sorted we will stay on the current behaviour which seems the less annoying from the ones listed

Yes, I am left handed! So what?

Having RCtrl broken is against the tradition of computer keyboards. It is
against the philosophy of Ubuntu: computer for people – including left
handed, those who are born with two hands, and those who have to type only
with one.

Letting a bug in Rhythmbox is not a good option too.

What does lead to wrongly input nbsp chars if we put it into level 3
instead of level 4?
Most of keyboards use level3, except a Finland one which use «include
"nbsp(level4)"», not «include "nbsp(level4n)"»

I think the the support of nbsp(level4n) is broken in X11.

And really, removing RCtrl is not an option.

2012/6/26 Sebastien Bacher <email address hidden>

> Emmanual: reading the upstream bug we have the choice between
>
> - having space input broken in media players (i.e rhythmbox)
> - having rctrl broken
> - having a layout that leads to wrongly input nbsp chars
>
> neiher of those look to good and I'm not sure what's the best solution,
> I will need to check what lucid was doing but
>
> - the rhythmbox issue was solved at this time (not sure if the fix was
> already breaking rctrl there)
> - we really want the rhythmbox issue fixed, so if we have to choice we
> will pick one of the 2 other bugs
> - I'm not sure how many users use rctrl, I'm french and I never used it
> nor saw people around me use ... are you left handed (I'm wondering if that
> reverses usage and if a lefty would use the right ctrl)?
>
> until we get those questions sorted we will stay on the current
> behaviour which seems the less annoying from the ones listed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/1013881/+subscriptions
>

Bryce Harrington (bryce) wrote :

The change is from patch 109_fr_oss_space_char.patch which was brought in with version 2.5-1ubuntu1.1. Changing the behavior of the right control key was intentional, as requested by reporters in bug #221112 to fix a bad problem that occurs when using Rhythmbox.

2.5-1ubuntu1.1 is included in precise-updates now, since the SRU request was accepted and processed. So it's too late to pull the fix, it'd need a new SRU filed with a reversion.

Note that the patch in question was also included in Lucid and Maverick as a Ubuntu-specific patch (when RB was the default music player), but inadvertently got dropped for natty and oneiric. Meanwhile, the patch was sent upstream and accepted there. While the patch is a behavioral change compared with oneiric, since it preserves a behavior fixed in Lucid it seems sensible to me to include it to eliminate the LTS->LTS behavior change.

As to the proposed alternate solution, I am open to that if it does indeed fix things for both parties, *and* if it gets taken upstream. I see that bug reporters have already raised that upstream, so thanks! What we're going to do is wait and see what upstream thinks about it, and if/when they commit a fix we can consider pulling it for Ubuntu too.

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → In Progress

Since "2.5-1ubuntu1.1 is included in precise-updates now", I guess this bug will become very popular...
Excuse my ignorance, but what is the SRU.
When you say "upstream", do you mean the FreeDesktop bug?

Sebastien Bacher (seb128) wrote :

> Yes, I am left handed! So what?

Nothing specific, you took that the wrong way, as said I was trying to have a feeling of what percentage of the users it concerns and what is their usecase, I didn't say it was fine to bug anyone, but understand that any of the suggested solution so far do bother a part of the userbase, so we are stucked in choising what part is the smallest one or what issue is easier to work around

> Since "2.5-1ubuntu1.1 is included in precise-updates now", I guess this bug will become very popular...

No, it's not, as pointed before that patch and behaviour was default in Ubuntu in the lucid LTS and for years and we get very few negative feedback about it, I'm sorry it's impacting you directly but that doesn't make it an issue that impact every french user...

> Excuse my ignorance, but what is the SRU.

"stable release update", that's how we can bug fixes uploaded to stable series

> When you say "upstream", do you mean the FreeDesktop bug?

yes

Sebastien Bacher (seb128) wrote :

note also that the bug is easy to work around, you can change for another french layout than the "french (variante)" one in the system settings

Sebastien Bacher (seb128) wrote :

Ok, checking on lucid, by then we had this fix:
http://launchpadlibrarian.net/44180279/xkeyboard-config_1.8-1ubuntu6_1.8-1ubuntu7.diff.gz

"# Description: Don't include level4nl but only level4n for french oss layout.
# both space and Ctrl + space returned the same XLookupString, which prevents
# space using in some application using gtk_action_group_add_toggle_actions
# to setup Ctrl + space accelerator. We loose rctrl accelator but that's better
# than not having space in those applications and setup it manually will
# reintroduce https://bugs.launchpad.net/bugs/198759
# Ubuntu: https://launchpad.net/bugs/221112
# Upstream: http://bugs.freedesktop.org/show_bug.cgi?id=15804

Index: xkeyboard-config-1.8/symbols/fr
===================================================================
--- xkeyboard-config-1.8.orig/symbols/fr 2010-04-14 17:52:47.850615502 +0200
+++ xkeyboard-config-1.8/symbols/fr 2010-04-14 17:53:03.174604295 +0200
@@ -129,7 +129,7 @@

     include "latin"
     include "level3(ralt_switch)"
- include "nbsp(level4nl)"
+ include "nbsp(level4n)"
     include "keypad(oss)"

     name[Group1]="France - Alternative";"

so by then we didn't add the "include "level5(rctrl_switch)"" line ... does anyone know why it was added this time? it seems lucid in fact had both rhythmbox and rctrl working

Steve Langasek (vorlon) wrote :

Bryce,

> 2.5-1ubuntu1.1 is included in precise-updates now, since the SRU
> request was accepted and processed.

No, it isn't. The 2.5-1ubuntu1.2 SRU was accepted (incorrectly) into precise-proposed before 2.5-1ubuntu1.1 was promoted to precise-updates.

I've just tested the patch from Sebastian, i.e. removing the «include "level5(rctrl_switch)"» from the current "precise-proposed" package. The behavior is Ok for me:
– Right Ctrl works
– Rhythmbox Ctrl-Space works
– Nbsp is available (on level 4).

Now, what is the procedure to cook the patch of the patch?

Bryce Harrington (bryce) wrote :

Steve, ah, weird, I assumed the previous version was supposed to get pushed to -updates before a new sru would go in.

In that case, then yes I can just discard the earlier fix. I've done so and re-uploaded 2.5-1ubuntu1.3 with that reverted out.

Sebastien Bacher (seb128) wrote :

@Emmanual: we will get an update with the other pending fixes out while the question of the space,ctrl issue is sorted, we will address that one in another update

Hello Emmanuel, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xkeyboard-config/2.5-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Unfortunately, the test failed:
– Right Ctrl works => OK
– Rhythmbox Ctrl-Space works => KO
– Nbsp is available (on level 4) => OK

I think it w

Unfortunately, the test failed:
– Right Ctrl works => OK
– Rhythmbox Ctrl-Space works => KO
– Nbsp is available (on level 4) => OK

I think I was not clear in comment #24. The comment #22 of Sebastien Bacher is clearer.
The line 128 of symbol/fr
    include "nbsp(level4nl)"
must be replaced by
    include "nbsp(level4n)"

For an unknown reason, the line «include "nbsp(level4nl)"» produces the bug of Rhythmbox.

Next time might be the right time.

tags: added: verification-failed
removed: verification-needed
Steve Langasek (vorlon) wrote :

Emmanuel, the intent of this latest upload is to roll back *all* changes to the space handling, so that the SRU can proceed with the other unrelated fixes rather than being blocked by a perfect solution to this one.

From that perspective, my understanding is that the change that's applied here *has* fixed the issue you reported in this bug, hasn't it? In that things now work consistently for you between versions 2.5-1ubuntu1 and 2.5-1ubuntu1.3 of xkb-data?

In that case, could you please mark this bug 'verification-done' rather than 'verification-failed', and we'll use the original bug, bug #221112, for tracking the Ctrl+Space issue.

Ok

tags: added: verification-done
removed: verification-failed
Sebastien Bacher (seb128) wrote :

@Emmanual: the reason we rolled back rather than include that nl->n 1 liner change is that we want to see the other fixes out and it's still not clear that the change is the correct one and wouldn't create issues and lead to another SRU verification fail.

Do you know the drawbacks we would have exactly with doing that change? It was mentioned upstream that it would make easier to insert nbsp chars by mistake, would you consider that a regression?

I've analysed the use of nbsp(levelX) in all the keyboards defined in
/usr/share/X11/xkb

Keyboards defining nbsp on level 3:
./symbols/tr: include "nbsp(level3)"
./symbols/fi: include "nbsp(level3)"
./symbols/lt: include "nbsp(level3)"
./symbols/fr: include "nbsp(level3)" // "French (legacy,
alternative)"
./symbols/no: include "nbsp(level3n)"
./symbols/ca: include "nbsp(level3s)"

Keyboards defineinf nbsp on level4:
./symbols/fi: include "nbsp(level4)"
./symbols/fi: include "nbsp(level4)"
./symbols/fr: include "nbsp(level4nl)" // The only keyboard using
level4nl -- which I think is buggy.

What nbsp(levelX) exactly means:
  nbsp:level2 Non-breakable space character at second level
  nbsp:level3 Non-breakable space character at third level
  nbsp:level3s Non-breakable space character at third level,
nothing at fourth level
  nbsp:level3n Non-breakable space character at third level, thin
non-breakable space character at fourth level
  nbsp:level4 Non-breakable space character at fourth level
  nbsp:level4n Non-breakable space character at fourth level, thin
non-breakable space character at sixth level
  nbsp:level4nl Non-breakable space character at fourth level, thin
non-breakable space character at sixth level (via Ctrl+Shift) ---- Broken
with RhythmBox

We have the following choices after dropping the level4nl (which is the
cause of the RhythmBox problem):
– using level4n works (I've tested it), but actually I can't produce
thin-nbsp as I don't know how to get sixth level. However, fr-oss defines
thin-nbsp on AltGr-V.
– using level4 might work just like level4n (I can test it). It has the
advantage of being in use in finish keyboard (fewer risk of bug).
– level3s is in use in Canada, but as you said, some people have complained
that it leads to mistyping (I don't agree, but it is only my opinion).

If you want nbsp accessible from the space bar, with a slight change for
those who use AltGr-Shift-Space to get nbsp, choose level3n.
     * nsbp on AltGr-Space / thin-nbsp on AltGet-Shift-Space and AltGr-V)
If you want a conservative choice, choose level4 (thin-nbsp still available
on Alt-Gr V).
     * nsbp on AltGr-Shift-Space / thin-nbsp on AltGr-V)

I prefer the first option, but I won't complain if you choose the
conservative one.

Clint Byrum (clint-fewbar) wrote :

The fix for this cannot progress to precise-updates until it is fixed in quantal. Can somebody please confirm that the bug is fixed in quantal? Preferrably by marking the bug status as 'Fix Released'.

Changed in xkeyboard-config (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → High
Steve Langasek (vorlon) wrote :

This particular bug pertains to the /reverting/ of a patch that was included in a previous SRU upload that was not yet promoted to -updates. So solving this in quantal should not be a blocker for promoting this SRU.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu1.3

---------------
xkeyboard-config (2.5-1ubuntu1.3) precise-proposed; urgency=low

  * Add 113_ossmath_is_five_levels.patch: Some keymaps like fr(oss) fail to
    load because they include ossmath (via keypad(oss)) which
    misconfigures the keypad as 4-level when it should be 5-level. This
    patch from upstream bugzilla fixes this by adding the 5th level to the
    ossmath definition.
    (LP: #985065)
  * Drop 109_fr_oss_space_char.patch change; the fix causes behavioral
    changes for right control which a fr(oss) user did not like.
    (LP: #1013881)

xkeyboard-config (2.5-1ubuntu1.2) precise-proposed; urgency=low

  * Add 111_cz_ssharp.patch: Fix mapping of 4th level of the AC11 key to
    ssharp rather than quotedbl for the Czech layout. Cherrypick of
    patch from upstream.
    (LP: #953477)
  * Add 112_dk_dvorak_tilde.patch: Fix tilde key in the Danish Dvorak
    layout. It's not the same as Norwegian as has been assumed previously.
    (LP: #989626)

xkeyboard-config (2.5-1ubuntu1.1) precise-proposed; urgency=low

  * Add 109_fr_oss_space_char.patch: Fix problems using space bar in various
    applications when using the fr(oss) keymap.
    (was for LP bug 221112)
  * Add 110_dead_hook_horn.patch: Add two deadkeys on level 3 and 4 of the
    j key for the latin keymap.
    (LP: #825624)
 -- Bryce Harrington <email address hidden> Mon, 25 Jun 2012 17:32:15 -0700

Changed in xkeyboard-config (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu6

---------------
xkeyboard-config (2.5-1ubuntu6) quantal; urgency=low

  * Disable patch 109. The fix causes behavioral changes for right
    control. Needs to be fixed differently; discussion ongoing upstream.
    (LP: #1013881)
 -- Bryce Harrington <email address hidden> Thu, 19 Jul 2012 14:08:18 -0700

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
75 comments hidden view all 152 comments
alex (a-jaury) wrote :

Bonjour, moi aussi je préfère que ma touche rctrl (Control R) se comporte comme une touche Control, et non comme level5_machin_chose.

Merci d'avance,
alex

Hello, so would I rather my rctrl key to behave as a control key.

Thanks,
alex

By the way, with this modification, the drawing around line 120 in/usr/share/X11/xkb/symbols/fr is wrong because it shows a keyboard with a Ctrl key on the right, not a Level5 thing...

Give us back - please - the right control key acting the same as left control key.

http://forum.ubuntu-fr.org/viewtopic.php?id=1563071

Claire Brione (cbrione) wrote :

I really do not understand why this key is disabled. If it is there, it is certainly not to make the keyboard look pretty.

Okay, your "vote" is currently happening on

https://bugs.launchpad.net/bugs/1013881

with 4 new entries today (from different people), 100% of them saying :

« PLEASE GIVE US OUR RIGHT [CTRL] KEY BEHAVING AS A [CTRL] KEY BACK !!! »

To summarize further, AFAIK, there is ONE person in the world happy that the french right [CTRL] has been broke, 100% of the other french keyboard users who want their [CTRL] key back,...

...and the rest of the world doesn't use a french keyboard and doesn't care.

Yes, please give it back !
Moreover I got two "Super" keys (with windows logo), why my right Super is also broken ? Is it the same problem as Ctrl ?

Rendez-vous la touche Ctrl-Droite, souiplait :-/

PLEASE GIVE US OUR RIGHT [CTRL] KEY BEHAVING AS A [CTRL] KEY BACK !!!
It is especially important for left-handed people.

Nicolas, I understand the logic in your position about Level 5. But I see a number of unhappy people. Could we find some other level5 chooser?

G-rom (g-rom-sempai) wrote :

I discovered that bug with Ubuntu 14.04. Seriously what's the hell!

Sorry to be rude but Nicolas you seriously fucked up here and raised an hungry mob.

I'm a full time developper and I just cannot think about writing code without CTRL_R. It make me feel so hungry when I discovered that bug and even more at what caused that. I was like: WTF Seriouslyyyyyyyyyy FUUUUUUUUUUUUUUUU

Temp fix:

echo 'keycode 105 = Control_R' >> ~/.Xmodmap
echo 'add Control = Control_R' >> ~/.Xmodmap
echo 'xmodmap ~/.Xmodmap' >> ~/.bashrc
source ~/.bashrc

Before searching a level5 chooser, please, a quick fix!

2014-05-02 0:59 GMT+02:00 Sergey V. Udaltsov <email address hidden>:

> Nicolas, I understand the logic in your position about Level 5. But I
> see a number of unhappy people. Could we find some other level5 chooser?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xkeyboard-config/+bug/1013881/+subscriptions
>

(In reply to comment #66)

> Regarding the voting, is there generic popular Linux-oriented site in
> France? Like slashdot.org or smth...

There is a popular Linux-oriented site in France (linuxfr.org) and the final ajustments of this layout were done after discussion on this site.

I realise there is a vocal minority that does not like some of those choices but
1. the other alternatives used in the ancestors of this layout generated a lot more hate mail
2. because I knew there was no choice everyone would like spacebar layout is modular (and I'm the person who modularized it as part of the creation of this layout). People can choose the previous behaviour if they want and a few other possibilities were added as part of the modularization
3. so far no one proposed any better option appart from removing symbols which are necessary to write proper French (arguably proper French is not the same as C code). It's a lot easier to clamor for removal of the bits you do not use than to try to design a general-purpose solution without cutting corners

(In reply to comment #69)

> > Regarding the voting, is there generic popular Linux-oriented site in
> > France? Like slashdot.org or smth...
>
> There is a popular Linux-oriented site in France (linuxfr.org) and the
> final ajustments of this layout were done after discussion on this site.
>
> I realise there is a vocal minority that does not like some of those choices

A site like linuxfr.org may well be a vocal minority in itself. Nothing proves that linuxfr.org is representative of ordinary users. And even on linuxfr.org I have seen posts saying "where is my CRTL-R gone?" or "my keyboard is broken since some new version of Ubuntu".
In a way, suppressing one of the customary CTRL keys is intrinsically a minority point of view.
[Furthermore, the French layout for the Belgian keyboard depends on the French layout for the French keyboard. I do not see why a discussion on linuxfr.org should decide that Belgians have no use of right CTRL.]

> but
> 1. the other alternatives used in the ancestors of this layout generated a
> lot more hate mail

I doubt having a right CTRL key ever generated hate mail. That hate mail was about other questions.

> 2. because I knew there was no choice everyone would like spacebar layout is
> modular (and I'm the person who modularized it as part of the creation of
> this layout). People can choose the previous behaviour if they want and a
> few other possibilities were added as part of the modularization

We are not here discussing space bar, but right CTRL. Is right CTRL modular? Is there an option easily accessible to the ordinary user to restore right CTRL?

> 3. so far no one proposed any better option appart from removing symbols
> which are necessary to write proper French (arguably proper French is not
> the same as C code). It's a lot easier to clamor for removal of the bits you
> do not use than to try to design a general-purpose solution without cutting
> corners

The clamor is not against proper French of for removal of anything. Furthermore, how could an ordinary user "try to design a solution"? The user wants a common PC keyboard with CTRL keys, without having to write the code himself. The clamor is: do what you can to allow writing proper French —and thank you for your trying to do it— but leave the right CTRL.
-------
If no agreement can be reached, would it be possible to have the old layout accessible, even under another name? I do not know how many variants are allowed, by design, or by freedesktop conventions. Of course a new variant would be useless if it didn’t appear in the choices offered to an ordinary user by the most popular GNU Linux distributions.

Download full text (3.5 KiB)

(In reply to comment #69)
> (In reply to comment #66)
>
> > Regarding the voting, is there generic popular Linux-oriented site in
> > France? Like slashdot.org or smth...
>
> There is a popular Linux-oriented site in France (linuxfr.org) and the
> final ajustments of this layout were done after discussion on this site.

But this has the same pitfall as any volunteered survey, it isn't any kind of representative. I for example myself barely ever read a linuxfr article, and wouldn't participate or even see a survey there. That doesn't mean I'm not a French fr/oss user :)

Also note that people suffering from the situations are a lot more likely to do something and speak their mind than people perfectly happy with the situation. So probably "discussing" a problem is likely to only include opinion from people not happy with the current state, and people closely involved.

> I realise there is a vocal minority that does not like some of those choices
> but

Just to be fair, I see *no one* else here arguing towards keeping right Ctrl Level5 modifier -- but sure, as I state above, people happy with it won't see the discussion or care, so it may be biased.

> 1. the other alternatives used in the ancestors of this layout generated a
> lot more hate mail

If it broke people's apps (or apps broke with it, I don't care who's fault it is), I surely can understand people being angry. But similarly, since the change from this report broke people's right Ctrl key, I can understand they get angry.

> 2. because I knew there was no choice everyone would like spacebar layout is
> modular (and I'm the person who modularized it as part of the creation of
> this layout). People can choose the previous behaviour if they want and a
> few other possibilities were added as part of the modularization

And we thank you for your work. But I don't think it's realistic to think everyone can "choose the previous behavior" if it means editing the keymap. I already said it, but it took me quite some time to find what caused my right Ctrl key to no longer work and fix it, and I think it's fair to consider myself a quite advanced user.

If really reverting the addition of Level5 is not an option (but see below), please add an alternative layout.

> 3. so far no one proposed any better option appart from removing symbols
> which are necessary to write proper French (arguably proper French is not
> the same as C code).

The change in this particular report did not add or remove any symbol, it only moved one to Level5 because some apps couldn't handle <Ctrl>Space with this layout. And as I said earlier, most of the incriminated apps (at least that I know of) don't even use <Ctrl>Space anymore, rendering the change moot for them.

And even if we wanted to please those apps, we mayb be able to without adding a new modifier (Level5) and a key for it -- again, see (comment #46).

Also note that event though I admittedly don't use short-nbsp (I'm afraid I don't know the rules where this one should be used in French typography), I'm an heavy user of nbsp everywhere French typography tells me to do it. So no, I don't want to remove anything, don't worry -- but I'd like my rig...

Read more...

(In reply to comment #70)

> If no agreement can be reached, would it be possible to have the old layout
> accessible, even under another name?

The old layout was never removed and kept its historical name (fr latin9)

(In reply to comment #72)
> The old layout was never removed and kept its historical name (fr latin9)

No, we are speaking here of fr/oss, but before it got right Ctrl as level5 modifier (what this bug end up changing).

I bet everyone complaining here was very happy with fr/oss before this Level5 modifier -- at least I was, this map has so everything useful (and more) on handy locations :)

(In reply to comment #71)

> And even if we wanted to please those apps, we mayb be able to without
> adding a new modifier (Level5) and a key for it -- again, see (comment #46).

I'm pretty sure some of the other spacebar configurations available as xkb options do not require level5. They are not the default for fr(oss) because without level5 it is too easy to type a nbspc by mistake and random nbspc everywhere breaks lots of things (as reported by fr latin9 users).

Nicolas,

Where does the need to *have* a key for nbsp come from? Isn't a compose combo more appropriate and less error-prone?

Cheers

(In reply to comment #75)
> Nicolas,
>
> Where does the need to *have* a key for nbsp come from?

Because unlike in English most French punctuation symbols require a space (sometimes a short space) before. And if it's not a non-breakable space apps will perform line breaks at the wrong position and you'll end up with orphan sumbols at line starts

Online
http://fr.wikipedia.org/wiki/Espace_ins%C3%A9cable

Actual authoritative reverence (highly recommended if you want to work on any system with French inputs or outputs)
http://www.amazon.fr/Lexique-r%C3%A8gles-typographiques-lImprimerie-Nationale/dp/2743304820

Lack of non breakspace on French layouts on some OSes is such a basic problem OpenOffice/LibreOffice had to hardcode a nbspc combo but that does not help when writing in you MUA, your browser, your IM client, etc

> Isn't a compose
> combo more appropriate and less error-prone?

Compose is not appropriate for basic symbols you need to write pretty much any correct sentence in the target language. And adding a specific input method for one symbol just because some people can't live with the modifier ISO chose for level 5 is disproportionnate.

3 comments hidden view all 152 comments

(In reply to comment #76)
> Compose is not appropriate for basic symbols you need to write pretty much
> any correct sentence in the target language. And adding a specific input
> method for one symbol just because some people can't live with the modifier
> ISO chose for level 5 is disproportionnate.

Woow, calm down guys. What's disproportionate is the reaction here! *before* the change this report introduced, and which many of us are trying to get reverted, *both* nbsp and nbspc were easily available:

nbsp AltGr+Shift+Space
nbspc Ctrl+Shift+Space

Reverting the change this report introduced would get this behavior. Please understand we just want to get nbspc moved back where it *was* (or for me, anywhere on a 1-4 level), not removed or anything. Also, realize that currently there is only *one* Level5-specific symbol, and that's nbspc, so we basically have a key only for that.

2 comments hidden view all 152 comments

However, for most French people, standard Right-Ctrl key is more important
than Nbsp.
Especially for left-handed people who use left hand for the mouse and most
letters, and right hand for Shift, Ctrl and AltGr. A notable exception is
Alt which only exists on the left.

Anyway, it's written Ctrl on the Right-Ctrl, so it MUST behave as a Ctrl.

Put nbsp where you want, but give us back the Right-Ctrl.

2014-05-07 11:41 GMT+02:00 Nicolas-mailhot-laposte <
<email address hidden>>:

> (In reply to comment #75)
> > Nicolas,
> >
> > Where does the need to *have* a key for nbsp come from?
>
> Because unlike in English most French punctuation symbols require a
> space (sometimes a short space) before. And if it's not a non-breakable
> space apps will perform line breaks at the wrong position and you'll end
> up with orphan sumbols at line starts
>
> Online
> http://fr.wikipedia.org/wiki/Espace_ins%C3%A9cable
>
> Actual authoritative reverence (highly recommended if you want to work on
> any system with French inputs or outputs)
>
> http://www.amazon.fr/Lexique-r%C3%A8gles-typographiques-lImprimerie-Nationale/dp/2743304820
>
> Lack of non breakspace on French layouts on some OSes is such a basic
> problem OpenOffice/LibreOffice had to hardcode a nbspc combo but that
> does not help when writing in you MUA, your browser, your IM client, etc
>
> > Isn't a compose
> > combo more appropriate and less error-prone?
>
> Compose is not appropriate for basic symbols you need to write pretty
> much any correct sentence in the target language. And adding a specific
> input method for one symbol just because some people can't live with the
> modifier ISO chose for level 5 is disproportionnate.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xkeyboard-config/+bug/1013881/+subscriptions
>

What if nbsp is accessible using AltGr+Space or AltGt+Shift+Space ?

2014-05-07 14:00 GMT+02:00 Emmanuel Castro <email address hidden>:

> However, for most French people, standard Right-Ctrl key is more
> important than Nbsp.
> Especially for left-handed people who use left hand for the mouse and most
> letters, and right hand for Shift, Ctrl and AltGr. A notable exception is
> Alt which only exists on the left.
>
> Anyway, it's written Ctrl on the Right-Ctrl, so it MUST behave as a Ctrl.
>
> Put nbsp where you want, but give us back the Right-Ctrl.
>
>
> 2014-05-07 11:41 GMT+02:00 Nicolas-mailhot-laposte <
> <email address hidden>>:
>
> (In reply to comment #75)
>> > Nicolas,
>> >
>> > Where does the need to *have* a key for nbsp come from?
>>
>> Because unlike in English most French punctuation symbols require a
>> space (sometimes a short space) before. And if it's not a non-breakable
>> space apps will perform line breaks at the wrong position and you'll end
>> up with orphan sumbols at line starts
>>
>> Online
>> http://fr.wikipedia.org/wiki/Espace_ins%C3%A9cable
>>
>> Actual authoritative reverence (highly recommended if you want to work on
>> any system with French inputs or outputs)
>>
>> http://www.amazon.fr/Lexique-r%C3%A8gles-typographiques-lImprimerie-Nationale/dp/2743304820
>>
>> Lack of non breakspace on French layouts on some OSes is such a basic
>> problem OpenOffice/LibreOffice had to hardcode a nbspc combo but that
>> does not help when writing in you MUA, your browser, your IM client, etc
>>
>> > Isn't a compose
>> > combo more appropriate and less error-prone?
>>
>> Compose is not appropriate for basic symbols you need to write pretty
>> much any correct sentence in the target language. And adding a specific
>> input method for one symbol just because some people can't live with the
>> modifier ISO chose for level 5 is disproportionnate.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1013881
>>
>> Title:
>> Right-Ctrl key broken on French OSS keyboard
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/xkeyboard-config/+bug/1013881/+subscriptions
>>
>
>

JC Boggio (jissouille) wrote :

Please give us our Right Ctrl key back. Forcing everyone to make his own .Xmodmap to bypass the bug *is* the disproportionnate thing IMO.

1 comments hidden view all 152 comments

I'm at a loss as to what to do to help find a solution for everyone.

fr-oss is a great layout with many useful improvements over fr-latin9, but the missing ControlR is a deal breaker. I'm personally back to using the default "fr" layout and I'll advise users to do the same if they want their ControlR back.

@Ubuntu users listening in through Launchpad: use whatever control panel you have to select a layout that doesn't have the words "Alternative" or "variante".

Cheers

Created attachment 98826
Make Level 5 choosers more easily available

The patch makes existing options for Level 5 choosers more easily available by adding them to the rules. This is useful in its own right, irrespective of this bug. In context of this ongoing discussion, it would allow to change back to the old default, and allow users who prefer the current behaviour to use the options lv5:rctrl_switch and nbsp:level4n to get their preferred behaviour.

About a "short nbsp" in french, let's make it perfectly clear that there must be about a hundred professionnal typographists in the whole country who care about it - most of them not using Linux BTW - and the rest of the ~40 million computer users here don't give a shit about a "short nbsp" and don't even know what it is, feel perfectly happy with the "correct french" they write without it, and many of them just would like their fscking right [Ctrl] key back.

If a so thin minority of professional typographists that in no way represent the average french "Joe" user want this modifier, it's perfectly OK that they devise their own special layout for their on needs, but by no means impose it on the rest of us.

You're kidding ! In France, professional typographists use Macintosh, I
fear. And the average French user is not "Joe", he's "Jean".

And I'll write unconstructive sarcasms until I get my Right-Ctrl back ! (Do
note the French style space before the exclamation marks)
Le 12 mai 2014 07:10, "Swâmi Petaramesh" <email address hidden> a
écrit :

> About a "short nbsp" in french, let's make it perfectly clear that there
> must be about a hundred professionnal typographists in the whole country
> who care about it - most of them not using Linux BTW - and the rest of
> the ~40 million computer users here don't give a shit about a "short
> nbsp" and don't even know what it is, feel perfectly happy with the
> "correct french" they write without it, and many of them just would like
> their fscking right [Ctrl] key back.
>
> If a so thin minority of professional typographists that in no way
> represent the average french "Joe" user want this modifier, it's
> perfectly OK that they devise their own special layout for their on
> needs, but by no means impose it on the rest of us.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1013881
>
> Title:
> Right-Ctrl key broken on French OSS keyboard
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/xkeyboard-config/+bug/1013881/+subscriptions
>

BTW, about the punctuation signs that, in French, requires a nbsp before them, i.e. " ; : ! ? " (for perfect typographic correctness, while usually few people know about this and nobody really cares...) :

Usual word processing programs, such as OpenOffice / LibreOffice, when configured to the french locale, add these typographically required nbsps automagically, so people actually do not have to type the nbsp, which makes the need for an easy entry of these still less of an issue.

Should we follow the slope of stealing a useful right [Ctrl] key for this, then me might well in the future steal the left one for the dash " - ", as in french, we typographically use at least 3 different lenghts for dashes. As previously, word processing software usually transforms the "normal dash" into the "typographically correct dash"... Nope, all this mess of quite complex and unusual characters is the very reason for which meta and compose keys exist in the first place...

Swâmi,

We've all laid out these arguments many times over. Yes, this issue is frustrating (and I regret having vented some of my own frustration in my first comments) but let's keep it civil.

There are proposed solutions. I, for one, think Andreas' proposal is the best way out of the current dead lock as it would allow each and everyone of us to configure the fr-oss layout the way we want it. It's now up to Sergey and Nicolas to decide how to move this forward.

Cheers

I too believe that Andreas' proposal is the right one. It permits people who really want the extra 5th level to be able to easily get it, while not breaking the 99% usual usage.

Just for the record, I had not seen the linuxfr discussion. I guess mostly only people who would want the extra 5th level did realize that it would steal the right control key. If a discussion happened on "are people fine with making the right control key the 5th level modifier by *default*", the result would be quite different, I believe.

At the risk of just making things worse ...

My €0.02 is that we should stick with level 5 right Control as being optional. This is a marginal (in terms of percentage of userbase that will ever see/use it) layout that people have to go out of their way to use, but still taking away a modifier is a pretty big and surprising step.

I've got sympathy with the non-breaking-space thing from a strict technical correctness point of view, however it just can't be essential for day-to-day usage if Windows requires you to enter it by the Unicode codepoint. If such a large percentage of the French-speaking world cope with it, then so can we.

I think Andreas's proposal is the only sensible one. Some people won't be happy with it, but if this discussion (and that of Bépo) has shown us anything, it's that you really can't please anyone when dealing with alternate French keyboard layouts.

Effede (dulaurier-f) wrote :

I don't believe this thread... Really, this is just unbelivable!

Nicolas, I don't know you, but you should seriously try to work on yourself and learn to accept when you're wrong.

For the virtual poll here, I say : PUT BACK THE CRTL-R KEY.

FWIW after user complaints I've reverted this change in Debian's xkeyboard-config, to have right control behave normally again.

ok, Daniel and Julien put last two nails into that coffin. I removed right control as level5 modifier in git. Thank you everybody. Really sorry there is no perfect solution here...

Changed in xkeyboard-config:
status: Confirmed → Fix Released

Hi,

Any chance to see this bug fixed in Trusty too?

As Trusty Tahr is a LTS edition, it should include the bug resolution so that it won't last for years.

Sebastien Bacher (seb128) wrote :

it would be nice to have a bug we can use for the SRU, not sure if that one is appropriate since it's years old and close. Otherwise agreed that we should fix that issue in trusty

Sebastien Bacher a écrit ce qui suit, le 23/07/14 12:10 :
> it would be nice to have a bug we can use for the SRU, not sure if that
> one is appropriate since it's years old and close. Otherwise agreed that
> we should fix that issue in trusty
>
In the Debian sid package xkb-data 2.12-1, the bug *is* corrected
(Ubuntu is still at 2.10). I did install it in 14.04 and test with the
Belgian alternate keyboard (based on the French). Both Ctrl keys do act
as Ctrl.
I do not understand the thing that would be nice to have above, but it
is not an issue any more for Debian testing or for Debian unstable.

@Dominique Meèus : how did you install xkb-data 2.12-1 in Trusty ? I've downloaded the .deb from https://packages.debian.org/sid/all/xkb-data/download but gdebi says : État : Erreur : n'est plus fourni xkb-data
I've tried through "Logithèque" which seems to install it (no error message) but still no classic right control key even after rebooting.
I'm using keyboard : Français (variante) and the keymap still shows "level 5…" under Right Ctrl key.

the fix looks like it'll reintroduce some form of #9529? or was the use of level4n instead of level4nl intentional?

I also noticed actual versions of xkb-data & xkb-data-i18n in Ubuntu 14.04.4/5 broke again right-ctrl-key with french ( alternative ) keyboard.

I've fixed it installing versions from xenial, using dpkg command.

http://packages.ubuntu.com/xenial/xkb-data
http://packages.ubuntu.com/xenial/xkb-data-i18n

Displaying first 40 and last 40 comments. View all 152 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.