Report Cards Missing Grades

Bug #1432672 reported by Tom Hoffman on 2015-03-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SchoolTool Gradebook
Critical
Douglas Cerna

Bug Description

My report cards are not showing courses or grades for any students. On the other hand, transcripts do show grades.

Here is what I have done:

1. I set up a section (with students and a teacher)
2. I added an activity in Sheet 1.
3. I added category weighting.
4. I created and deployed a report sheet "Final Grades."
5. In that report sheet I entered student grades.
6. I created a Report Card Layout that uses the report sheet "Final Grades."
7. I generated report cards.
8. I generated transcripts.

I am using Schooltool 2.8.3.

Can you point me in the right direction to make sure courses and grades appear in both report cards and transcripts?

Changed in schooltool:
status: New → Triaged
assignee: nobody → Douglas Cerna (replaceafill)
importance: Undecided → Critical
Charl Bouwer (zarachnia) wrote :

https://answers.launchpad.net/schooltool/+question/251426
This question helped explain it to me and now I created a end of term sheet to be shown in the report cards. I would have liked if the teacher's sheet and the end of term sheet could be linked but with a facility to manually adjust the end term marks after it was exported from teacher's sheet.

Tom Hoffman (tom-hoffman) said on 2014-07-09: #3

The basic model for the gradebook/report card system is that the teachers will have sheets that they use to record day to day grades and calculate the end of term grade, and then enter the end of term grade in the report sheet.

When you deploy the report sheet, it adds the report sheet with the columns you've defined in the template, to each section's sheet.

Changed in schooltool:
status: Triaged → Fix Committed
affects: schooltool → schooltool.gradebook
Changed in schooltool.gradebook:
milestone: none → 2.8.4
Changed in schooltool.gradebook:
status: Fix Committed → Fix Released
Daniel Owens (dh-owens) wrote :

Thanks for working on this! I updated my installation to 2.8.4 this morning and gave it a go. However, for some reason now I get an error message when I try to generate a report card. It tells me I have no report card layout defined. See attached screenshot. I still have the same report card layout defined from before. I confirmed that it is still there. Could this be related to the most recent patch, or am I missing something?

Douglas Cerna (replaceafill) wrote :

Hi Daniel.

Do you have multiple school years defined in your instance? Do all of them have report card layouts defined?

Douglas Cerna (replaceafill) wrote :

Oh, I just saw the problem. It's a bad condition that wants both Grid columns and Outline items to be available. I'll fix it right away.

Douglas Cerna (replaceafill) wrote :

Just released SchoolTool Gradebook 2.8.4.1 to address this issue.

Daniel Owens (dh-owens) wrote :

Cool, thanks!

Daniel Owens (dh-owens) wrote :

I am not sure if this is related, but since I upgraded I cannot generate PDFs for report cards or transcripts. I get a font error. See attached error file.

Douglas Cerna (replaceafill) wrote :

Hi Daniel.

Can you check you have the "ttf-ubuntu-font-family" package installed:

$ apt-cache policy ttf-ubuntu-font-family
ttf-ubuntu-font-family:
  Installed: 0.80-0ubuntu6
  Candidate: 0.80-0ubuntu6
  Version table:
 *** 0.80-0ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Also, have you changed your /etc/schooltool/standard/schooltool.conf file somehow. There's a reportlab_fontdir line which should look like:

reportlab_fontdir /usr/share/fonts/truetype/liberation:/usr/share/fonts/truetype/ubuntu-font-family

I was able to reproduce your traceback by uninstalling the font package and by commenting the reportlab_fontdir line.

Daniel Owens (dh-owens) wrote :

Right, I forgot about schooltool.conf. I had set it up to use DejaVu fonts instead of Ubuntu fonts because DejaVu has better glyph coverage. Anyway, thanks for the help. Next time I will document my modifications.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions