Restore/revert of non-toplevel items produces only empty folders

Bug #709338 reported by Jean-Peer Lorenz on 2011-01-28
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
sbackup
Status tracked in Trunk
0.11
High
Jean-Peer Lorenz
Trunk
High
Unassigned
sbackup (Ubuntu)
Undecided
Unassigned

Bug Description

Problem was originally reported by Julien on 2011-01-07:

Whatever button I click (revert/restore/revert to/ restore to), I only get empty folders with eventually empty sub-folders. If I do the same with a single file, the file is correctly restored. I can see in the .tar.gz file that my folders should not be empty.

I have french version running 0.11.3 on Ubuntu Maverick.
I am trying to restore files as root (from Applications->Outils Systemes Ubuntu main menu)

My tar.gz file is as follows :
/etc
/home
/usr/local
/var

If I try to restore my /home/julien/.thunderbird folder (containing one folder and three files), only the folder tree is restored but there is no file. I obtained the enclosed log running with "RestoreAs" button.

If I launch the following command by myself in a terminal
/bin/tar -xp --gzip --ignore-failed-read --occurrence=1 --backup=existing --totals --same-owner --directory=/home/julien/zzz_test_restauration_home_julien/sbackup-restore_mykZJN --suffix=.before_restore_2011-01-27_17.42.23.294921 --file=/media/160GB/sauvegardes/2010-12-13_11.43.10.731121.moines.ful/files.tar.gz home/julien/.thunderbird

the result is the same : the folder tree is there but there is no file...

/bin/tar --version
tar (GNU tar) 1.23

Related branches

Jean-Peer Lorenz (peer.loz) wrote :
description: updated
Changed in sbackup (Ubuntu):
status: New → Confirmed
Jean-Peer Lorenz (peer.loz) wrote :

The problem stems from tar's commandline option '--occurrence' which behaves inconsistently. It does work if a top-level folder is being extracted but does not work for other directories. Unfortunately, pre-release test didn't cover such cases. Sorry for any trouble - a fix will be released ASAP.

Jean-Peer Lorenz (peer.loz) wrote :

The error was introduced in lp:sbackup/0.11 r211. This means solely sbackup 0.11.3 is affected.
Workarounds: restore top-level folders, install from source, install 0.11.2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sbackup - 0.11.4-0ubuntu1

---------------
sbackup (0.11.4-0ubuntu1) natty; urgency=low

  * [Fix] LP: #714916 Unhandled error in gio backend when looking up
                      verbose error message
  * [Fix] LP: #662613 sbackup crashes with 'NonValidOptionException'
  * [Fix] LP: #709338 Restore/revert of non-toplevel items produces only
                      empty folders
  * [Fix] LP: #689016 Uncaught error 'invalid literal for int() when
                      processing invalid configuration files
  * [Fix] LP: #697386 RemoteMountFailedError 'Max. number of password inputs
                      reached' not handled properly
  * [Fix] LP: #697654 No desktop session found: no notification icon:
  * [Fix] LP: #701403 Unable to use remote target without giving a password:
  * [Fix] LP: #588578 Email notification/reporting doesn't work with GMAIL
  * [Fix] LP: #706037 Email reports not working; enable debug output
                      for sending mail
  * [Fix] LP: #683990 Uncaught 'NoSectionError' when adding report settings
                      (SMTP server etc.)
  * [Fix] LP: #695613 Empty notification popup due to invalid markup
  * [Fix] LP: #671785 Parsing remote URIs fails when username or password
                      contains special characters; quote special characters
                      to comply with RFC 1738 sec. 3.1
  * [Fix] LP: #675361 Restore process fails with error 'is not a file' while
                      copying
  * [Fix] LP: #696183 Failed to set GID to `admin`; improved handling of
                      non-existent user groups
  * [Fix] LP: #507177 update translations
  * debian/control: added gconf2 and desktop-file-utils to Depends
 -- Jean-Peer Lorenz <email address hidden> Tue, 08 Feb 2011 13:58:43 +0100

Changed in sbackup (Ubuntu):
status: Confirmed → Fix Released
dag (jer1117) wrote :

I have sbackup version 0.11.3ubuntu1

the problem is not fixed .

When I try to revert /home I get empty directories.

The "restore top-level folders" does not work for me since I backed up /home
and in the windows of restore I can only choose "FileSystem" (I do not see "/")
Choosing "FileSystem" causes the restoration of /home/home
instead of /home

Please advise

thanks
Dag

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments