[SRU] Intrepid: No Access to NAS (samba<=2.2.x) shares any more

Reported by tankdriver on 2008-10-12
144
This bug affects 11 people
Affects Status Importance Assigned to Milestone
samba
Fix Released
Medium
samba (Ubuntu)
Medium
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: nautilus

I use Ubuntu 8.10 Intrepid Beta 64-bit

Versions:
samba: 2:3.2.3-1ubuntu3
nautilus: 1:2.24.0-0ubuntu2

Network attached storage: Longshine (smb and ftp)

The following connections work: (with nautilus window)

hardy <--> nas
hardy <--> intrepid
(intrepid <--> intrepid)

this works not:

intrepid <--> nas

When I try to open my network drive in nautilus I see the folder that my files are in but when I click the folder they are empty.

I tried the shell:

***********************************
thomas@thomas-hp-pav:~$ smbclient -N -L //192.168.2.6
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.2.8a]

 Sharename Type Comment
 --------- ---- -------
 Share Disk Share to All
 WEB Disk WEB
 Backup Disk Backup
 HPOSBkup Disk HPOSBkup
 IPC$ IPC IPC Service ()
 ADMIN$ IPC IPC Service ()
read_socket_with_timeout: timeout read. read error = Connection reset by peer.
Receiving SMB: Server stopped responding
session request to 192.168.2.6 failed (Read error: Connection reset by peer)
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.2.8a]

 Server Comment
 --------- -------
 I-DRIVE
 THOMAS-DESKTOP thomas-desktop server (Samba, Ubuntu)
 THOMAS-HP-PAV thomas-hp-pav server (Samba, Ubuntu)

 Workgroup Master
 --------- -------
 WORKGROUP I-DRIVE

***************************************

In Ftp-mode everything works well.

Any ideas?

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Does using gvfs-mount and gvfs-copy works correctly? What nas model do you use?

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
tankdriver (stoneraider) wrote :

Model:
Longshine LCS-8240 (Network USB Storage Server)
Site : http://www.longshine.de/longshine/p_storage.php?lang=ger
I don't know how to check gvfs-mount and gvfs-copy. (I can't find information about the usage)

Sebastien Bacher (seb128) wrote :

you can mount the share using gvfs-mount server-url and then copy using gvfs-copy url destination

tankdriver (stoneraider) wrote :

OK,
gvfs-mount was not installed, i 've installed the suggested gvfs-bin (apt-get).

then:
************
thomas@thomas-hp-pav:~$ gvfs-mount smb://i-drive/share/ (Desktop symbol appears)
thomas@thomas-hp-pav:~$ gvfs-copy smb://i-drive/share /Desktop/test
Error copying file smb://i-drive/share: Verzeichnis kann nicht rekursiv kopiert werden (i don't know how to get that message in english)
************

tankdriver (stoneraider) wrote :

Please ignore my last line.
Sorry, my fault: wrong command line (destination directory)
it should be:
*****************
thomas@thomas-hp-pav:~$ gvfs-copy smb://i-drive/share/ /home/thomas/Desktop/test/
Error copying file smb://i-drive/share/: Verzeichnis kann nicht über Verzeichnis kopiert werden
*****************

tankdriver (stoneraider) wrote :

SORRY, I am completely wrong today!
i 've tried it with one file:

****************************
thomas@thomas-hp-pav:~$ gvfs-mount smb://i-drive/share/ (Desktop symbol appears)
thomas@thomas-hp-pav:~$ gvfs-copy smb://i-drive/share/testfile.txt /home/thomas/Desktop/test/
****************************
Success!
The file "testfile.txt" appears in my "test" folder on my desktop.

Sebastien Bacher (seb128) wrote :

did you try copying the same file using nautilus?

tankdriver (stoneraider) wrote :

I don't even see the files in nautilus.
The share is mounted. Doubleclick on the icon --> nautilus windows pops up. There are no files listed.
In nautilus window at "locations": smb://i-drive/share/
Clicking on "refresh" (and waiting for some time and trying again) makes no difference.

Sebastien Bacher (seb128) wrote :

could you try if "gvfs-ls smb://i-drive/share/" lists the directory correctly?

tankdriver (stoneraider) wrote :

OK
Step1:
*************
thomas@thomas-hp-pav:~$ gvfs-ls smb://i-drive/
Share
WEB
Backup
HPOSBkup (Thats correct!)
thomas@thomas-hp-pav:~$
*************

Step2:
*************
thomas@thomas-hp-pav:~$ gvfs-mount smb://i-drive/share/ (Desktop symbol appears)
thomas@thomas-hp-pav:~$
*************

Step3:
*************
thomas@thomas-hp-pav:~$ gvfs-ls smb://i-drive/share/

thomas@thomas-hp-pav:~$
*************

Thats all I got. (the same (nothing) output with the other folders)

Sebastien Bacher (seb128) wrote :

do you usually need authentification to list the content of this directory?

tankdriver (stoneraider) wrote :

No.
I tried something:

************************
thomas@thomas-hp-pav:~$ smbclient -N //192.168.2.6/share
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.2.8a]
smb: \> l
                                      D 0 Wed Aug 31 07:59:02 2005
  . D 0 Sun Jul 6 18:19:46 2008
  Citroen_2CV6_Charleston02.pn A 825031 Mon Aug 1 21:51:22 2005
  TechSpec_TT-budget® S2-3200new DE.pd A 61325 Tue Aug 2 18:29:50 2005
  dvb-usb-megasky-02.f A 3360 Fri Aug 5 19:14:35 2005
  vdr.tar.g A 1215363 Fri Aug 5 19:56:04 2005
  dvb.tar.g A 19898034 Fri Aug 5 20:06:15 2005
  vollmacht.pn A 1689205 Fri Aug 5 22:22:36 2005
  streamtune D 0 Sat Jul 30 05:29:28 2005
  WindowsXP-KB936929-SP3-x86-DEU.ex A 328324136 Tue Aug 2 08:37:51 2005
  WindowsXP-KB835935-SP2-DEU.ex A 277936872 Tue Aug 2 08:40:19 2005
  HW 22.9.08.od 26425 Tue Aug 30 11:37:01 2005
  HW 09.10.08.od A 27661 Thu Sep 15 20:08:39 2005
  huh D 0 Mon Sep 19 04:29:38 2005
  testfile.tx 0 Wed Aug 31 07:58:53 2005

  46945 blocks of size 8388608. 13691 blocks available
smb: \>
************************
(I have only listed some files, not all)
The last letter of each file is missing.

this is strange.

tankdriver (stoneraider) wrote :

Additional information: the folder .gvfs is empty.
I can't find any debug logs or such things.

tankdriver (stoneraider) wrote :

Sorry again, my previous comment was not completely correct.

I mount "share":
thomas@thomas-hp-pav:~$ gvfs-mount smb://i-drive/share/
In the folder ".gvfs" appears the folder "share auf i-drive" after clicking on refresh( and waiting for 15 seconds)!

OK, i tried to open that folder "share auf i-drive": Result:
An error message pops up, telling: folder content can't be displayed and "Transport endpoint is not connected"
and "Apport" pops up:
Title: "gvfs-fuse-daemon crashed wih SIGSEGV in strlen()"
I think, there are already similar bugs reported.

I have attached the file generated by apport (located in /var/crash/)

tankdriver (stoneraider) wrote :

UPDATE: fresh installed&updated Intrepid RC:
same issue, no changes.

I am plagued with exactly the same problem. I can can see the shares but they are empty, I can read and write to them (blindly) but nautilus doesn't list any files. I think this has something to do with the server version, I'm also running an older samba server (a freesco router) with version 2.2.8. I also have a gutsy box with some shares on it, I've got no problems accessing those shares (though I think I did before some updates about a week ago?). FuseSMB is also in an unusable state though I'm not sure it's entirely related as it's having problems with the shares on the gutsy box as well.

All my shares are security=share with no passwords.
I can read/write files if I type the filenames manually but nautilus lists the shares as empty.
I can mount with smbmount and things seem to work fine. Can also list files with smbclient.
gvfs-mount/ls do not work. Doesn't matter if I use IPs or hostnames.

Forgot to say, this is on a box upgraded to intrepid and current with updates (so rc atm). I tried the shares yesterday with the livecd and had the same problem.

tankdriver (stoneraider) wrote :

Thank you, for your comments.
It is not easy to be alone with such a annoying bug.

Have you tried to open the folder (after mounting) in .gvfs manually? What happened?
see bug: https://bugs.launchpad.net/ubuntu/+source/fuse/+bug/284558

@developer/admin:
suggestion: maybe change bug description to "gvfs/nautilus can't display samba 2.2.8 shares correctly" (or something more eye-catchy)

At the moment it's giving me the "Transport endpoint is not connected" message when I try to cd into .gvfs but previously I could do an ls and see the shares listed. But when I cd into one I got an error message and the share disappeared. The same as you I believe. I'm out of my depth here but looking at your attached crash log it seems as if things are crashing when "fuse_add_direntry ()" called. I'm guessing this function adds a directory entry and so is called multiple times to populate a directory (duh!) in this case the share folder, with the real share contents from samba. If it's crashing out here it must be passing corrupt (or null?) paremeters or something which I guess would have to be coming from the smb client like that. Maybe the last character of the filename missing thing is relevant here? When I do "smbclient -N //server/share" then an ls at the prompt I also get all the filenames in the list returned missing the last character. Whereas if I do this on one of the working shares on my gutsy box the filenames are as they should. I think it's too much of a coincidence for these not to be related. I hypothesize filenames from 2.2.8 samba servers are somehow corrupted or incomplete and when this info is fed into gvfs to populate the directories it chokes and crashes on the first entry. That's my uneducated guess anyway!

Michael Devenish (mdevenish) wrote :

I have the same problem when connecting to my buffalo linkstation using Intrepid (updated this morning). Nautilus seems to connect ok but files and folders are not visible. If I connect using smbclient //server/share and use the -W <workgroup> and -U <username> options all the files and folders are listed when I enter ls at the smb prompt. Connecting using nautilus on hardy displays all the files.

My linkstation is also running samba 2.2.8. smbclient lists it as Samba 2.2.8a-ja-1.1

tankdriver (stoneraider) wrote :

Thank you!
I think 3 persons with this bug are enough to set status >confirmed.
(please feel free to correct me, if I am wrong)

Changed in gvfs:
status: Incomplete → Confirmed
heathenx (heathenx) wrote :

Hello.

I can confirm that I have the same problem as the above users. I just upgraded from Hardy to Intrepid RC yesterday and I cannot access my NAS drive through nautlius either. I can connect but no files are visible. Working just fine in Hardy.

I have found a workaround that works for me which amounts to manually mounting the drive. He is what I did.

sudo mount -t cifs //192.168.1.8/disk /media/nas_drive -o username=my_username_here,password=my_password_here,iocharset=utf8,file_mode=0777,dir_mode=0777

Hopefully that will help some of you while this issue is being fixed. :)

heathenx (heathenx) wrote :

Update:

I added this to my fstab so that my NAS is mounted at boot up/login. I get a CIFS error message on shutdown but it doesn't seem to affect anything.

//192.168.1.8/disk /media/nas cifs username=my_username_here,password=my_password_here,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

I can read and write to all of my directories just fine and it is mapped/bookmarked in Places>Removable Media. :)

Hi, I don't think anybody here has a problem with accessing the shares normally like that. I can mount them with "smbmount //server/share /mountpoint" just fine. The problem seems to just lie with gvfs so "traditional" access is unaffected. What version is the samba server you are connecting to? So far the thing in common is the server being 2.2.8*. You can find out by doing: "smbclient -N //server/share". Also, if you type "ls" at the smb prompt after the last command are the filenames returned missing the last letter?

Michiel Toneman (michiel-kopz) wrote :

Hi Robert,

I have the same problem accessing my FSG 3. I can confirm that the smbclient "ls" command has the same problem (I guess you can guess the directory names)

-------------------------------------------------------------------
$ smbclient //FSG/backup
Enter password:
Domain=[MSHOME] OS=[Unix] Server=[Samba 2.2.12]
smb: \> ls
                                      D 0 Wed Apr 11 22:47:59 2007
  . D 0 Sat Dec 29 22:48:07 2007
  Musi D 0 Sat Jan 27 21:47:39 2007
  Image D 0 Sun Oct 26 15:59:03 2008
  Vide D 0 Sun Apr 27 23:12:43 2008
  Wallpaper D 0 Thu Apr 12 00:40:21 2007
  .DS_Stor H 12292 Sun Sep 21 15:55:53 2008

smb: \>
--------------------------------------------------------------------

emilio (emiliomaggio) wrote :

Same problem here (intrepid all updates)

emilio (emiliomaggio) wrote :

I should have added that in my case the NAS is a Bufallo Terastation Pro.

I am experiencing the missing character problem with smbclient, a known bug
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495081

Also, while with gvfs i can copy the file, smbclient does not complete the copy without returning any error (i.e. it copies only 8MB out of the 16MB of a zip file)

cosi (rg-cosiworld) wrote :

I've added the link to the Samba project and Samba's upstream bug for the missing character problem.
My Dolphin crashes with SIGABRT in Kubuntu :(

Changed in samba:
status: Unknown → In Progress
Carsten Maus (carsten-maus) wrote :

I've also the same problem. Intrepid with all patches. Mounting of smb-shares is possible (and works fine with eg. smbclient in the console), but nautilus does not show anything of the content of a share.

Is anyone here willing to have a go at compiling samba with that smbclient patch (see the debian bug)? I might do it if I can't find a new deb with it in.

Changed in gvfs:
assignee: desktop-bugs → nobody
oombas (oombas) wrote :

Very glad to have found this thread.
Just upgraded from 8.04 to 8.10 the other day, for the sake of creating a bootable USB stick.
My NAS, a Buffalo Terastation is there, no filenames.
I then mounted my drive with the earlier mentioned method and found the last character in the filenames missing.

bas@bas-desktop:~$ gvfs-mount smb://hd-htgl947/terastation
bas@bas-desktop:~$ smbclient -N //192.168.1.37/Terastation
Domain=[MYNAS] OS=[Unix] Server=[Samba 2.2.8a-ja-1.1]
smb: \> ls
                                      D 0 Mon Nov 10 17:00:12 2008
  . D 0 Mon Oct 30 16:52:55 2006
  11se D 0 Fri May 30 16:30:59 2008
  vmdisk D 0 Fri Jul 18 14:47:59 2008
  appl D 0 Mon Oct 30 17:12:21 2006
  armada_v30 D 0 Thu Dec 20 23:50:57 2007
  audi D 0 Sat Jul 19 13:49:40 2008

(11se should be 11sep, etc.)

What I could do however, was using OpenOffice.org and edit and save 'recent documents' on my NAS, without problems.
Recompiled my VMware 6.5 and in my Windows VM's, everything works fine, including my networkdrive.
Could not open my RedHat 7.3 VM because of a 'serious error because of a retrieved NFS file handle'.
Will look afterwards into this.
So I decided to just wait for the Samba bugfix.
A bit sad to say that creating the 8.10 bootable USB stick failed, creating looked good and the logo appears, but it won't boot.
In this case, upgrading feels a bit like downgrading.
Thanks for all the useful hints.

I compiled samba with the patch from the samba bug tracker.
I installed the new smbclient deb and smbclient ls's on my 2.2.8 server worked properly as they should (no last letter missing). Then I installed the new libsmbclient deb (what gvfs-smb uses) and now the shares work properly in nautilus.

I'm attaching just the libsmbclient deb I made, no guarantees on it as I'm no expert in this field (nor really having any prior knowledge before today). But if you're like me and regretting upgrading and not having anyhope of a fix anytime soon then maybe it will help you out. I didn't change the version number or anything like that so you will have to "reinstall" the new deb. May need to logout or do "sudo /etc/init.d/samba restart" or whatever.

If you need the fixed smbclient deb for some reason then just ask.

FuseSMB is still flakey/broken for me, I switched to smbnetfs (and I like it better) and it is working but I have still had it crash a bit (fuse bug?).

To any devs: This patch seems to fix the original problem, would be awesome to have it in ubuntu sooner rather than waiting for it to come down from upstream.

Michiel Toneman (michiel-kopz) wrote :

I can confirm that Robert's patched libsmbclient solves the problem for me (Connecting to a Freecom FSG-3).

I didn't need to reboot/log out, after reinstalling libsmbclient with the downloaded package, it "Just Worked" (TM).

Thanks Robert!

oombas (oombas) wrote :

The same applies for me, (connecting to a Terastation).
Thanks to Robert en hurray for Open Source!

OB

Chris C. (chris-c64) wrote :

Same here, Multiple 8.10 machines, upgrade and fresh install. Not showing any files in Nautilus and smbclient from a console chops off letters listing the files.

Connecting to an NSLU2 running OpenWRT firmware (Samba 2.0.10-security-rollup) I cant see files.

Odd thing was that running the standard Linksys firmware on the NSLU2 I did not have these issues connecting to it from an 8.10 machine. Files listed correctly with both smbclient and Nautilus. So at first I was afraid it was just the OpenWRT, but sounds like it might be a bug with 8.10 and certian versions of samba? Guessing Linksys was just using a version of samba in there firmware as well.

Thanks.

Michael Devenish (mdevenish) wrote :

Robert's patched libsmbclient works for me as well (buffalo linkstation). I didn't need to reboot.

Thanks Robert!

Kokodhem (kokodhem) wrote :

omg Robert, you are a lifesaver! Thank you!

I had cobbled something together to force the servers to mount as a media drive anyway, but I prefer to not always have them mounted (limited number of access points for our Windows users) and I also prefer Samba to work correctly rather than have to hack the sys to make it happen. =j

euda (eiichirou) wrote :

I also applied the patch above. It works out nicely.
I am looking for fixed gvfs component from Ubuntu official repository.
Thanks.

Thierry Carrez (ttx) on 2008-11-17
Changed in samba:
importance: Low → Medium

Debdiff for jaunty

samba (2:3.2.4-1ubuntu2) jaunty; urgency=low

  * debian/patches/last-char-truncation.patch: Fix compatibility issue with
    NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

Thierry Carrez (ttx) wrote :

Debdiff for potential intrepid SRU

samba (2:3.2.3-1ubuntu3.1) intrepid-proposed; urgency=low

 * debian/patches/last-char-truncation.patch: Fix compatibility issue with
    NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

Thierry Carrez (ttx) wrote :

Updated samba package for Intrepid is available for testing from my PPA :
https://launchpad.net/~tcarrez/+archive

Chuck Short (zulcss) wrote :

Samba 3.2.3 introduced a bug which makes it incompatible with older versions of Samba and some NAS devices.

Steps to Reproduce

See above.

I have attached the patch which fixes this issue.

Regards
chuck

Chuck Short (zulcss) wrote :

Quoting Thierry Carrez (<email address hidden>):
> Debdiff for potential intrepid SRU
>
> samba (2:3.2.3-1ubuntu3.1) intrepid-proposed; urgency=low
>
> * debian/patches/last-char-truncation.patch: Fix compatibility issue with
> NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

Was this submitted upstream (upstream being Debian or real upstream)?

Thierry Carrez (ttx) wrote :

Christian:
This patch was extracted from upstream Bugzilla bug [1] which was found referenced in the corresponding Debian bug [2]. So yes, this is already submitted both upstream and in Debian.

[1] https://bugzilla.samba.org/show_bug.cgi?id=5826
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495081

On Tue, Nov 18, 2008 at 07:43:40AM +0100, Christian Perrier wrote:
> Quoting Thierry Carrez (<email address hidden>):
> > Debdiff for potential intrepid SRU

> > samba (2:3.2.3-1ubuntu3.1) intrepid-proposed; urgency=low

> > * debian/patches/last-char-truncation.patch: Fix compatibility issue with
> > NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

> Was this submitted upstream (upstream being Debian or real upstream)?

According to the patch file, it was cherry-picked from upstream.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Quoting Thierry Carrez (<email address hidden>):
> Christian:
> This patch was extracted from upstream Bugzilla bug [1] which was found referenced in the corresponding Debian bug [2]. So yes, this is already submitted both upstream and in Debian.
>
> [1] https://bugzilla.samba.org/show_bug.cgi?id=5826
> [2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495081

Hmm, OK, sorry for re-asking.

Steve, that seems to be a good candidate for 3.2.4-2, what do you think?

Looks indeed like a good candidate; issue seems to be resolved after installing
http://launchpadlibrarian.net/19559308/libsmbclient_3.2.3-1ubuntu3_i386.deb

Thierry Carrez (ttx) wrote :

Please confirm that the packages in my PPA fix the issue, rather than the one from Robert ?
It's theorically containing the same fix, but we need the source changes to upload it (rather than a .deb).

Add "deb http://ppa.launchpad.net/tcarrez/ubuntu intrepid main" to /etc/apt/sources.list
Then "sudo apt-get update && sudo apt-get upgrade"
Confirm that you are testing 3.2.3-1ubuntu3.1~ppa1

You can also download debs directly at https://launchpad.net/~tcarrez/+archive
Thanks,

Thierry Carrez wrote:
> Please confirm that the packages in my PPA fix the issue, rather than the one from Robert ?
> It's theorically containing the same fix, but we need the source changes to upload it (rather than a .deb).
>
> Add "deb http://ppa.launchpad.net/tcarrez/ubuntu intrepid main" to /etc/apt/sources.list
> Then "sudo apt-get update && sudo apt-get upgrade"
> Confirm that you are testing 3.2.3-1ubuntu3.1~ppa1
>
> You can also download debs directly at https://launchpad.net/~tcarrez/+archive
> Thanks,
>
>
I used
http://launchpadlibrarian.net/19559308/libsmbclient_3.2.3-1ubuntu3_i386.deb
<http://launchpadlibrarian.net/19559308/libsmbclient_3.2.3-1ubuntu3_i386.deb>

I didn't know what to do with the .debdiff file & I didn't have the time
to work it out (I had to get to work) - probably real simple.

the libsmbclient_3.2.3-1ubuntu3_i386.deb
<http://launchpadlibrarian.net/19559308/libsmbclient_3.2.3-1ubuntu3_i386.deb>
worked with just a double click.

Cheers

Gerard

Ian Booth (eyebeear) wrote :

Quoting Thierry Carrez:
>Add "deb http://ppa.launchpad.net/tcarrez/ubuntu intrepid main" to /etc/apt/sources.list
>Then "sudo apt-get update && sudo apt-get upgrade"
>Confirm that you are testing 3.2.3-1ubuntu3.1~ppa1

This seems to be working for me. Can now access shares on my Buffalo Linkstation!

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in samba:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Please fix this in Jaunty ASAP.

Changed in samba:
assignee: nobody → tcarrez
status: Confirmed → In Progress

The packages from Thierry Carrez work for me. Will from proposed as soon as they show up.

Thierry Carrez (ttx) wrote :

Debdiff for Jaunty is at https://bugs.launchpad.net/ubuntu/+source/samba/+bug/282298/comments/39
Subscribing main sponsors.

Changed in samba:
assignee: tcarrez → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.2.4-1ubuntu2

---------------
samba (2:3.2.4-1ubuntu2) jaunty; urgency=low

  * debian/patches/last-char-truncation.patch: Fix compatibility issue with
    NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

 -- Thierry Carrez <email address hidden> Mon, 17 Nov 2008 16:17:26 +0000

Changed in samba:
status: Confirmed → Fix Released
Ian Davis (nospam-iandavis) wrote :

Got this update today and it all works now. Thanks to everyone who worked on this bug.

Nicolas (nicolas-homenico) wrote :

libsmbclient 2:3.2.3-1ubuntu3.1 from the intrepid-proposed repository work with unsecured share (without access-control) of my NAS (D-Link DSM-G6OO, samba 2.2.8a).
But when i try to access to a secured share gvfs-mount failed (
Error mounting location).
With smbclient :
nicolas@nicolas-laptop:~$ smbclient -U nicolas //192.168.1.5/HDD_a
Enter nicolas's password:
Domain=[TUXLAND] OS=[Unix] Server=[Samba 2.2.8a]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: SUCCESS - 0

Nicolas (nicolas-homenico) wrote :

Sorry, it's work very well afteri add this line in the [gobal] section of the /etc/samba/smb.conf file :
client lanman auth = yes

Kai Blin (kai.blin) wrote :

Yes, that's because Samba disabled the old, insecure "lanman auth" authentication scheme per default a couple of versions back. As you said, it's easy to turn on from the config file. :)

vronp (dougjames) wrote :

Folks,

It still does NOT work here with a Buffalo Terastation.

I updated both libsmbclient and smbclient through intrepid proposed but I still cannot see any files on my NAS.

oombas (oombas) wrote :

Strange!
I also have a Terastation, it works fine now.
Read back earlier messages and apply the fix, compiled by Robert.
It worked for me within one minute:
http://launchpadlibrarian.net/19559308/libsmbclient_3.2.3-1ubuntu3_i386.deb
Didn't look into any further, no time and no need.

Good luck
OB

2008/11/23 vronp <email address hidden>

> Folks,
>
> It still does NOT work here with a Buffalo Terastation.
>
> I updated both libsmbclient and smbclient through intrepid proposed but
> I still cannot see any files on my NAS.
>
> --
> [SRU] Intrepid: No Access to NAS (samba<=2.2.x) shares any more
> https://bugs.launchpad.net/bugs/282298
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Samba: In Progress
> Status in "samba" source package in Ubuntu: Fix Released
> Status in samba in Ubuntu Intrepid: Fix Committed
> Status in samba in Ubuntu Jaunty: Fix Released
>
> Bug description:
> Binary package hint: nautilus
>
> I use Ubuntu 8.10 Intrepid Beta 64-bit
>
> Versions:
> samba: 2:3.2.3-1ubuntu3
> nautilus: 1:2.24.0-0ubuntu2
>
> Network attached storage: Longshine (smb and ftp)
>
> The following connections work: (with nautilus window)
>
> hardy <--> nas
> hardy <--> intrepid
> (intrepid <--> intrepid)
>
> this works not:
>
> intrepid <--> nas
>
> When I try to open my network drive in nautilus I see the folder that my
> files are in but when I click the folder they are empty.
>
> I tried the shell:
>
> ***********************************
> thomas@thomas-hp-pav:~$ smbclient -N -L //192.168.2.6
> Anonymous login successful
> Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.2.8a]
>
> Sharename Type Comment
> --------- ---- -------
> Share Disk Share to All
> WEB Disk WEB
> Backup Disk Backup
> HPOSBkup Disk HPOSBkup
> IPC$ IPC IPC Service ()
> ADMIN$ IPC IPC Service ()
> read_socket_with_timeout: timeout read. read error = Connection reset by
> peer.
> Receiving SMB: Server stopped responding
> session request to 192.168.2.6 failed (Read error: Connection reset by
> peer)
> Anonymous login successful
> Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.2.8a]
>
> Server Comment
> --------- -------
> I-DRIVE
> THOMAS-DESKTOP thomas-desktop server (Samba, Ubuntu)
> THOMAS-HP-PAV thomas-hp-pav server (Samba, Ubuntu)
>
> Workgroup Master
> --------- -------
> WORKGROUP I-DRIVE
>
> ***************************************
>
> In Ftp-mode everything works well.
>
> Any ideas?
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package samba - 2:3.2.3-1ubuntu3.1

---------------
samba (2:3.2.3-1ubuntu3.1) intrepid-proposed; urgency=low

  * debian/patches/last-char-truncation.patch: Fix compatibility issue with
    NAS boxes still using Samba 2.2 or before (fixes LP: #282298)

 -- Thierry Carrez <email address hidden> Mon, 17 Nov 2008 17:04:35 +0100

Changed in samba:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to intrepid-updates.

cosbear (cosbear) wrote :

I have added the repo for the fix to my sources and downloaded and installed all the updates but still cannot access any samba shares on Ubuntu 8.10, Xubuntu 8.10 or the Mint based on 8.10, on both the 32 and 64 bit versions. This includes Xubuntu 8.04 installs which I upgraded to 8.10. They had access to all shares before but not after the upgrade. Nothing else has changed on my lan as concerns hardware or settings. The only change was the upgrades. The installs I have of Xubuntu 8.04 still can access all my samba shares from boxes running XP and from linux boxes running samba. The Klikit-linux RC3 based on Kubuntu Hardy can also access all the shares. I can see the other samba shares with 8.10 installs, I just cannot access them at all. I have simple sharing set up on all the boxes on my lan, and have never used any passwords or users. I have several boxes set up in my office and 1 in my living room. They are connected with wired ethernet together with two gigabit network switches one of which is connected to a wireless router connected to a cable modem. All use manually set dedicated IP addresses. I have tried using DHCP as well but no change. The workgroup on all shares is set to workgroup.

The problem is not in samba from what I can tell as all shares can access shares on the 8.10 boxes with read/write permissions. The problem appears to be in smbclient or it's dependencies. I have read some conjecture in various places about the problem being with this or that file manager, but I have the same problem with dolphin, konqueror, and nautilus. Nautilus gives this error:

Sorry, could not display all the contents of "Windows shares on mediaserver": DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

If there is not a fix of some sort soon I'm giving up on 8.10 and going back to 8.04 which works perfectly for me. I hate to do it though because otherwise I really like 8.10. I'm really at wits end with this issue. Later... cos

Kai Blin (kai.blin) wrote :

I have to admit that the Nautilus error is all but helpful. Could you try with smbclient as described by the initial reporter and check if that works or give the error output from smbclient?

cosbear (cosbear) wrote :

Well I'm not sure how to try it as the initial reporter as I don't have a network drive, just computers. I am not sure how to get the error output from smbclient. I have found a work around that works fairly well though. In Xbuutu using konqueror I changed the address bar to a normal one for inputing addresses. If I put in for example smb:/192.168.1.10/ it will bring up the machine at that address, all the shares on that machine are now showing in the window and can be opened graphically now and work as usual. Since all my machines have set addresses I just bookmarked the address for each machine. So now it works fine, using that method of access. Sorry I can't be of more help with whatever issue is causing all of this. If you send me a command, or where to look for the smbclient error output I would be glad to see what I can do. I'm kind of new to Linux and neither networking or the cli are my strong points. Later... cos

Grobot (grobottom) wrote :

Hi
 I have read through this bug with some interest and tried to add the libsmbclient suggested above and was told a newer version was already installed...
I have a similar problem as reported initially and a real Linux Noob.. I was hoping the patch downloaded today would fix things but no joy..

gary@gary-laptop:~$ smbclient -V
Version 3.2.3
My proceedings are as follows in a shell

gary@gary-laptop:~$ smbclient //NASSTORE/PUBLIC -W SHAZ -U gary
Enter gary's password:
Domain=[ȇ] OS=[] Server=[���]
smb: \> ls
cli_list_new: Error: unable to parse name from info level 1
Segmentation fault
gary@gary-laptop:~$

the system logs this
Jan 6 21:58:53 gary-laptop kernel: [ 3969.498048] smbclient[6183]: segfault at 0 ip b7ad42c3 sp bfed5f3c error 4 in libc-2.8.90.so[b7a5d000+158000]

I can mkdir and cd etc but no access to file listings.
Nautilus just re-directs itself to my home page.

my NAS is a NexStarLX with the latest firmware Version installed which is like dated 2006-10-9 which doesnt really fill me with much warmth but I do knw this drive did work with a previous debian installation I had. not sure of the version. Funny old thing is the Solaris installation I tried also failed to access the NAS. (I have been trying out versions untill I found one I like.) (Ubuntu 8.10 seems to be the winner bar this samba problem :( )

I havent tried the gvs stuff yet.. but will ry and pick through it.
Happy New year to you all.
Gary..

Grobot (grobottom) wrote :

further to above

gary@gary-laptop:~$ gvfs-mount smb://nasstore/public/
gary@gary-laptop:~$ gvfs-ls smb://nasstore/public/
Error: The specified location is not mounted
(same error in logs
Jan 6 22:21:36 gary-laptop kernel: [ 5332.697311] gvfsd-smb[6362]: segfault at 0 ip b78762c3 sp b72f0c9c error 4 in libc-2.8.90.so[b77ff000+158000]
)

gary@gary-laptop:~$ gvfs-ls smb://nasstore/
Music
Films
Pictures
Downloads
PUBLIC
gary@gary-laptop:~$ gvfs-ls smb://nasstore/Music
Error: The specified location is not mounted
gary@gary-laptop:~$ gvfs-ls smb://nasstore/Music/
Error: The specified location is not mounted
gary@gary-laptop:~$ gvfs-ls smb://nasstore/
Music
Films
Pictures
Downloads
PUBLIC
gary@gary-laptop:~$ gvfs-ls smb://nasstore/Films
Error: The specified location is not mounted
gary@gary-laptop:~$

Kai Blin (kai.blin) wrote :

Grobot, your smbclient problem is fixed with the fix to bug #264943.

Changed in samba:
status: In Progress → Fix Released
Changed in samba:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.