Comment 3 for bug 665199

herrold (herrold) wrote :

something wrong here -- possibly a yoper'ness ?

[herrold@python26-32 rpm5]$ rpm -Uvh rpm-5.2.2-5.src.rpm
error: Failed dependencies:
        g++ is needed by rpm-5.2.2-5.i686
        linux-libc-headers is needed by rpm-5.2.2-5.i686
        automake is needed by rpm-5.2.2-5.i686
        perl-devel >= 5.12.1 is needed by rpm-5.2.2-5.i686
        python-devel >= 2.7 is needed by rpm-5.2.2-5.i686
        popt-devel >= 1.16 is needed by rpm-5.2.2-5.i686
        elfutils-devel >= 0.148 is needed by rpm-5.2.2-5.i686
        libxml2-devel >= 2.7.7 is needed by rpm-5.2.2-5.i686
        file-devel is needed by rpm-5.2.2-5.i686
        keyutils-devel >= 1.4 is needed by rpm-5.2.2-5.i686
        lua-devel is needed by rpm-5.2.2-5.i686
        beecrypt-devel is needed by rpm-5.2.2-5.i686
        rpm = 4.4.2.3-20.el5_5.1 is needed by (installed) rpm-libs-4.4.2.3-20.el5_5.1.i386
        rpm = 4.4.2.3-20.el5_5.1 is needed by (installed) rpm-python-4.4.2.3-20.el5_5.1.i386
        rpm = 4.4.2.3-20.el5_5.1 is needed by (installed) rpm-build-4.4.2.3-20.el5_5.1.i386
        /bin/rpm is needed by (installed) policycoreutils-1.33.12-14.8.el5.i386
[herrold@python26-32 rpm5]$

SRPMs should not Require much at all to unpack