RPM

RFE: --whatneeds feature missing

Bug #638630 reported by Jeff Johnson on 2010-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
RPM
Medium
Unassigned
Fedora
Invalid
Medium

Bug Description

tracker

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030630 Galeon/1.3.8

Description of problem:
[19:09] <estr4ng3d> "rpm -q --whatrequires xyz-package" says that no
package requires xyz. However, "rpm -e the-same-xyz-package" will
refuse to execute, reporting one or more package names as needing xyz.
What gives?
[19:10] jbj: -estr4ng3d: rpm -q --whatrequires `rpm -q --provides
xyz-package` is conceptually what you want
[19:11] <jbj> i.e. dependency relations are more complicated than
package dependencies, there are sonames, file paths, virtual provides,
more within the xyz-package container
[19:11] <jbj> rpm -q --provides --qf '%{name}'
[19:12] <jbj> is almost exatclt how to extract the tokens that are
used for dependency relations (there are still some details regarding
versioning that need some sdjustment)

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1.n/a
2.n/a
3.n/a

Additional info:

*** Bug 84176 has been marked as a duplicate of this bug. ***

this being a more recent report, should this not have been marked as a
duplicate of Bug 84176 and not the other way around ?

*** Bug 156903 has been marked as a duplicate of this bug. ***

User <email address hidden>'s account has been closed

Reassigning to owner after bugzilla made a mess, sorry about the noise...

https://bugzilla.redhat.com/show_bug.cgi?id=84176 should still, having been the
first recorded instance of this report, been the controlling instance -- the
above recorded IRC conversation could merely be tacked onto the end of it as
continuing contribution to the description of 84176, whereas this report has
recieved _no further response_.

There are many ancient bugs in need of response and action, working through them
is slow business :-/

This happens to be an old "favorite" of mine, having to resort to tricks like
$ rpm --provides -q vte | xargs rpm --whatrequires -q | grep -v no\ package | uniq

..seems silly as rpm is perfectly capable of doing a proper job. One way to do
fully depsolved "whatneeds" is
$ rpm -e --test vte 2>&1|awk '{print $NF}'|uniq

...but that's still heavily in the ugly tricks department. OTOH these days you
can do this with repoquery (from yum-utils) too:
$ repoquery --pkgnarrow=installed --whatrequires --alldeps vte

That's still much more typing than one would hope though...

indeed. Well, as long as you're keeping Bug 84176 in consideration when you get
to where you can follow up on this. The workaround suggestions you made above
will help in the meantime though, at least for reference purposes.

triaged

And <email address hidden>.

A popt alias that looks like
    rpm alias --whatneeds --queryformat '[%{whatneeds}\n]'
is all that remains to be added.

*** Bug 475882 has been marked as a duplicate of this bug. ***

FWIW, in the next @rpm5.org release, 5.1.7, that it will be released shortly, the functionality --whatneeds, --needwhats will be included.

Jeff Johnson (n3npq) on 2010-09-15
tags: added: fedora query

(In reply to comment #11)
> And <email address hidden>.
>
> A popt alias that looks like
> rpm alias --whatneeds --queryformat '[%{whatneeds}\n]'
> is all that remains to be added.

Implemented also in

5.1.0 -> 5.2a0

devzero2000 (pinto-elia) on 2010-09-15
Changed in rpm:
status: New → Fix Released
importance: Undecided → Medium
milestone: none → 5.1.10
devzero2000 (pinto-elia) wrote :

Implemented in 5.1.7.

This package has changed ownership in the Fedora Package Database. Reassigning to the new owner of this component.

As for why closing the older bug as dupe, see https://bugzilla.redhat.com/show_bug.cgi?id=1393704#c3. Helps clearing out over a decades worth of historical babbage of bugzilla administrativia, owner changes and whatnot.

So if you want to complain, complain here. But lets keep the new bug tidy please :)

*** This bug has been marked as a duplicate of bug 1393704 ***

Changed in fedora:
importance: Unknown → Medium
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.