Tracks synced to iphone won't play

Bug #659244 reported by AlexFarran on 2010-10-12
148
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
High
rhythmbox (Ubuntu)
Low
Unassigned
Maverick
Low
Didier Roche

Bug Description

Uploaded to -proposed:
rhythmbox (0.13.1-0ubuntu6) maverick-proposed; urgency=low

  * debian/patches/92_git_add_hardcoded_extensions_for_common_media_types.patch:
    backport from upstream, add a fallback system to rename files accordingly to
    what the device is expecting even if the right encoder isn't installed
    (LP: #659244)

Test case:
1. install the version from -proposed
2. try to copy a podcast to your iphone/ipod/other device where you encounter this bug from rhythmbox
3. check that you can now play it from it

--------------

I'm using rhythmbox to copy podcasts to my iphone. The tracks appear to copy correctly and if I play them through rhythmbox they play OK. When I try to play them on the iphone they end as soon as they start.

I've just upgraded from 10.04 to 10.10. I did not have this problem in 10.04.
---
Architecture: i386
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
Package: libgstreamer0.10-0 0.10.30-1build2
PackageArchitecture: i386
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: ubuntu-une maverick
Uname: Linux 2.6.35-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Nitesh Mistry (mistrynitesh) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 659244

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → rhythmbox (Ubuntu)
Changed in rhythmbox (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated
tags: added: regression-release
tags: added: hw-specific
Changed in rhythmbox (Ubuntu):
status: Incomplete → New
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Jonathan Brown (jcb900) on 2010-10-20
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
status: Confirmed → New
Konstantin (konstantin-shkut) wrote :

Tracks synced to android device (Samsun Vibrant) won't play too. Rhythmbox upload files to device without extension. After upload all files looks like "some filename" but not a "some filename.mp3". But sometimes files with ".ogg" extension syncs just fine with extension.

Changed in rhythmbox (Ubuntu):
status: New → Confirmed
PetterKatt (petterkatt) wrote :

Same problem on x64 Ubuntu 10.10

Same problem here. With Amarok I can sync and play tracks in Ipod normally. Tracks added before upgrade to maverick plays too.

PetterKatt (petterkatt) wrote :

more likely a problem with libmobiledevice or whatever lib is used to communicate with smartphones.

olivier Rinaudo (orinaudo) wrote :

config: latest 10.10 amd64 as of today+ppa pa.launchpad.net/pmcenery/ppa/
iphone 3GS iOS4.1
rhythmbox re-installed

-no issue with gtkpod : songs are synced with .mp3 extension and then can be played
-with same song in rhythmbox file is synced on iphone *without* the mp3 at the end
only the final dot is here. song can't be played from the iphone but start from rhythmbox

by directly renaming the file on the iphone adding proper extension, it then run ok

Luca Ferretti (elle.uca) wrote :

I haven't seen this bug before opening another one about this issue. Maybe you could collect more info from Rhythmbox log while transferring tracks to iPod. A simple copy and paste from terminal is here
https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/668336/comments/2

alexutz (alex-nicolescu) wrote :

Same here with ubuntu 10.10 64bit, preinstalled rhythmbox and iphone 3GS with iOS 3.1.3.

Tristan (talinnell) wrote :

Same here with iPod Classic and Rhythmbox. Tracks work OK when gtkpod is used to copy them. Never had this issue on 10.04, and also this was working fine on 10.10 until one of the recent updates, although I can't remember which or when.

Derek0207 (derek0207) wrote :

Same problem; ipod nano, ubuntu 10.10 updated today

I ran rhythm box form the console, transferred some music to the ipod and then right-clicked eject. The messages below came on the console. Not sure if its a problem or not......

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(rhythmbox:2857): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
^A

Derek,

Were you able to play the music you transferred to ipod? If you were
able to play the music and have this error only on ejecting then you
should probably open another bug report.

Thanks.

On Mon, Nov 1, 2010 at 2:42 AM, Nitesh Mistry <email address hidden> wrote:
> Derek,
>
> Were you able to play the music you transferred to ipod? If you were
> able to play the music and have this error only on ejecting then you
> should probably open another bug report.
>
> Thanks.
>
> --
> Tracks synced to iphone won't play
> https://bugs.launchpad.net/bugs/659244
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (658085).
>

I guess the problem is at Rhythmbox. I could listen to songs uploaded
to my iPod touch 3g using banshee media player without problem...

--
Lucas Nogueira

sirjoebob (sirjoebob) wrote :

Syncing Rhythmbox to my Android phone fails as well. Files do not recognize as media on my device. Possible file corruption?

Markus Korn (thekorn) wrote :

This bug has already been fixed upstream, see the upstream bug for further details.
Also, the fix has been released in rhythmbox 0.13.2, see http://ftp.acc.umu.se/pub/gnome/sources/rhythmbox/0.13/rhythmbox-0.13.2.news

Sebastien Bacher (seb128) wrote :

Didier, do you think you could backport that commit?

Changed in rhythmbox (Ubuntu):
status: Confirmed → Fix Committed
Changed in rhythmbox (Ubuntu Maverick):
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :
description: updated
Changed in rhythmbox:
importance: Unknown → High
status: Unknown → Fix Released
tags: added: patch
Luca Ferretti (elle.uca) wrote :

Didier, I can't find any rhythmbox 0.13.1-0ubuntu6 in proposed...

Didier Roche (didrocks) wrote :

That's normal, archives are frozen right now in -proposed. You will see a message there once it is accepted.

Accepted rhythmbox into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in rhythmbox (Ubuntu Maverick):
status: Confirmed → Fix Committed
tags: added: verification-needed
Dale Moore (ariakkas10) wrote :

It's now working for me, was able to transfer songs to my jailbroken iphone 3gs with 3.1.2 firmware.

excellent work guys, thanks a bunch!

tags: added: verification-done
removed: verification-needed
Michael (schmid-michl) wrote :

When is the fix going to be in the official repositories?

Michael (schmid-michl) wrote :

Sorry, got it from -proposed.

Fix doesn't work for me. (Ipod 5.Gen Nano)

Rythmbox shows the Song/Podcast on my Ipod but the Ipod still says 0 Tracks.
Do I have to submit a new Bug report?

Didier Roche (didrocks) wrote :

Michael: I think you should opened a separate bug report stating that on other device you still have that issue.

Luca Ferretti (elle.uca) wrote :

Michael: the issue was rhythmbox related (i.e. not related to libraries actually performing the sync), check using gtkpod or bashee

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.13.1-0ubuntu6

---------------
rhythmbox (0.13.1-0ubuntu6) maverick-proposed; urgency=low

  * debian/patches/92_git_add_hardcoded_extensions_for_common_media_types.patch:
    backport from upstream, add a fallback system to rename files accordingly to
    what the device is expecting even if the right encoder isn't installed
    (LP: #659244)
 -- Didier Roche <email address hidden> Tue, 02 Nov 2010 13:05:02 +0100

Changed in rhythmbox (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to natty as well.

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.