Rhythmbox should never start minimised to tray

Bug #270206 reported by David Prieto on 2008-09-14
190
This bug affects 39 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Rhythmbox
Fix Released
Medium
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

I have noticed that RB remembers whether it was minimised to tray when it closed, and starts in the same state. Some users might find that confusing, however. My mother does actually, sometimes she opens RB to listen to her music and she doesn't realise that small white square on the notification area, so she thinks the program didn't start properly.

I think RB should NEVER start minimised to tray, unless it's specified through a command option.

Pedro Villavicencio (pedro) wrote :

thanks for the report, that's known upstream you can read about it here: http://bugzilla.gnome.org/show_bug.cgi?id=537868

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in rhythmbox:
status: Unknown → New
mercutio22 (macabro22) wrote :

No one dare come say its a feature!

Adam Niedling (krychek) wrote :

Still an issue in Karmic and it's very annoying.

Adam Niedling (krychek) wrote :

Starting rhythmbox minimized does not make any sense since it does not play anything without human intervention.

Changed in hundredpapercuts:
status: New → Confirmed
MathUHenry (mathuhenry) wrote :

I really like it this way and would not want to see it changed. By starting minimized, it's always ready to play from a button on my remote, but never gets in the way - super convenient.

Glad it works for you, but I'd say a majority of users don't have a remote control.

Adam Niedling (krychek) wrote :

So make it configurable.

Vish (vish) on 2010-03-23
Changed in hundredpapercuts:
importance: Undecided → Low
status: Confirmed → Triaged

This is really dire if you happen not to have Notification Area on your panel. You start rhythmbox (e.g. from Main Menu or Alt+F2) and apparently nothing happens at all -- there's no indication that the app has started. I've been living with this annoying behaviour for a few months. I think it's the cause of this guy's problems too: http://bugs.debian.org/504936.

A workaround is to open gconf-editor and edit the gumph in /apps/rhythmbox/plugins/status-icon/ (hint found in this thread: http://www.uluga.ubuntuforums.org/showthread.php?p=8571328). Try unticking 'active'.

Perhaps there's a bug in the 'remember if minimised to tray' code: in my case it seems to remember it was minimised to tray on exit even though I don't have a tray to minimise to.

Vish (vish) on 2010-06-10
Changed in hundredpapercuts:
milestone: none → maverick-round-6-sound+video
John Macdonald (jxtreme42) wrote :

I can see why this is annoying to some people, but it is helpful to me. I have Rhythmbox set to run on startup so that when I want to listen to my music (almost every time I use the computer), I just press the play button on my keyboard and seek through it with the appropriate media buttons on my keyboard. I would like the opening in the tray to be an option not enabled by default.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.8git20100616-0ubuntu2

---------------
rhythmbox (0.12.8git20100616-0ubuntu2) maverick; urgency=low

  * debian/patches/04_no_hide_on_startup.patch:
    - Always show main window on startup (LP: #270206)
 -- Robert Ancell <email address hidden> Mon, 21 Jun 2010 14:34:05 +1000

Changed in rhythmbox (Ubuntu):
status: Triaged → Fix Released
Vish (vish) on 2010-06-21
Changed in hundredpapercuts:
status: Triaged → Fix Released

I confirm, it's fixed good job ^^

Changed in rhythmbox:
status: New → Fix Released
Martijn Bastiaan (hmb1) wrote :

There are two types of users here:

 1. Those who start it with autostart and expect Rhythmbox to only show in the tray
 2. Those who expect Rhythmbox to be visible when started (shortcut key or menu)

I think this (https://bugzilla.gnome.org/show_bug.cgi?id=537868#c7) is a good compromise. I hope the Ubuntu developers apply this patch as I think this is the best solution.

Adam Niedling (krychek) on 2010-08-09
summary: - RB should never start minimised to tray
+ Rhythmbox should never start minimised to tray
Harm van Bakel (hvbakel) wrote :

Any chance of having this backported to Lucid?

Changed in rhythmbox:
importance: Unknown → Medium
Vancouverite (sethgilchrist) wrote :

I second a backport to Lucid. It is the LTS after all, and this bug is very annoying.

Vish (vish) wrote :

@Vancouverite , Harm van Bakel: This is could be considered a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 , 2 , 3 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

That was a feature not a bug and a very useful one especially now that rhythmbox-client --play will open and start the player
which i had been using a script for on lucid that opens the player waits for it to open then tells it to play till it does
now i have to close the window every time i login
the --hide option on rhythmbox-client does nothing nor does any option in the status plugin to re-enable it work
i have tried using devils pie on it but it minimizes it to the window list
Rhythmbox 0.13.3
Ubuntu - natty

michealPW (michealpw) wrote :

Oh my, what a bad workaround. I totaly understand that this behavior is confusing for some people and admittedly it confused my wife (Until I explained the feature and showed her how to disable it.)

This "bug" solution only creates yet another problem... Now _nobody_ can start RB minimized, including all the people who actually liked this _feature_ (It's not a bug, it's by design and many people liked this behavior.)

Couldn't we just set this feature to be disabled by default that could be if the user wanted to, rather than breaking the feature all together?

This bug's "solution" is the cause of this unanswerable question: http://askubuntu.com/questions/125224/how-do-i-hide-rhythmbox-to-just-show-a-tray-icon

Also countless other Google results if you search for "How do I start Rhythmbox minimized?" || "How do I start Rhythmbox in quiet/silent/hidden mode?"

  • unnamed Edit (2.1 KiB, text/enriched; charset=windows-1252)

I will be out of the office until 9th January, in my absense please contact Nick Tait

On 29 Nov 2012, at 19:55, michealPW <email address hidden> wrote:

> Oh my, what a bad workaround. I totaly understand that this behavior is
> confusing for some people and admittedly it confused my wife (Until I
> explained the feature and showed her how to disable it.)
>
> This "bug" solution only creates yet another problem... Now _nobody_ can
> start RB minimized, including all the people who actually liked this
> _feature_ (It's not a bug, it's by design and many people liked this
> behavior.)
>
> Couldn't we just set this feature to be disabled by default that could
> be if the user wanted to, rather than breaking the feature all together?
>
> This bug's "solution" is the cause of this unanswerable question:
> http://askubuntu.com/questions/125224/how-do-i-hide-rhythmbox-to-just-
> show-a-tray-icon
>
> Also countless other Google results if you search for "How do I start
> Rhythmbox minimized?" || "How do I start Rhythmbox in
> quiet/silent/hidden mode?"
>
> --
> You received this bug notification because you are a member of Canonical
> User Experience and Design team, which is subscribed to a duplicate bug
> report (527119).
> https://bugs.launchpad.net/bugs/270206
>
> Title:
>  Rhythmbox should never start minimised to tray
>
> Status in One Hundred Paper Cuts:
>  Fix Released
> Status in The Rhythmbox Music Management Application:
>  Fix Released
> Status in “rhythmbox” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Binary package hint: rhythmbox
>
>  I have noticed that RB remembers whether it was minimised to tray when
>  it closed, and starts in the same state. Some users might find that
>  confusing, however. My mother does actually, sometimes she opens RB to
>  listen to her music and she doesn't realise that small white square on
>  the notification area, so she thinks the program didn't start
>  properly.
>
>  I think RB should NEVER start minimised to tray, unless it's specified
>  through a command option.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/270206/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.