Sound doesn't loop smoothly anymore

Bug #647686 reported by Jo'ogn on 2010-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ren'Py
Fix Released
High
Tom Rothamel

Bug Description

While sound-loops in 6.10.2e work smoothly, there is now a small gap in 6.11.1b replay.

Esp on very short loops of less than half a second the gap slightly varies in length. From 30 to upto 120ms.

Sound example of what is supposed to be a constant phone dial tone is attached.

Win XP sp3
Dual Core 3GHz
1GB RAM

Jo'ogn (ajon) wrote :
Tom Rothamel (renpytom) wrote :

Can you try with a longer sample? There's a size below which Ren'Py can't keep up with starting and stopping the samples. (I don't think this code changed between 6.10 and 6.11, though.)

Jo'ogn (ajon) wrote :

Longer samples - e.g. way over 10 seconds - also have audible gaps in 6.11.1b.
As said, the dial tone loop worked smoothly till I 'updated' from 6.10.2e to 6.11.1.

Tom Rothamel (renpytom) wrote :

Can you attach your short dialtone sample? I've been unable to recreate it myself, but the last time we had a similar problem, it was specific to a particular sample.

Thanks for bearing with me on this.

Changed in renpy:
milestone: none → 6.11.2
importance: Undecided → High
status: New → Incomplete
assignee: nobody → renpytom (renpytom)
Jo'ogn (ajon) wrote :

I used the dial tone as an example because it loops very quickly - as opposed to much longer loops. I ran 6.10.2b next to 6.11.1 on my computer. Any looped sound has an audible gap - seemingly independent of its length in the new Renpy release. I usually run games in windowed mode. All my samples are in ogg-vorbis format.

Has 6.11.1 perhaps a different "frame rate". I do recall that there is some 'inofficial' variable for a "refresh-rate" or sth?! I understand, that one major change in 6.11 is the screen resolution independent scaling feature - might that be related?

Tom Rothamel (renpytom) wrote :

After spending some time digging through ffmpeg, I realized that the true problem was that I am a moron, and accidentally set it not to queue by default. The fix is a one-line change, the change to audio.py at:

http://bazaar.launchpad.net/~renpytom/renpy/main/revision/1264

It'll be in Ren'Py 6.11.2.

Changed in renpy:
status: Incomplete → Fix Committed
Tom Rothamel (renpytom) on 2011-02-08
Changed in renpy:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers