Please update .pot file

Bug #1317683 reported by David Planella on 2014-05-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sudoku App
High
Daniel Holbach
Ubuntu Calculator App
High
Bartosz Kosiorek
Ubuntu Calendar App
High
Mihir Soni
Ubuntu Clock App
High
Unassigned
Ubuntu File Manager App
Medium
Daniel Holbach
Ubuntu Music App
High
Victor Thompson
Ubuntu Notes app
High
David Planella
Ubuntu Shorts App
High
Joey Chan
Ubuntu Terminal App
Low
Daniel Holbach
Ubuntu Translations
Undecided
Unassigned
Ubuntu Weather App
High
Unassigned
unity8 (Ubuntu)
Undecided
Martin Pitt
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

We've got a new show coming up in June: Mobile Asia Expo, which is an event much like the past Mobile World Congress. There it will be key to not only show off core apps, but also to display their native language support, in particular for Simplified Chinese and other languages/scripts used across Asia.

In order for our translators to be able to do their work, we'll need the translatable messages to be up-to-date. This effectively means:

- Ensuring all visible messages in the app are marked for translation (i.e. enclosed in i18n.tr() calls)
- Updating the po/*.pot files as described in the README.translations or po/README.translations files
- Committing and pushing the changes to Launchpad

From then on, translators can take over :)

Related branches

David Planella (dpm) on 2014-05-08
Changed in reminders-app:
status: New → Triaged
importance: Undecided → High
tags: added: bitesize touch-cn
Changed in sudoku-app:
importance: Undecided → High
status: New → Triaged
David Planella (dpm) on 2014-05-08
Changed in ubuntu-calculator-app:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-calendar-app:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-clock-app:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-filemanager-app:
importance: Undecided → Medium
status: New → Triaged
Changed in music-app:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-rssreader-app:
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-terminal-app:
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-weather-app:
importance: Undecided → High
status: New → Triaged
Changed in music-app:
assignee: nobody → Victor Thompson (vthompson)
status: Triaged → In Progress
Victor Thompson (vthompson) wrote :

Is there currently an issue with using translations in some of the apps? For instance, I've changed my language to both French and Spanish and neither seems to change anything in the music-app. I know translations have been done for both of these languages.

Victor Thompson (vthompson) wrote :

Matter of fact, it really only seems like date strings are being translated.

Joey Chan (qqworini) wrote :

No core apps are translated to Chinese... using r302

Fix committed into lp:music-app at revision None, scheduled for release in music-app, milestone 1.0

Changed in music-app:
status: In Progress → Fix Committed
David Planella (dpm) wrote :

Victor, Joey, thanks for the heads up, I could confirm the regression in which translations are no longer loaded from click packages, and filed bug 1317772

Changed in ubuntu-calculator-app:
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in ubuntu-calculator-app:
status: Triaged → In Progress

Fix committed into lp:ubuntu-calculator-app at revision 257, scheduled for release in ubuntu-calculator-app, milestone 1.6

Changed in ubuntu-calculator-app:
status: In Progress → Fix Committed
Bartosz Kosiorek (gang65) wrote :

According to lp:1318008 the application comment and keywords should be added.
It will be good to do that before updating pot file.

Changed in ubuntu-clock-app:
assignee: nobody → Bartosz Kosiorek (gang65)
status: Triaged → In Progress
Changed in ubuntu-terminal-app:
status: Triaged → In Progress
Changed in sudoku-app:
assignee: nobody → Daniel Holbach (dholbach)
status: Triaged → In Progress
Changed in ubuntu-terminal-app:
assignee: nobody → Daniel Holbach (dholbach)
Changed in ubuntu-filemanager-app:
assignee: nobody → Daniel Holbach (dholbach)
status: Triaged → In Progress
David Planella (dpm) on 2014-05-15
Changed in reminders-app:
assignee: nobody → David Planella (dpm)
status: Triaged → In Progress
Changed in ubuntu-weather-app:
status: Triaged → Invalid
Changed in ubuntu-filemanager-app:
status: In Progress → Fix Committed

Fix committed into lp:ubuntu-filemanager-app at revision None, scheduled for release in ubuntu-filemanager-app, milestone alpha-1

David Planella (dpm) wrote :

Marking bug as Invalid for all those apps that already have an up-to-date template.

Changed in ubuntu-clock-app:
status: In Progress → Invalid

Fix committed into lp:sudoku-app at revision None, scheduled for release in sudoku-app, milestone Unknown

Changed in sudoku-app:
status: In Progress → Fix Committed

Fix committed into lp:ubuntu-terminal-app at revision None, scheduled for release in ubuntu-terminal-app, milestone alpha-1

Changed in ubuntu-terminal-app:
status: In Progress → Fix Committed
Victor Thompson (vthompson) wrote :

It might be a good idea to to block on some of the current Calendar MPs (for as long as reasonable), the various MPs that have been in the queue for a good deal of time each has an impact to the translations

Changed in ubuntu-clock-app:
assignee: Bartosz Kosiorek (gang65) → nobody

Fix committed into lp:reminders-app at revision 142, scheduled for release in reminders-app, milestone 0.4

Changed in reminders-app:
status: In Progress → Fix Committed
David Planella (dpm) on 2014-05-19
Changed in reminders-app:
status: Fix Committed → Fix Released
David Planella (dpm) on 2014-05-19
Changed in ubuntu-filemanager-app:
status: Fix Committed → Fix Released
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
Changed in music-app:
status: Fix Committed → Fix Released

Fix committed into lp:ubuntu-calendar-app at revision 288, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: Triaged → Fix Committed
Mihir Soni (mihirsoni) on 2014-06-02
Changed in ubuntu-calendar-app:
assignee: nobody → Mihir Soni (mihirsoni)
David Planella (dpm) on 2014-06-27
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released
Changed in sudoku-app:
status: Fix Committed → Fix Released
Changed in ubuntu-terminal-app:
status: Fix Committed → Fix Released
Joey Chan (qqworini) on 2014-08-05
Changed in ubuntu-rssreader-app:
assignee: nobody → Joey Chan (qqworini)
status: Triaged → In Progress

Fix committed into lp:ubuntu-rssreader-app at revision 278, scheduled for release in ubuntu-rssreader-app, milestone alpha-1

Changed in ubuntu-rssreader-app:
status: In Progress → Fix Committed
Adolfo Jayme (fitojb) wrote :

It’d be great if developers updated their POTs with every branch so that the updated strings are immediately delivered to translators. It’s a pain to be reminding devs to do this :-/

David Planella (dpm) wrote :

Indeed. I know Saviq mentioned in another MP for unity8 that he'd been looking at writing a bzr push or commit hook to prompt for a .pot update, but he's been busy with other stuff. It'd be great if someone else could pick that up.

Leo Arias (elopio) wrote :

I never realised about this before. All the system apps have a merge proposal checklist that they review before approving the branch. We can add an item to that checklist telling them to update pots if they changed the UI labels.

Thanks Leo, that'd work very well until we can get more sophisticated
automation.

On Thu, Aug 7, 2014 at 6:24 PM, Leo Arias <email address hidden> wrote:

> I never realised about this before. All the system apps have a merge
> proposal checklist that they review before approving the branch. We can
> add an item to that checklist telling them to update pots if they
> changed the UI labels.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> Matching subscriptions: File Manager App Bugmail, Ubuntu RSS Reader Bugmail
> https://bugs.launchpad.net/bugs/1317683
>
> Title:
> Please update .pot file
>
> Status in Music application for Ubuntu devices:
> Fix Released
> Status in Ubuntu Reminders app:
> Fix Released
> Status in Sudoku game for Ubuntu Touch:
> Fix Released
> Status in Calculator application for Ubuntu devices:
> Fix Released
> Status in Calendar application for Ubuntu devices:
> Fix Released
> Status in Clock application for Ubuntu devices:
> Invalid
> Status in File Manager application for Ubuntu devices:
> Fix Released
> Status in RSS Feed Reader application for Ubuntu devices:
> Fix Committed
> Status in Terminal application for Ubuntu devices:
> Fix Released
> Status in Weather application for Ubuntu devices:
> Invalid
>
> Bug description:
> We've got a new show coming up in June: Mobile Asia Expo, which is an
> event much like the past Mobile World Congress. There it will be key
> to not only show off core apps, but also to display their native
> language support, in particular for Simplified Chinese and other
> languages/scripts used across Asia.
>
> In order for our translators to be able to do their work, we'll need
> the translatable messages to be up-to-date. This effectively means:
>
> - Ensuring all visible messages in the app are marked for translation
> (i.e. enclosed in i18n.tr() calls)
> - Updating the po/*.pot files as described in the README.translations or
> po/README.translations files
> - Committing and pushing the changes to Launchpad
>
> From then on, translators can take over :)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/music-app/+bug/1317683/+subscriptions
>

Martin Pitt (pitti) wrote :

On most current devel-proposed build (178) the new "Unlock SIM" string isn't in the pot file yet, so can't be translated.

Changed in unity8:
status: New → Confirmed
Martin Pitt (pitti) on 2014-08-08
Changed in unity8:
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
tags: added: rtm14 touch
Changed in ubuntu-translations:
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.00+14.10.20140811-0ubuntu1

---------------
unity8 (8.00+14.10.20140811-0ubuntu1) utopic; urgency=low

  [ Andrea Cimitan ]
  * Add emblem support in dash cards.

  [ Michael Terry ]
  * Fix a variety of design nits with the current lockscreen: * disable
    indicators and launcher when locked * when reversing the direction
    of a greeter flick, treat it as a cancel * don't animate dots when
    changing the infographic data source * make cancelling a login
    nicer: * reduce the delay before greeter starts animating * show the
    greeter from the same side of the screen that it hid to * don't re-
    animate the infographic (LP: #1351027)

  [ Stephen M. Webb ]
  * enables the unity8 upstart job for desktop sessions (LP: #1353041)

  [ Albert Astals ]
  * Dash Overview (LP: #1317683)
  * GenericScopeView: On click only activate scope:// uris and
    clickscope items The rest of clicks result in a preview, also
    scope:// uris don't get a preview
  * Pass the scope search hint up to the search line
 -- Ubuntu daily release <email address hidden> Mon, 11 Aug 2014 19:03:41 +0000

Changed in unity8 (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.00+rtm+14.09.20140812-0ubuntu1

---------------
unity8 (8.00+rtm+14.09.20140812-0ubuntu1) 14.09; urgency=low

  [ Andrea Cimitan ]
  * trunk/r1141: Add emblem support in dash cards.

  [ Michael Terry ]
  * trunk/r1143: Fix a variety of design nits with the current
    lockscreen (LP: #1351027)

  [ Stephen M. Webb ]
  * trunk/r1145: enables the unity8 upstart job for desktop sessions
    (LP: #1354029)

  [ Albert Astals ]
  * trunk/r1140: Dash Overview (LP: #1317683)
  * trunk/r1142: GenericScopeView: On click only activate scope:// uris
    and clickscope items
  * trunk/r1144: Pass the scope search hint up to the search line
 -- Ubuntu daily release <email address hidden> Tue, 12 Aug 2014 19:51:59 +0000

Changed in unity8 (Ubuntu RTM):
status: New → Fix Released
Michał Sawicz (saviq) on 2014-08-13
Changed in unity8:
status: In Progress → Fix Released
David Planella (dpm) on 2014-09-19
Changed in ubuntu-translations:
status: Triaged → Fix Released
David Planella (dpm) on 2014-09-29
Changed in ubuntu-rssreader-app:
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers