ability to save .bib file only for the current tag

Bug #134172 reported by pliz
2
Affects Status Importance Assigned to Milestone
Referencer
Wishlist
Mads Chr. Olesen

Bug Description

This is a feature request rather than a bug.

As of now (version 1.0.4) when I decide to export as bibtex the whole collection is exported. It would be nice if I could export only the papers of the chosen tag. This seems like a very useful feature, especially in connection with the ability of one paper to be in several tags at once.

Thanks for a great tool! It shows a lot of potential!

John S (jcspray)
Changed in referencer:
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
John S (jcspray) wrote :

This is already possible, by using the "Selected Documents" option for "Selection" in the export dialog: to select all documents with a certain tag you can filter the view on that tag and quickly select everything.

Since more than one person has mentioned this I'm adding a sentence to the introduction document to clarify that it is indeed possible.

Changed in referencer:
assignee: nobody → jcspray
status: Triaged → Fix Committed
Revision history for this message
pliz (pliz) wrote :

Great! Thanks!

Revision history for this message
Christophe Dumez (hydr0g3n) wrote :

It is true that it works that way but this is not exactly the expected behavior from the user point of view. Maybe you could add a right-click popup menu on the tags with an "export as BibTeX..." entry that would export only the selected tag (without having to select all its documents). This is just an idea to make the life easier for the user (it sure would be faster).

Revision history for this message
pliz (pliz) wrote :

That is an interesting suggestion and I believe this feature would be useful for me too. I have noticed a need for something related:

Sometimes I need to just pick several particular papers from my collection from different tags. I select a tag choose papers I need with holding CTRL and then loose the selection when click on the next tag. Thus I only can choose papers visually from a single tag. I do not have a clear suggestion of GUI construct that would do what I need but just the task I sometimes have to do. May be I am not alone here and people have a way to do it?

Thanks

Changed in referencer:
status: Fix Committed → Won't Fix
status: Won't Fix → In Progress
assignee: John S (jcspray) → Mads Chr. Olesen (shiyee)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers