Comment 8 for bug 1573577

David Planella (dpm) wrote :

Thanks so much Felix for the fixes here and upstream, you rock!

I created a new release in the Qreator stable PPA. You can install it with:

sudo add-apt-repository ppa:qreator-hackers/qreator-stable
sudo apt update
sudo apt install qreator python-qrencode

I've backported your fix to pyqrencode upstream to the python-qrencode package and uploaded it to the Qreator PPA. This way both packages will be updated and Qreator will ultimately work.

The final, proper, fix is to do an SRU (Stable Release Upload) of both packages to Ubuntu 16.04, but I'll have to leave that for later. If someone wants to pick up the task of preparing an SRU for python-qrencode based on the package I uploaded to the PPA, the help will be really welcome!